Duke4.net Forums: [RELEASE] EDuke32 Addon Compilation - Duke4.net Forums

Jump to content

  • 43 Pages +
  • « First
  • 41
  • 42
  • 43
  • You cannot start a new topic
  • You cannot reply to this topic

[RELEASE] EDuke32 Addon Compilation  "Version 3.13 released on December 6, 2016!"


View PostETPC, on 05 December 2020 - 08:15 AM, said:


quick screen grab of the two problem elevators in this room in DNCM2. i'm currently standing on one, trying to make it go up. the one on the bottom left does the same thing. eduke build is r9257, i'll try with an older build in a little bit.

This has been fixed with the following commit: https://voidpoint.io...f5c773d255f3351


View PostETPC, on 07 December 2020 - 08:12 AM, said:

also, i ran through WGSpace and encountered zero showstoppers except a broken elevator in WGS4X (picture attached) and a few exit switches being finnicky to hit.

Attachment duke0007.png

View PostNightFright, on 28 February 2021 - 06:13 AM, said:


- WGSpace (WGS4X: Broken elevator)

This one is a bug in the map. It occurs in DOS Duke 3D just the same, you can reproduce this yourself with the following test map: Attached File  wgsx4_bug.zip (2.15K)
Number of downloads: 7


View PostNightFright, on 28 February 2021 - 06:13 AM, said:

- Quest for Hussein (elevator transition issue with first/last map)

Tested it, and this was also fixed, namely with the following commit: https://voidpoint.io...dc80a80ee0c5a3c

See also: https://voidpoint.io...32/-/issues/100

This post has been edited by Doom64hunter: 22 July 2021 - 06:46 AM


User is offline   Phredreeke 


More ERP compatibility updates

Compatible: lorch, mic_episode, penthouse, pinxten, prequeltime, ruohonen
Semi-compatible (need new skyboxes or skyboxes disabled): lostduke, losthighway, mathpak, metromayhem, mssp, munasta, quakis, red, roch

lastreaction needs workaround for anms, tiles 2503/3281/3293 as well as skyboxes

This bumps it up to 25 full compatible and an additional 31 mostly compatible, out of 103.


View PostAx 34noff, on 30 December 2020 - 07:54 AM, said:

A Dream Trilogy has broken ladders too

These ladders work as of r9484. You need to press and hold use on them to climb up.

View PostAx 34noff, on 30 December 2020 - 02:14 PM, said:

A bug found in Alien Extermination: flamethrower freezes facehuggers instead of burning them.

This occurs because the facehuggers replace the GREENSLIME, which is hardcoded to be frozen when hit by the FREEZEBLAST projectile. I doubt this ever worked correctly.

View PostAx 34noff, on 01 January 2021 - 07:31 AM, said:

1999 TC: a really lot of some kind of invisible bulletproof objects on The Wash map. Still playable but very annoying.

This occurs in DOS as well, and it's an issue that truly puzzles me. The problem appears to stem from the cactus sprite stored at picnum 3634, combined with the fact that the map consists of an enormous snaking sector that starts at the bus and goes all the way to the end of the map.

There are actually no invisible objects at all where the hitscan shots are blocked. It appears that the engine however thinks there is something there -- something even the original 1.5 version does. Furthermore, the cactus has no special properties -- you can dump the map and extract the tile, and it will show the exact same issue without any custom CON code.

If you split up this sector into smaller chunks and/or delete tile 3634, the problem disappears.

This post has been edited by Doom64hunter: 23 July 2021 - 11:20 AM



View PostAx 34noff, on 01 January 2021 - 09:31 AM, said:

A bug in Castle Dukenstein: dogs are very hard to kill, exactly like chickens in Redneck Rampage, except chickens can't eat you. Looks like a regression in Dukenstein or Eduke32, i played this mod before and dogs were easily killable.

Using a revision from 2012, the hitbox of these dogs is exactly the same. Should definitely possible to fix in the CON files though.

View PostAx 34noff, on 13 January 2021 - 05:26 AM, said:

Community Build Project map 3: this lock doesn't work:

Correct, it's not supposed to work. You're supposed to press use on this semi-transparent wall-aligned stripper sprite in the room on the other end of the hallway:

Attached Image: capt0001.png

The extra blue keycard you get in Sang's section only serves to confuse, and has no use. Not a bug.

View PostETPC, on 26 February 2021 - 07:53 AM, said:

playing through lost highway, and there is some visual weirdness on Toxic Gas (the third map), is this intentional? i'm running on r9310.

This bug is present in `losthw03_ror.map`, and it is a map bug, not an engine issue. The sector ceiling doesn't have pal 1 set.

What's more serious though is that in the sewer section, in `losthw03.map` the switches are entirely pitch black, rendering it basically impossible to finish the map. This is another map bug.

Attached Image: duke0003.png

In `losthw03_ror.map`, these switches are visible. I would fix the ceiling in `losthw03_ror.map` and just use that one.

View PostAx 34noff, on 19 March 2021 - 11:09 AM, said:

Layre: i stuck at E1L1. I found 5 of 6 secrets but still stuck. The map itself looks raw and unfinished, i don't even know if it's beatable.

Regarding Layre, I'm getting the following errors on startup:
Warning: Failed including duke3d.def on line scripts/layre.def:1
Sound sounds/navgate1.wav(#409) not found!
Sound sounds/navgate2.wav(#410) not found!
Sound sounds/navgate3.wav(#411) not found!
Sound sounds/navgate4.wav(#412) not found!
Sound music1.voc(#413) not found!
Sound amb2.voc(#414) not found!

I'm also constantly getting the following error in the console, which indicates that some script is trying to execute but is being aborted becaused of a missing sound:

Line 8603, soundonce: invalid sound 420 

Keep on the lookout for these error messages. Missing sounds can cause the rest of the code to stop executing. In this case, the fan actor isn't working properly.

Both maps can be completed in the most recent eduke32 revision. They are confusing and weird, but beatable. Here's some other issues I found with them:

The player can get stuck in this wall near the exit to the first map if he walks into it:

Attached Image: duke0007.png

In the second map, the following textures turn into a HOM effect if destroyed:
Attached Image: duke0010.png
Attached Image: duke0011.png

Finally, and this issue is more critical. In chapter 2, the pool in the boss area is larger than the underwater sector. If the queen walks onto the pool, it will get stuck out of bounds, rendering the player unable to finish the level:

Attached Image: duke0015.png


View PostAx 34noff, on 22 March 2021 - 02:23 PM, said:

Savior of Alien Era, second map, can't climb up here:

Not a bug, you're supposed to raise the floor first:

Attached Image: duke0021.png
Attached Image: duke0020.png

Edit 2: Map06 of savior.grp is beatable, but extremely long (1000 enemies, jesus christ). I did not encounter any softlocks.

Edit 3:

View PostAx 34noff, on 12 July 2021 - 08:47 AM, said:

Starship Troopers: at sstb1.map allies constantly shoot even though there are no enemies.

I can't reproduce this with r9484. Were you using the latest revision?

This post has been edited by Doom64hunter: 24 July 2021 - 02:02 PM


User is offline   Ax 34noff 


View PostDoom64hunter, on 24 July 2021 - 11:09 AM, said:

Not a bug, you're supposed to raise the floor first:
Attachment duke0021.png
Attachment duke0020.png

View PostAx 34noff, on 24 March 2021 - 05:04 AM, said:

In Savior of Alien Era that was my fault, i forgot to press button. Playtesting continues...

View PostDoom64hunter, on 24 July 2021 - 11:09 AM, said:

Edit 2: Map06 of savior.grp is beatable, but extremely long (1000 enemies, jesus christ). I did not encounter any softlocks.

Then you just didn't explore it well enough.

View PostDoom64hunter, on 24 July 2021 - 11:09 AM, said:

Edit 3:
I can't reproduce this with r9484. Were you using the latest revision?

I experienced this bug with EDuke32 git commit 2b4fa55fb27a12df023f46e7a0a2050eabf3ac88, also i experienced it a couple years ago.

This post has been edited by Ax 34noff: 25 July 2021 - 05:47 AM



View PostAx 34noff, on 25 July 2021 - 05:47 AM, said:

I experienced this bug with EDuke32 git commit 2b4fa55fb27a12df023f46e7a0a2050eabf3ac88, also i experienced it a couple years ago.

I still haven't been able to reproduce it. The marines always stand around peacefully for me. Is there anything particular that might trigger them?

And this is the first map of the third episode select, right?

Anyways, here's my analysis of the current issues:

View PostNightFright, on 24 May 2021 - 09:49 PM, said:

Current testing progress overview:

- 1999 TC: Invisible bullet-proof objects in "The Wash"
-> Issue that needs to be fixed in the map. Occurs in DOS Duke3D as well.
- A.Dream Trilogy (ladders not working)
-> Ladder works as of r9485.
- Castle Dukenstein: Dogs are hard to kill
-> Will probably need to be fixed in CON, dogs were hard to kill in very old eduke32 versions as well.
- Critical Mass (DNCM2: two elevators not working, r7470+)
-> Elevators work as of r9485.
- Grins of Divinity (ladders not working after r7432)
-> Ladders work as of r9485.
- Layre (chaptr1: beatable?)
-> Is beatable, but some issues found, see my previous posts.
- Lost Highway (sky issue in losthw03 "Toxic Gas")
-> A mapping error, easily fixed by changing the ceiling pal.
- Quest for Hussein (elevator transition issue with first/last map)
-> Issue fixed as of r9485.
- Savior of Alien Era (foreverp: unable to climb ladder? / blink1: potential softlock)
-> No ladder issue in foreverp, I found no potential softlock in blink1 playing it casually.
- The Gate (GATE306: shooting sprite platform not working/teleporter to SOS room not working)
-> The former is fixed with r9485, the latter will be fixed with upcoming patches (something above r9560).
- WGSpace (WGS4X: Broken elevator)
-> Elevator doesn't work in DOS either. Intentional?

- Community Build Project: Blue keycard lock not working in CBP3
-> Intentional, not a bug. Need to hit stripper wallsprite.
- DukeVR (Pipebombs cannot be stacked in RED2, still works in r7470)
-> I submitted a Merge Request that could fix the pipebomb stacking in eduke32. Not fixed in any particular revision yet.
- Red Series (RED4: pipebombs won't fit through hole, r7470-7615/getting stuck in black room, r8659-8700)
-> The former is partially an eduke32 problem and partially a mapping bug, see below. For the latter I submitted a Merge Request to eduke32 that will fix the issue.

The pipebombs not fitting through the hole in Red4 occurs because pipebombs can normally not go through blocking walls. For some reason both the inner and the outer wall of this hole are blocking lines.

The problem can easily be fixed in the map by removing the blocking bit from the inner wall. This changes nothing about how the player clips with the hole itself, and allows the pipebomb to pass through.

The fact that the pipebomb was even able to pass through both blocking linedefs was a bug in updatesector() that was fixed in an eduke32 commit.

Edit: Also, midi music may still cause freezes on level transitions. TerminX is aware, and this will also be fixed in some future commit (r9600+ probably).

This post has been edited by Doom64hunter: Yesterday, 12:21 AM


User is offline   NightFright 

  • The Truth is in here


Updated checklist:


OK after review/EDuke32 updates



This post has been edited by NightFright: Yesterday, 05:11 AM


User is offline   FistMarine 


Can confirm that the 1999 episode (as part of the 2000 Demo) has that canyon level with the buggy hitscan attacks happening even in the DOS version 1.5. I finished the episode two weeks ago in DOSBox and noticed the pistol bullets hit the air or something, making taking those troopers down a bit of a chore, since there were so many enemies in this level and not so much health/supplies. Also had to use precious RPG/Devastator/Freezer shots to take down those pig tanks, as I couldn't consistently get behind them to self-destruct without firing at me and Duke's speed is also slightly slower in the mod, probably as trade-off for having stronger weapons, which in turn also makes most enemies' attacks deadlier. Then there was that bullshit Battlelord boss in last level, probably the most frustrating boss fight I ever witnessed in Duke3D mods. Not only he does more damage than before but there also aren't many supplies available, I only had 30 devastator ammo, portable medkit and just 100 health. No armor or atomic health to help further. And the arena you fight him had no supplies at all! Took me probably 20 or so attempts to beat him by finishing him off with the shotgun while he was busy shooting mortars at me while I was using jetpack. Was there a secret area or something that I may have missed? Because as far as I know, I was able to get all kills and secrets (last few maps have no secrets at all I think), besides one missing kill in level 3 and 5 missing kills in level 4. Don't know what was with missing kills and these annoyances with last two levels but I didn't really enjoy my time with the mod (although the first 3 levels were nice) and I still have to do 2000 episode which is just a single level. I find interesting how every Duke3D mod that uses Redneck Rampage textures turns out to be crap gameplay wise.

Anyway, I promised a while ago that I will be testing further addons, when I get around testing some addons with latest EDuke32 build, I will be definitely letting you know and squish more bugs! Thanks Doom64hunter and the rest for finding a lot of bugs!

Also just remembered another thing in last level of 1999 episode. In one of the houses, there is a place that you could get temporary stuck if you wanted to grab that medkit, I barely managed to fit through the opening with the help of getting pushed by the door and then get unstuck after trying to exit the bathroom for a whole minute. I wonder how are things in the latest EDuke32 build, especially with the clipping changes. I am talking about the place in the screenshot below:

Attached thumbnail(s)

  • Attached Image: 1999_L6_Bathroom.png


User is offline   NightFright 

  • The Truth is in here


"Layre" and "Lost Highway" updated.

"Layre" fixes:
- Missing sounds are commented out. In the case of sound #420 (FAN1), fan1.wav was renamed to fan1snd.wav since actor name is also FAN1. I am not 100% sure if that fixed it.
- CHAPTR2: Seems the size of the underwater sector matches the surface one perfectly in the boss area. However, the SE7 transport sprite #288 for the underwater sector was not where it should be (needs to be at the exact same spot as on the surface). Relocating the sprite fixed the problem for me (kinda, the boss is still pretty large for that pool, but at least you can kill it). For the other map-related issues, I'll have to dig deeper later on.

"Lost Highway" fixes:
- LOSTHW03: Two critical sewer switches have their shade values lowered to 20
- LOSTHW03_ROR: Ceiling pal for sector 362 changed to 1

To update:
- Use the downloader script (unzip into your EDuke32 root dir and execute eac_install.bat) OR
- Get the updated EAC Base Pack (13.3 MB) and download "layre.grp" + "losthighway.grp" from the repository


BTW, I am still not giving up on pushing WGet to be the only download option for all users since it would be so much easier for me to handle files instead of managing two repositories.

So, my request @ anyone not using Windows:
1) Please try to install WGet with one of the following tutorials for Linux - MacOS - FreeBSD
2) I don't know where this will be installed by default or how it works in general, but try to get it working from your EDuke32 installation dir and execute the following commands:
wget http://www.duke4.org/files/nightfright/eac/eac_install-base.txt
wget http://www.duke4.org/files/nightfright/eac/eac_install-grp.txt
wget -i eac_install-base.txt -p -nH --cut-dirs=3 --timestamping
wget -i eac_install-grp.txt -p -nH --cut-dirs=3 --timestamping

I would appreciate any feedback you can provide.

This post has been edited by NightFright: Yesterday, 06:17 AM


Share this topic:

  • 43 Pages +
  • « First
  • 41
  • 42
  • 43
  • You cannot start a new topic
  • You cannot reply to this topic

All copyrights and trademarks not owned by Voidpoint, LLC are the sole property of their respective owners. Play Ion Fury! ;) © Voidpoint, LLC

Enter your sign in name and password

Sign in options