Duke4.net Forums: Those simple questions thread - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

  • 17 Pages +
  • « First
  • 11
  • 12
  • 13
  • 14
  • 15
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic

Those simple questions thread  "Simple questions, simple answers"

User is offline   Mark 

  • Honored Donor

#361

pointhighlightdist = 1024 works good for me as a workaround until if or when it gets fixed. I tried that setting for a few minutes and not once did the selection tool start up while pointing and dragging verts or sprites. But I agree with you. I would prefer the old way of selecting by using the shift button. Not both ways like now.

This post has been edited by Mark.: 18 September 2017 - 10:49 AM

0

User is offline   pmw 

#362

View PostMark., on 18 September 2017 - 10:48 AM, said:

pointhighlightdist = 1024 works good for me as a workaround until if or when it gets fixed. I tried that setting for a few minutes and not once did the selection tool start up while pointing and dragging verts or sprites. But I agree with you. I would prefer the old way of selecting by using the shift button. Not both ways like now.


Yep fixing these values makes hitting wall points easier, definitely. However, the actual problem is way too annoying. As you said, selection should only activate via shift button.

I'll just wait for new build where this feature is A ) disabled B ) possible to disable via configs.
For now, it so annoying that makes me completely stop using Mapster.

This post has been edited by pmw: 18 September 2017 - 11:37 AM

0

User is offline   Hendricks266 

  • Weaponized Autism

  #363

>button previously does nothing
>button now does something
>pmw complains

I think we have a PEBKAC.
0

User is offline   pmw 

#364

View PostHendricks266, on 18 September 2017 - 12:14 PM, said:

>button previously does nothing
>button now does something
>pmw complains

I think we have a PEBKAC.


Button was doing something, it had purpose and it was same like since first Build.
I understand adding more buttons, if they are not already in any use. But in case like this, it's _most used_ button and changes behaviour. Maybe I'm the only one, but it really bothers me. Especially since it(using selection tool via mouse button) has no purpose really. I think it's really rare to use selection tool at all, whatever activates it. With Mapster, I don't like to select a lot of stuff and move it around the map, it doesn't go like that. That works in blender, 3dsmax, Hammer, etc. Where texturelocks and 3D really exists and works. With build? Not really...and when it activates automatically every time I click mouse button, thanks but no thanks. This is just my opinion.

I understand someone had a great idea there and maybe likes it, but changing so radically the most used button in the editor..? Well, whatever, I'll come back in next year.

This post has been edited by pmw: 18 September 2017 - 01:00 PM

0

User is offline   Hendricks266 

  • Weaponized Autism

  #365

The only circumstances where the button does what you don't like are in cases where it used to do nothing. Is this correct?
0

User is offline   Mark 

  • Honored Donor

#366

He wants it to go back to the way it used to be. Selecting a single point or sprite. Not a selection box also. At least thats how I understand his complaint. And I happen to agree.

I never noticed this before because up til now I had been working on projects with older Eduke32 and Mapster versions. Now that I'm done with those and will start using updated versions I was surprised to see this one and will have to get used to the new color scheme for lines and sprites in the 2d map. I hope there aren't any more surprises.

I don't recall if these 2 changes were discussed with mappers before or only after they were implemented. I know that eventually I will get used to the new way, just like the remapping of keys for panning textures when it happened. It was horrible at the time because of how many times I did it the old way by mistake til I got used to it.

This post has been edited by Mark.: 18 September 2017 - 02:41 PM

0

User is offline   BestViking 

#367

Is it possible to have .mdl support for models in the future?
0

User is offline   Mark 

  • Honored Donor

#368

There is a long and lively discussion of future model formats in some earlier thread. Best to read that instead of starting it up again. It wasn't pretty. ;) But no to mdl.

This post has been edited by Mark.: 18 September 2017 - 02:46 PM

0

User is offline   Hendricks266 

  • Weaponized Autism

  #369

View PostBestViking, on 18 September 2017 - 02:39 PM, said:

Is it possible to have .mdl support for models in the future?

If you mean Quake 1 models, definitely not. Why would we go backwards? You can convert them to MD2 with this: https://www.icculus....qwalk/download/ I believe it would be a lossless conversion but I need someone to confirm this for me.

If you mean Source Engine models,

Quote

MDL is the extension for Source's proprietary

Nope.

Support for IQM is in our roadmap. I believe many of MDL's features could be converted to IQM but I would need someone more experienced to confirm this as well.

To fend off the same discussion we had last time, supporting FBX models would be as nonsensical as supporting PSD images, and I will delete any posts that try to argue for FBX in spite of this.
0

User is offline   Mike Norvak 

  • Music Producer

#370

View PostTrooper Dan, on 10 February 2016 - 09:46 PM, said:

Here's a very safe way to do it which will work in any mod, if you are worried about messing up the weapon flags. This is a concern because in some mods, weapon flags change dynamically when a weapon switches from one firing mode to another (.e.g. regular versus altfire in WGR2).

Find where the player actor code starts. This will be the line "actor APLAYER MAXPLAYERHEALTH PSTAND 0 0". Below that, add the following:

orvar WEAPON1_FLAGS 256
orvar WEAPON2_FLAGS 256
orvar WEAPON3_FLAGS 256
orvar WEAPON4_FLAGS 256
orvar WEAPON6_FLAGS 256
orvar WEAPON7_FLAGS 256
orvar WEAPON9_FLAGS 256
orvar WEAPON11_FLAGS 256


Note that I skipped the mighty boot, pipebomb, and laser tripbomb, since none of those flash the level anyway.


Thanks DT. Hey sprry for the late reply (2 years later) haha
I just want you to know that I did this with success. :)

This post has been edited by Mike Norvak: 09 January 2018 - 10:25 AM

1

User is online   RPD Guy 

#371

Does anyone have a small "how-to" tutorial instructing how to make new weapons for the game?
0

User is offline   Mark 

  • Honored Donor

#372

How much info you need depends on what you want to do. If you just want to replace the graphics and use existing code for everything else its pretty easy. But if you want to customize the projectile it fires, damage amount and other things it gets way more involved.
0

User is online   Sanek 

#373

Is that possible to apply the slippery effect on all inclined surfaces in the game? I saw the effect in DukePlus where the player will slip when he's on ice. I want to apply that effect on all sectors that are not flat.
0

User is online   Micky C 

  • Honored Donor

#374

To clarify, are you talking about slipping (i.e some momentum in movement), or sliding down a slope due to gravity?
0

User is online   Sanek 

#375

sliding down a slope due to gravity
0

User is offline   Forge 

#376

View PostSanek, on 13 January 2018 - 05:55 PM, said:

sliding down a slope due to gravity

in vanilla on a slope?
there might be some trick or build porn, but the best I could come up with off the top of my head is to use the conveyor effect and an unremarkable texture in which you can't see the panning movement.

This post has been edited by Forge: 13 January 2018 - 06:39 PM

0

User is online   Sanek 

#377

View PostForge, on 13 January 2018 - 06:39 PM, said:

in vanilla on a slope?
there might be some trick or build porn, but the best I could come up with off the top of my head is to use the conveyor effect and an unremarkable texture in which you can't see the panning movement.

No, not in vanilla of course. And what if I don't have the "unremarkable" texure?
I mean, imagine a rolling ball that will slide down on a slope, and will also slide if you go up and the decide to stop in a middle. Is that possible to do with some new code?
0

User is online   RPD Guy 

#378

View PostMark., on 10 January 2018 - 10:50 AM, said:

How much info you need depends on what you want to do. If you just want to replace the graphics and use existing code for everything else its pretty easy. But if you want to customize the projectile it fires, damage amount and other things it gets way more involved.

That's what I want >>> Draw new sprites on screen, including all functions (bobbing, reloading etc..), using my own projectiles. I suppose that drawing the weapon is the hardest part of all.
0

User is online   RPD Guy 

#379

I have another question:
For APLAYER we have "spritebridge" and "sbs" properties. The other actors don't have these.
How can I know if a actor is standing upon an "spritebridge"?
0

User is online   RPD Guy 

#380

I'm feeling a bit alone now.
0

User is offline   Mere_Duke 

#381

Maybe try:
getactor[myenemy].sectnum mysect
getsector[mysect].floorpicnum getfloorpicnum



getfloorpicnum is the floor texture for myenemy

This post has been edited by Mere_Duke: 13 February 2018 - 10:34 AM

0

User is offline   Mark 

  • Honored Donor

#382

What am I doing wrong? The c9 cannister will not explode. Hopefully you can see the hitag and lotag of the effectors in the pic.

I have the following:
C9 132,10 (channel,delay)
D 0,132 (0,channel)
T 0, 132 (0,channel)


The instructions are here:

Place as many SEENINE/OOZFILTER explosives tagged [Channel,DelayExplosion] as you want. For DelayExplosion, a value of 30 = 1 second. If you want to make the explosives intangible in the game, shrink them horizontally (x-wise) as much as possible. Raise each one to the height at which you want it to explode. Each SEENINE/OOZFILTER must have a Lo-Tag value or else it won't visibly or audibly explode (although it will still shake the screen and spawn debris). It is also recommended to assign time-delay Lo-Tag values to linked tangible explosives, because in the case of multiple tangible explosives, only the one with the largest sprite number will visibly and audibly explode. Place a D[0,Channel] in just one sector containing a SEENINE/OOZFILTER explosive (the Channel will link the rest of the explosives together). Place either a T[0,Channel] or else a Switch tagged [ActivationSound,Channel] somewhere in the map (to trigger the explosion).

Attached thumbnail(s)

  • Attached Image: TRIGGERED.png

0

User is offline   Taamalus 

#383

^ based on the image, it should work.

reference
http://wiki.eduke32....ing_C-9_Effects

Whenever I come across a snag like this, I use L-Shift to see if there is another sprite connected to the set that should not be.
0

User is offline   Mark 

  • Honored Donor

#384

I already tried the "shift check" and rebuilt the effectors a second time. Usually that works.

EDIT: I just rebuilt it a 3rd time and now it worked. :blink:

This post has been edited by Mark.: 15 February 2018 - 04:18 PM

0

User is offline   Forge 

#385

Happened to me a long time ago, so it's nothing new. I think it has to do with the D sprite. Single canisters usually work fine, it's when multiple are linked that it might go awry
0

User is offline   blizzart 

#386

[SOLVED]

Hi guys,
I´m looking for a download link of the Aliens VS Duke TC Demo (https://www.youtube....FMLrwX60&t=326s). Does anyone of you has a copy and can provide it? The download link at MSDN isn´t working unfortunately.

Big thanks in advance.

EDIT:
Found it myself: http://www.r-t-c-m.c...-addons/avd.zip

This post has been edited by blizzart: 25 February 2018 - 01:15 PM

0

User is offline   Daedolon 

  • Ancient Blood God

#387

ModDB has had it for years.
0

User is online   NightFright 

  • The Truth is in here

#388

I was wondering if transparency is working at all on statusbars when using PNG replacements in EDuke32. For example, when you try using oasiz' widescreen statusbar, you would get black parts where the transparency is supposed to be (using tilefromtexture). Any way to eliminate this?
0

User is offline   Hendricks266 

  • Weaponized Autism

  #389

You won't be able to use it as a simple tile replacement. You would have to separately code the game to only use it in the "overlay status bar" mode, while maintaining the full width bar in "narrow the viewport vertically" mode.
1

User is online   NightFright 

  • The Truth is in here

#390

That explains why I was never able to get this working. I really need to stop comparing this to GZDoom where the statusbar can be fully customized and even made transparent via the sbarinfo lump. It's a pity since I am searching for a way since ages to get a statusbar in Duke3D that does not take away too much viewport space (without having to minimize it too much in size). If some of you guys follow the ZDoom forums, DTDsphere came up with a neat statusbar solution for GZDoom. Having something like that in EDuke32 would have been really great, but I guess there are considerable technical restrictions.

This post has been edited by NightFright: 01 March 2018 - 04:57 AM

1

Share this topic:


  • 17 Pages +
  • « First
  • 11
  • 12
  • 13
  • 14
  • 15
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners. Instead of reading this text, you could be playing Ion Fury! ;) © 2019 Voidpoint, LLC

Enter your sign in name and password


Sign in options