Duke4.net Forums: VoidSW Public Beta - Duke4.net Forums

Jump to content

  • 4 Pages +
  • « First
  • 2
  • 3
  • 4
  • You cannot start a new topic
  • You cannot reply to this topic

VoidSW Public Beta

User is offline   jkas789 

#91

I have not tested the issue with other source ports but I'm at home atm so I'll try it out and report if on my side it is a user issue or a possible source port issue.
0

User is online   Phredreeke 

#92

View Postrandir14, on 29 October 2020 - 11:34 AM, said:

I also tested Shadow Warrior with BuildGDX and Raze, neither had the same issue. In fact Raze runs like butter which is weird since I thought it was based on VoidSW code.


The game side code is based on VoidSW. the engine side code is different, it uses Polymost to generate geometry but then uses its own backend to draw it.
0

User is offline   jkas789 

#93

Can confirm, a micro stutter on my machine (a laptop with a gtx 960m, i7 6700 hq and 16 gb of ram, and two ssd one of 100 gb and the other of 1 tb) while playing Shadow Warrior on 1920x1080. I tried lowering the resolution to 720 however I noticed the same stutter. It a minor thing frankly and not very noticeable, but it is there.

Edit: forgot to add, im using the void executable of the latest synth r9273.

This post has been edited by jkas789: 29 October 2020 - 12:33 PM

0

User is offline   Jimmy 

  • 1776 World Wide

#94

I think this happens in everything that uses Polymost.
0

User is offline   Hendricks266 

  • Weaponized Autism

  #95

Can you try different values of the r_glfinish cvar? If that changes nothing, please see: https://forums.duke4...ing-megathread/
0

User is offline   jkas789 

#96

View PostHendricks266, on 29 October 2020 - 01:01 PM, said:

Can you try different values of the r_glfinish cvar? If that changes nothing, please see: https://forums.duke4...ing-megathread/


Changed the value from 0 to 1 and Jesus Christ the game plays so smooth now. I tried to play through as many busy maps as I could remember and yup. No micro stutters. Should this value be changed every time I load the game?
1

User is offline   Hendricks266 

  • Weaponized Autism

  #97

Glad to hear that's all it took to fix your issue. It not being saved is a bug.

Now what we need to figure out is how the engine can detect what the correct behavior should be depending on the user's setup and do that automatically without needing this user-tunable knob.
4

User is offline   BFG9000 

#98

getting a weird graphical glitch(?) in the first level where you get the rocket launcher. The textures will flash and sort of "jump".. that's the best way I can put it at least.
1

User is online   Phredreeke 

#99

Could you perhaps record the glitch with OBS? Also what renderer were you using?
0

User is offline   jkas789 

#100

Recording of the glitch in the rocket launcher room while playing Shadow Warrior with VoidSW. Latest revision with polimost settings at 1080p. I disabled every mod except the voxel mod for better framerate while recording.


0

#101

 jkas789, on 03 December 2020 - 06:52 PM, said:

Recording of the glitch in the rocket launcher room while playing Shadow Warrior with VoidSW. Latest revision with polimost settings at 1080p. I disabled every mod except the voxel mod for better framerate while recording.



Had same problem when I tried older revisions of VoidSW. At first, I assumed it had something to do with a fov. Now, I am not sure.
0

User is offline   jkas789 

#102

View PostBubble Gum Chewer, on 04 December 2020 - 02:15 PM, said:

Had same problem when I tried older revisions of VoidSW. At first, I assumed it had something to do with a fov. Now, I am not sure.


I initially thought it was was a problem with my graphics card. I'm trying to see if there are other places in the game were this happens.
0

User is offline   MetHy 

#103

1) Please try to see if this happens without using widescreen resolutions and/or with different FOVs

2) Check if it happens in this version of the map I just joined, which deletes the viewscreen. My hunch is that it has something to do with it.

Attached File(s)


2

User is offline   jkas789 

#104

View PostMetHy, on 05 December 2020 - 03:34 AM, said:

1) Please try to see if this happens without using widescreen resolutions and/or with different FOVs

2) Check if it happens in this version of the map I just joined, which deletes the viewscreen. My hunch is that it has something to do with it.


I have confirmed that it happens with low screen resolutions (tested this from 1920x1080 to 800x600 on all types of fovs). I haven't been able to test the map as I don't quite know how to load user maps in VoidSW.

Edit: I'm thinking on testing it with older versions of VoidSW as I remember this not being a issue with older revisions.

Edit 2: Hendricks kindly told me in the discord the command to play with user maps and I can confirm that the glitch disappeared while testing MetHy's version of the map.

This post has been edited by jkas789: 05 December 2020 - 05:40 PM

2

User is offline   jkas789 

#105

I have been playing the game combing the levels (slowly as time permits me) to see if I can encounter the same glitch elsewhere. Found it again in E1M3 in the Jackie Chan secret with the portals:




EDIT: So as it turns out (This info is from Hendricks, thanks a lot for clarifying it on Discord :) ), this only happens if the FOV is below or above 90.

This post has been edited by jkas789: 13 December 2020 - 03:18 AM

0

#106

View Postjkas789, on 13 December 2020 - 02:16 AM, said:

I have been playing the game combing the levels (slowly as time permits me) to see if I can encounter the same glitch elsewhere. Found it again in E1M3 in the Jackie Chan secret with the portals:




EDIT: So as it turns out (This info is from Hendricks, thanks a lot for clarifying it on Discord :) ), this only happens if the FOV is below or above 90.

Figures, my FOV is 100 or above if possible.
0

#107

Hi, there's a bug in Twin Dragon's level, The Fishing Village. This bug is also present in Redux and the original Shadow Warrior.

If you activate the ending switch jumping sideways, the game makes you skip the next level Secret Garden straight to Fortress.

Normally, you wouldn't jump, but depending on the resolution, the collision detection of the switch changes so you can't activate it standing, thus how I discovered the bug. (This damn thing made me ragequit)

I hope I was clear enough, it's my first time here.
:D :D
0

User is offline   BFG9000 

#108

Even with a few issues it's amazing how much better this plays than Shadow Warrior Redux, at least for me. No matter what I do Redux always looks like it's running below 60fps, but this is incredibly smooth
0

User is offline   Kil3r 

#109

Great job on the port. I played through both SW and WD with it. I did encounter a couple bugs but I can't remember all of them anymore. One that I do remember is that with the widescreen weapons the shotgun alt fire red light was shifted to the right(therefore didn't cover the sprite properly). This was my first playthrough of SW. I gotta say, a very great port for a very good game. Kudos!

This post has been edited by Kil3r: 03 February 2021 - 11:30 PM

0

User is offline   Striker 

  • Auramancer

#110

 jkas789, on 03 December 2020 - 06:52 PM, said:

Recording of the glitch in the rocket launcher room while playing Shadow Warrior with VoidSW. Latest revision with polimost settings at 1080p. I disabled every mod except the voxel mod for better framerate while recording.



That almost looks as if the FOV is getting screwed up somehow.
0

User is offline   Anacronox 

#111

Latest releases dont detect wd,grp for some reason. Tried both windows & linux versions. Base game & TD do work. Buildgdx or good old dosbox run just fine with same wd.grp. Any ideas what might have cause it?
0

User is offline   jkas789 

#112

View PostAnacronox, on 07 February 2021 - 10:31 PM, said:

Latest releases don't detect wd,grp for some reason. Tried both windows & linux versions. Base game & TD do work. Buildgdx or good old dosbox run just fine with same wd.grp. Any ideas what might have cause it?


Are you sure? I'm using the latest revision r9310 and it detects it all right:

Spoiler


Spoiler


Spoiler


Maybe you are not installing it correctly?

This post has been edited by jkas789: 07 February 2021 - 10:49 PM

0

User is offline   Anacronox 

#113

Hm its not like there are multiple overly complicated ways to install it. All 3 grps are in the same folder plus voidsw. Yet checksum on wt.grp apparently fails as its not shown on game tab. The game itself is from original cd expansions from moddb. Oh well good to know the problem is actually on my end though i have no idea what might cause it. As i said buildgdx & original exe detect it just fine.
0

User is offline   jkas789 

#114

Try making a shortcut and adding the gWT.grp command.

Or re install SW.

This post has been edited by jkas789: 08 February 2021 - 09:04 AM

0

User is offline   Hendricks266 

  • Weaponized Autism

  #115

View PostAnacronox, on 08 February 2021 - 08:06 AM, said:

Hm its not like there are multiple overly complicated ways to install it. All 3 grps are in the same folder plus voidsw. Yet checksum on wt.grp apparently fails as its not shown on game tab. The game itself is from original cd expansions from moddb. Oh well good to know the problem is actually on my end though i have no idea what might cause it. As i said buildgdx & original exe detect it just fine.

If you downloaded some random entry from ModDB then you probably have a custom repack of the GRP which is unsupported. Get the official version.

View Postjkas789, on 08 February 2021 - 09:04 AM, said:

Try making a shortcut and adding the gWT.grp command.

Do not do this. This is not how you load expansions.
0

User is online   Phredreeke 

#116

what would be the drawback from loading an expansion as a group file?
0

User is offline   Player Lin 

#117

Load the expansion GRP/resources twice and caused conflicts or something not good?
0

User is offline   Anacronox 

#118

View PostHendricks266, on 08 February 2021 - 12:14 PM, said:

If you downloaded some random entry from ModDB then you probably have a custom repack of the GRP which is unsupported. Get the official version.

Wasn't some random entry though. Official version is the very same file. Tried it - same result.
Anyway after messing around with different versions of the game found the culprit. Turns out sw.grp (shows up as shadow warrior (europe) on game tab) from original cd with wanton destruction prevents the latter from loading in voidsw. All while twin dragon works just fine. Using sw.grp from gog classic solved the problem. Weird stuff heh.

This post has been edited by Anacronox: 09 February 2021 - 02:17 AM

0

User is offline   FistMarine 

#119

I can confirm that Shadow Warrior, Twin Dragon and Wanton Destruction all show up fine on my end. I use the SW.GRP from original US CD version, WT.GRP from official swwd.exe installer downloaded from FilePlanet and the tdragon.zip file from gamers.org.
https://www.fileplan...-Expansion-FREE
http://www.gamers.or...gon/tdragon.zip

I would recommend to get the addons from these places (or other similar places that have the two files: swwd.exe and tdragon.zip, in case gamers.org is blocked by your antivirus for example, although the site should be safe as I downloaded a lot of stuff from it before) instead of random ModDB uploads by other users. As Hendricks266 mentioned, the Twin Dragon grp found there is modified or repacked by ProAsm, I think. However there is also TD.grp which is only found in Classic Redux and that one probably works too.

Anyway, I want to report two minor issues that persist in latest build (r9310)
-When starting the game, it seems you can't skip the Lo Wang cutscene with SPACE, however it works with ENTER button
-After starting Wanton Destruction and going to New Game, the second episode WANTON DESTRUCTION seems to go outside of screen. I know in original DOS version, the episode was displayed as "WANTON DESTR" or something similar, presumably to avoid the text going outside of screen, while here the episode name was fixed, but the text goes outside of screen. This may be because I'm playing on resolution 1024x768 and it would display fine on widescreen resolution. Yep, just confirmed on the 1360x768 resolution (the highest available on my PC), the episode name just barely fits on my monitor, however I'm not a fan of letterboxed display, I like when the whole screen fills the monitor instead of the black bars on edges.

Other than that, I really like the port! It runs smooth from my 5 minutes testing with cheats on the first level! :)
1

User is offline   jkas789 

#120

It runs better than Shadow Warrior GDX. The only thing missing IMO is being able to load user maps from the ingame menu.
0

Share this topic:


  • 4 Pages +
  • « First
  • 2
  • 3
  • 4
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks not owned by Voidpoint, LLC are the sole property of their respective owners. Play Ion Fury! ;) © Voidpoint, LLC

Enter your sign in name and password


Sign in options