Duke4.net Forums: v-sync setting resets when restarting eduke32 - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

v-sync setting resets when restarting eduke32

User is offline   Mr. Death 

  • 2

#1

Hi,

I'm new to both Duke3D & the EDuke32 source port, so please forgive me if this bug has already been reported or it's because of something I'm doing wrong on my end...

I've noticed that whenever I launch EDuke32 that my setting for v-sync always defaults to OFF, even though it shows in the options menu that it's currently set to ON. The only way I can re-enable it is to select OFF & then ON again.

Another thing is that if I launch EDuke32 & don't change the v-sync option, but then start a new episode, it will re-enable itself. But if I launch EDuke32 & re-load a save instead, it will still be disabled :/

It's not really a huge deal, but it is an annoyance that I have to do each time I want to play.

Thanks for any help!
1

User is offline   Hendricks266 

  • EDuke32 Senior Developer
  • 5,992

  #2

Thanks for the report, we'll take a look.

Has anyone else experienced this?
0

User is offline   Mr. Death 

  • 2

#3

I also wanted to add that this happens with all three rendering modes (Classic, Polymost & Polymer). I've also tried using the "restartvid" console command after I launch EDuke32, but this does not re-enable v-sync either.

On a side not, I've noticed that when v-sync is enabled w/ polymost the performance is very stuttery & has constant little hiccups that causes the FPS to jump a few frames above & below my refresh rate. The other two renderers do not have this problem, but those both have obvious slowdown in some spots so I wanted to stick with polymost. Is there any way to fix this?

Here are my specs if that will help (I know, they're a bit outdated):

Windows Vista 32-bit
AMD Athlon 64 X2 Dual Core 4600+ (2.40GHz)
4 GB of RAM
NVIDIA Geforce 9800GT

Thanks again!
0

User is offline   Hendricks266 

  • EDuke32 Senior Developer
  • 5,992

  #4

The vsync option problem seems familiar but I can't remember if there was a user-facing solution. If you launch EDuke32 and trigger the problem a few times, does eduke32.log say anything about it?

The stuttering might be fixable by enabling "Threaded optimization" in NVIDIA Control Panel.
0

User is offline   axl 

  • 121

#5

View PostHendricks266, on 08 January 2018 - 11:27 AM, said:

Thanks for the report, we'll take a look.

Has anyone else experienced this?


I have experienced similar issues with vsync and EDuke32.

When I start playing with vsync on and start a new game, I have absolutely no screen tearing whatsoever. However, when I save a game, quit and then reload that savegame, I get screen tearing. Going to options, selecting vsync off and then back on, somehow resolves the issue and the screen tearing disappears.

Not sure if these issues are related.
0

User is offline   Mr. Death 

  • 2

#6

View Postaxl, on 09 January 2018 - 12:39 PM, said:

I have experienced similar issues with vsync and EDuke32.

When I start playing with vsync on and start a new game, I have absolutely no screen tearing whatsoever. However, when I save a game, quit and then reload that savegame, I get screen tearing. Going to options, selecting vsync off and then back on, somehow resolves the issue and the screen tearing disappears.

Not sure if these issues are related.

Yes, that is the exact issue I'm having. If you enable the FPS counter you can easily see when it stops/starts working again.

I've checked the log file after starting EDuke32 & messing with the v-sync setting but I don't see anything out of the ordinary (I don't really know what to look for though).

My graphics control panel has threaded optimization set to "auto" by default, but just to check I switched it to "on" and I don't really see a difference while playing (still stuttering/hitching). If I use the frame rate limiter instead of v-sync everything seems to run much smoother with polymost, so maybe I'll just use that for now.

Thanks for looking into this issue, I hope you guys figure out what's causing it :)
1

User is offline   pogokeen 

  • EDuke32 Developer
  • 22

#7

I've pushed some patches tonight that should fix these issues (r6682 & r6683) -- you can find the specific revision binary with both fixes here (or in the latest Synthesis builds):
http://dukeworld.com.../20180221-6683/

Please let me know in this thread if you're still encountering any vsync problems with these updates! :)
1

User is offline   Mr. Death 

  • 2

#8

View Postpogokeen, on 21 February 2018 - 07:52 PM, said:

I've pushed some patches tonight that should fix these issues (r6682 & r6683) -- you can find the specific revision binary with both fixes here (or in the latest Synthesis builds):
http://dukeworld.com.../20180221-6683/

Please let me know in this thread if you're still encountering any vsync problems with these updates! :)

Yes, v-sync appears to be working properly now upon restarting EDuk32!

I did notice a small little side effect of having the v-sync setting enabled when I restart the game though; there's a quick flashing window once I click "Start" & then my desktop cursor remains on screen while the intro cinematics play. Once I get into the main menu though it switches back to the default crosshair cursor. This does not happen if the v-sync setting is already disabled when restarting the game. It's a very minor thing, but I just thought I'd mention it in case it's fixable.

Great work :)
0

User is offline   pogokeen 

  • EDuke32 Developer
  • 22

#9

That's a good note, thanks for the heads up! :) I'll take a look & see what I can do to fix that :)
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners. Instead of reading this text, you could be playing Ion Maiden! ;) © 2018 Voidpoint, LLC

Enter your sign in name and password


Sign in options