Duke4.net Forums: Newbeast and menu related bugs - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Newbeast and menu related bugs

User is offline   Darkus 

  • 250

#1

Found a bug with the Newbeast, and some concerning the menus:

Freeze a Newbeast, and wait him for unfreeze. He will have a strange behavior, as if he could not change direction. This doesnt happen in vanilla when the newbeast could chase the player again.

For the bugs related with the menus, it's like eduke don't remember which setting have changed, especially when quitting and restarting. Deleting the cfg files does not help.

- In the mouse button assignement, I wanted to bind the third button to "-nothing-". It works, but after quitting and restarting EDuke32, it's still assigned back to jetpack. However, assigning button another than "-nothing-" seems to work.

- Same thing for the sound/music volume, setting the main volume to 0% works, but quit and restart EDuke32, the main volume is back to 100%, even if the slide bar is on 0%.

- In OpenGL (Polymost or Polymer), set texture filter to "filtered", quit and restart, it will say "classic", even if the textures are filtered.

Finally, the most important, when using the Polymost HRP (not Polymer), and not started a new game, going to the player setup menu makes eduke stall.

Tested with EDuke32 r5412 (64-bit)
4

User is offline   LeoD 

  • 473

#2

View PostDarkus, on 04 November 2015 - 03:15 PM, said:

Finally, the most important, when using the Polymost HRP (not Polymer), and not started a new game, going to the player setup menu makes eduke stall.
Tested with EDuke32 r5412 (64-bit)
Confirmed.
Wow, that's ugly. My local r5419 builds are affected as well, 32-bit binaries, too.

Semi-random additional information:
Both Polymost renderer and HRP must be used to provoke the freeze.
Attached File  eduke32-5412.log (2.42K)
Number of downloads: 91
no difference if:
- fullscreen or windowed mode
- Override Pack or command line parameter used for Polymost HRP invocation
- official or repository HRP, zipped or from directory hierarchy

I think something goes wrong when EDuke32 tries to load that animated Duke into the player setup menu.

Polymost HRP / Z-Pack: customize your HRP | User Map Maphacks
"Redneck Rampage has chickens. If you put a chicken in Duke3D then it's Duke3D with a chicken."
0

User is offline   Hendricks266 

  • EDuke32 Senior Developer
  • 5,363

  #3

Which of these bugs are still present?
0

User is offline   Darkus 

  • 250

#4

All of them, exept the sound/music volume which is fixed (the volume settings are kept when restarting eduke). All of the other, including newbeast that can't change direction (probably intended to prevent 3d models to rotate) and polymost crash in player menu are still here.
0

User is offline   Hendricks266 

  • EDuke32 Senior Developer
  • 5,363

  #5

View PostDarkus, on 04 November 2015 - 03:15 PM, said:

Freeze a Newbeast, and wait him for unfreeze. He will have a strange behavior, as if he could not change direction. This doesnt happen in vanilla when the newbeast could chase the player again.

I tried going back to around r4600 and letting a Protector Drone thaw didn't have the angle bug, but it still acted stupid, shooting at walls and not actually attacking the player.

View PostDarkus, on 04 November 2015 - 03:15 PM, said:

- In the mouse button assignement, I wanted to bind the third button to "-nothing-". It works, but after quitting and restarting EDuke32, it's still assigned back to jetpack. However, assigning button another than "-nothing-" seems to work.

Fixing this will take some restructuring in our cfg file code. Nothing major though. Good observation.

View PostDarkus, on 04 November 2015 - 03:15 PM, said:

- In OpenGL (Polymost or Polymer), set texture filter to "filtered", quit and restart, it will say "classic", even if the textures are filtered.

Fixed in r5878.

View PostDarkus, on 04 November 2015 - 03:15 PM, said:

Finally, the most important, when using the Polymost HRP (not Polymer), and not started a new game, going to the player setup menu makes eduke stall.

Fixed in r5876.
0

User is offline   Captain Massive 

  • 140

#6

Cant sort sounds F2 with capslock on.

This bugged me for ages and could not figure out why I could not sort sounds, I was rebooting and trying all kinds of things, untill 1 day it dawned on me to try capslock.

Sound's 386 & 388 missing from sound list as well.

r5875

Massive Out....
0

User is offline   Darkus 

  • 250

#7

View PostHendricks266, on 02 October 2016 - 08:30 PM, said:

I tried going back to around r4600 and letting a Protector Drone thaw didn't have the angle bug, but it still acted stupid, shooting at walls and not actually attacking the player.

I have some news about the NEWBEAST bug: I wanted to fix another NEWBEAST bug for my GAME.CON, when you freeze a colored NEWBEAST and wait until it thaws, his color change back to 0, no matter which color it had.

The code inside the 'useractor enemy NEWBEAST' was the cause:
    spritepal 6
    state newbeastcode
    ifaction ANEWBEASTFROZEN
      break
    getlastpal
 


I rearanged by removing 'spritepal 6' and 'getlastpal' so I could code the colored blood by using events. And when I checked if the bug was still present, not only when it thaws, he's back with the good color, but it also resumed his normal behavior, chasing the player again.
But the bug is still present in the original GAME.CON file.
2

User is offline   Darkus 

  • 250

#8

Found other minors problems about the menu:

Another bug for the sounds that are not stopping when you pause the game: it happen only the first time when you pause the game, but after starting a second game. Here how to reproduce:
After launching EDuke, start a new game, then start a second new game, and pause the game (either by bringing the menu or using pause key), the sounds are not stopped the first time. The behavior is correct the rest of each time game is paused, unless you start a new game again.

The following problems appear only in classic renderer:

- The 'pixel doubling' option is inverted: when disabled, it show ON and vice-versa.

- The 'framerate limit' option is not set properly each time i'm launching EDuke, my counter show +300-500 fps when i'm in game, when it supposed to be 60. Modifying the counter in the options fix the problem, also typing simply 'r_maxfps' in the console restore it. But quitting and restarting EDuke disable the fps limit, even if the option is set on another value.

- The vsync option does not seem to work in classic renderer.
1

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners and all comments are owned by their posters. Yes, our forum uses cookies. © 2004-2017 Duke4.net and Voidpoint, LLC

Enter your sign in name and password


Sign in options