Duke4.net Forums: EDuke32 2.0 and Polymer! - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

  • 191 Pages +
  • « First
  • 189
  • 190
  • 191
  • You cannot start a new topic
  • You cannot reply to this topic

EDuke32 2.0 and Polymer!  "talk about the wonders of EDuke32 and the new renderer"

User is online   Hendricks266 

  • EDuke32 Senior Developer
  • 5,350

  #5701

Probably somewhere in the 4000s before development became myopic for HTTKC, damage which we're still working on.

Crash logs always help. I think our synthesis compiler has caused debug crash logs to be useless lately, so it would be greatly appreciated if you can build your own with `make RELEASE=0`.
0

User is online   Hendricks266 

  • EDuke32 Senior Developer
  • 5,350

  #5702

View PostTrooper Dan, on 25 July 2017 - 05:50 PM, said:

Any reports on whether this attempted fix was successful? Jblade?

As of the latest synthesis featuring a fix from TX, Jblade and I have been in contact and so far it looks fixed. Please let us know if you encounter any issues.
2

User is offline   Trooper Dan 

  • Duke Plus Developer
  • 2,087

#5703

View PostHendricks266, on 28 July 2017 - 03:06 AM, said:

As of the latest synthesis featuring a fix from TX, Jblade and I have been in contact and so far it looks fixed. Please let us know if you encounter any issues.


Cool. I haven't actually touched EDuke32 in a while, but I'll let you know (as always) if and when I find anything.
0

User is online   Hendricks266 

  • EDuke32 Senior Developer
  • 5,350

  #5704

View PostTea Monster, on 04 September 2016 - 01:24 AM, said:

Something is definitely weird in how models are rendered in Polymer. Models appear correctly lit back in ver. 4593. In more recent versions (Can't remember the version No. But in August of this year), Models look very dark. This is not a model issue as the same models appear completely different in the two versions of the renderer.

Posted Image
Same model, same level, same lighting, different SVN version.

This bug is now fixed.
1

User is online   Mark. 

  • Honored Donor
  • 1,836

#5705

YAY

Attached thumbnail(s)

  • Attached Image: rejoicing.jpg

0

User is online   TerminX 

  • el fundador
  • 4,934

  #5706

Sorry guys, that problem was my bad. I optimized a bunch of code and didn't test it thoroughly enough.

EDuke32 ? wiki ? svn builds ? bugs
Join us in #eduke32 on irc.freenode.net!
0

User is online   Mark. 

  • Honored Donor
  • 1,836

#5707

Sorry doesn't grow back the hair I pulled out over the last couple of years. :lol:

And Teamonsters tickets for kicking his dogs out of frustration won't come off his record.

Ahh... A bug fixed and I ordered out for the best tasting pizza I've had in months. Life is good.

This post has been edited by Mark.: 28 July 2017 - 02:50 PM

1

User is offline   Tea Monster 

  • Polymancer
  • 1,730

#5708

I celebrated properly :D

Mark, you are lucky you still have hair!

Posted Image

This post has been edited by Tea Monster: 28 July 2017 - 03:33 PM

0

User is online   Mark. 

  • Honored Donor
  • 1,836

#5709

I celebrated too but I'd rather not show how. ;)

Don't worry Jimmy. I'll send you a PM pic. :P

This post has been edited by Mark.: 28 July 2017 - 03:52 PM

0

User is online   Hendricks266 

  • EDuke32 Senior Developer
  • 5,350

  #5710

View PostHendricks266, on 26 July 2017 - 12:33 PM, said:

Crash logs always help. I think our synthesis compiler has caused debug crash logs to be useless lately, so it would be greatly appreciated if you can build your own with `make RELEASE=0`.

As of r6407, we have worked around the problem and eduke32.crash.log files should once again be useful.
0

User is offline   Sanek 

  • 301

#5711

Have 2 questions for Polymer cult:

1. Is it possible to turn off every single Polymer feature (guns firing, buttons lights, shrinker flickering etc) except the SE-Polymer lights?

2. Is it possible to place the Polymer light feature on a moving object, like that moving lights from Dukepus mod?

I'm working on a map right now that requires some kind of cost/size-efficent way to have lightning, and Polymer lights is the first thing I've been thinking of.
0

User is online   Mark. 

  • Honored Donor
  • 1,836

#5712

In the display menu under Polymer setup there is an option for dynamic lighting. Choose "map only"

If your map will be all or mostly indoors, you can use lots of SE49 point lights before frame rate gets tanked. And as long as SE50 lights aren't large or overlapping with other lighting you should be able to sprinkle those around the map too. Keep in mind that if you start to see some lighting disappear in areas with lots of lights you might have to bump up the setting of "max light passes" or whatever its called.

This post has been edited by Mark.: Today, 07:18 AM

0

Share this topic:


  • 191 Pages +
  • « First
  • 189
  • 190
  • 191
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners and all comments are owned by their posters. Yes, our forum uses cookies. © 2004-2017 Duke4.net and Voidpoint, LLC

Enter your sign in name and password


Sign in options