Duke4.net Forums: EDuke32 2.0 and Polymer! - Duke4.net Forums

Jump to content

  • 210 Pages +
  • « First
  • 180
  • 181
  • 182
  • 183
  • 184
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic

EDuke32 2.0 and Polymer!  "talk about the wonders of EDuke32 and the new renderer"

User is offline   Photonic 

#5431

View PostJblade, on 15 March 2016 - 03:56 AM, said:

Is there a limit to the number of voxels that can be defined? I'm having some problems where the last voxels to be loaded instead load up the first voxels to be defined.



View PostTerminX, on 15 March 2016 - 11:31 AM, said:

There is, but it's 4096 and I doubt you're hitting it.



Voxels interact weird with the memory limit, especially in polymost, try setting the cache higher??

This post has been edited by Drek: 15 March 2016 - 12:59 PM

0

User is offline   Jblade 

#5432

I did try that, no dice - I'll go over and take a look but I can't see any kind of typos I made in the list. All I know is that the last few voxels I've defined start getting replaced by the first ones I've defined. I've only got 256 so yeah I can't of reached the limit.
0

User is offline   TerminX 

  • el fundador

  #5433

Should be fixed in r5671.
1

User is offline   Jblade 

#5434

yep that fixed it, much appreciated!

This post has been edited by Jblade: 16 March 2016 - 02:17 AM

1

User is offline   Spiker 

#5435

How do you enable gloss maps apart from setting a part of an image transparent in specular map? Because for me and some other people it never worked.
0

User is offline   Jblade 

#5436

If you save a game near an ambient sound, the sound will stop playing until you move away and come back into radius again (I tried other menu options but only going into the save menu and saving did it - basically I think when you save and the menu automatically exits and takes you back into the game is what causes it) Not sure if this is just an engine quirk or whatever but I thought it's worth bringing up.

This post has been edited by Jblade: 18 March 2016 - 05:14 AM

0

User is online   Trooper Dan 

  • Duke Plus Developer

#5437

View PostJblade, on 18 March 2016 - 05:14 AM, said:

If you save a game near an ambient sound, the sound will stop playing until you move away and come back into radius again (I tried other menu options but only going into the save menu and saving did it - basically I think when you save and the menu automatically exits and takes you back into the game is what causes it) Not sure if this is just an engine quirk or whatever but I thought it's worth bringing up.


Was the sound actually playing when the game saved? Maybe when you restart the game, the sound is still "playing", but it never ends because it isn't actually playing, so it never starts again.
0

User is offline   Plagman 

  • Former VP of Media Operations

#5438

View PostSpiker, on 18 March 2016 - 01:52 AM, said:

How do you enable gloss maps apart from setting a part of an image transparent in specular map? Because for me and some other people it never worked.


You set the base specular power/factor of your material with the specularpower / specularfactor DEF tokens in the specular map definition, and then the RGB channels modulate the RGB components of the factor separately, while the Alpha channel modulates the power.
0

User is offline   Spiker 

#5439

Ok, I think that changed something. But how to get reflective surfaces? Like the windows that were once hardcoded.
0

User is online   Micky C 

  • Honored Donor

#5440

IIRC there's no way to get reflective surfaces like that in the game from the modder's end. I doubt anything's changed since I last looked into it a while back.
0

User is offline   Jblade 

#5441

Would there be a chance you guys could add a similer shortcut to ; and P or V that allows us to set the shade of all selected sectors, walls, and sprites? Or is there already a mapster script or something that adds that functionality?
0

User is offline   Hendricks266 

  • Weaponized Autism

  #5442

Throw this in a .m32 file, adjust to taste, and include it from the console. Select the sectors in question with RALT and do state jbladeshade.

gamevar i 0 0
gamevar j 0 0

defstate jbladeshade
    for i selsectors
    {
        set sector[i].floorshade 0
        set sector[i].ceilingshade 0

        for j wallsofsector i
        {
            set wall[j].shade 0
        }

        for j spritesofsector i
        {
            set sprite[j].shade 0
        }
    }
ends


Or, a more robust version if you'd like to also be able to select individual sprites and walls with RSHIFT:

gamevar i 0 0
gamevar j 0 0

defstate jbladeshade
    for i selsectors
    {
        set sector[i].floorshade 0
        set sector[i].ceilingshade 0

        for j wallsofsector i
        {
            set wall[j].shade 0
        }

        for j spritesofsector i
        {
            set sprite[j].shade 0
        }
    }

    for i selwalls
    {
        set wall[i].shade 0
    }

    for i selsprites
    {
        set sprite[i].shade 0
    }
ends


Third version, has a variable setshade that you can do set setshade 10 from the console instead of changing and reloading the script:

gamevar i 0 0
gamevar j 0 0

gamevar setshade 0 0

defstate jbladeshade
    for i selsectors
    {
        set sector[i].floorshade setshade
        set sector[i].ceilingshade setshade

        for j wallsofsector i
        {
            set wall[j].shade setshade
        }

        for j spritesofsector i
        {
            set sprite[j].shade setshade
        }
    }

    for i selwalls
    {
        set wall[i].shade setshade
    }

    for i selsprites
    {
        set sprite[i].shade setshade
    }
ends\

1

User is offline   Fox 

  • Fraka kaka kaka kaka-kow!

#5443

In the special functions menu, use the global shade divide with a value of 128. That will set the shade of the whole map to zero.Select the area you want and in the 3D view change the shade. Load the map again so your area with different shade will be copied to the same map.
0

User is offline   Jblade 

#5444

That should do it hendricks, thanks a lot for posting the code!
1

User is offline   Plagman 

  • Former VP of Media Operations

#5445

View PostSpiker, on 20 March 2016 - 10:09 PM, said:

Ok, I think that changed something. But how to get reflective surfaces? Like the windows that were once hardcoded.


If the wall is marked as a mirror it should do the right thing. The map was changed for that wall to be a mirror for these screenshots.
0

User is offline   Spiker 

#5446

Ah, so it won't work for models alone.
0

User is offline   Jblade 

#5447

Just a theoretical question - would it be possible to change a certain pal number's shade table so that the sprite itself is rendered invisible (or close to it, whatever) but everything under the sprite is actually made brighter? How would one go about doing this if it is possible?
0

User is offline   Fox 

  • Fraka kaka kaka kaka-kow!

#5448

You would have to change the sprite blend table.
0

User is offline   Tea Monster 

  • Polymancer

#5449

I don't know if anyone else has noticed this or not, but Mark and I have found that normal. spec and gloss maps don't work on models assigned to custom (user defined) tile numbers.

This bug was introduced in build 5400. 5395 worked OK.

Flyspray won't authenticate my login, so I've PM'd Plagman and Mark has started a thread in the bug thread.

For all of you asking about gloss maps, this is probably why. I tested it with the HUD pistol and it seemed to work.

This post has been edited by Tea Monster: 01 April 2016 - 06:05 AM

0

User is offline   Jblade 

#5450

Just a quick question, how do I use mapster32 script to draw a line between 2 sprites with matching tags? I've tried to take a crack at it but I can't get it to work.
0

User is offline   Gambini 

#5451

I just installed the latest mapster32 snapshot for 64bits but when i fire it in windowed mode, it is way too high in the screen, hiding the top bar and a whole chunk of the tool itslef. Is there any way to position it so the bottom line of the window alligns the taskbar? I know this was possible with older snapshots (maybe with windowpositioning?) but i can´t even drag the top bar to place it properly because it´s hidden way up there where my screen doesn´t reach.

This post has been edited by Gambini: 15 May 2016 - 01:37 PM

0

User is offline   Photonic 

#5452

Right click taskbar select cascade windows.

Should do it for you.


(added;)

You can set the window position manually in mapster32.cfg

Line 59...
; Window positioning, 0 = center, 1 = memory
windowpositioning = 1
windowposx = 3
windowposy = 30


That will be top left corner.

This post has been edited by Drek: 15 May 2016 - 01:53 PM

1

User is offline   Jblade 

#5453

Does STAT_MIRROREDACTOR not work anymore? I vaguely remember seeing someone mention it a while ago; I tried to use it ingame but the statnum isn't being set by anything (or rather I have the sprite set up to log its statnum and there's no result matching STAT_MIRROREDACTOR )
0

User is offline   Fox 

  • Fraka kaka kaka kaka-kow!

#5454

It's only set during animatesprites for sprites displayed on mirrors.
0

User is offline   Jblade 

#5455

I know that, it doesn't work.
0

User is offline   Paul B 

#5456

I'm curious to know if the developers are still intending to release Eduke\Mapster updates? Or has Gearbox put a noose on such activity? Hasn't been any published updates in over a month and I find that kinda strange.

This post has been edited by Paul B: 18 August 2016 - 11:30 AM

1

User is offline   Mblackwell 

  • Evil Overlord

#5457

It's because there's a big code refactoring happening behind the scenes that's not getting pushed until there's been a ton of testing. When that comes, coming with it are a decent number of bug fixes.
1

User is offline   Paul B 

#5458

View PostMblackwell, on 18 August 2016 - 12:58 PM, said:

It's because there's a big code refactoring happening behind the scenes that's not getting pushed until there's been a ton of testing. When that comes, coming with it are a decent number of bug fixes.


Thank you for the update! Looking forward to see what's around the corner. =)

This post has been edited by Paul B: 18 August 2016 - 01:58 PM

0

User is online   Trooper Dan 

  • Duke Plus Developer

#5459

Hey guys, I just tried out EDuke32 r5829 64bit in order to test out one of my mods (Attrition). It wouldn't start and I found this error in the log:

ERROR: NULL weapon! WTF?! WEAPONzd_CLIP

The older snapshot works fine. I don't have time to investigate this, I'm just saying this is what happened.
1

User is offline   TerminX 

  • el fundador

  #5460

Yeah, it's actually a compiler bug. We're working on further changing the affected bits of the source to work around it.
0

Share this topic:


  • 210 Pages +
  • « First
  • 180
  • 181
  • 182
  • 183
  • 184
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks not owned by Voidpoint, LLC are the sole property of their respective owners. Play Ion Fury! ;) © Voidpoint, LLC

Enter your sign in name and password


Sign in options