Duke4.net Forums: I have an ATI card and all I see is white boxes! - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

  • 2 Pages +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

I have an ATI card and all I see is white boxes!  "How to fix the white boxes on ATI cards."

User is offline   The Commander 

  • I used to be a Brown Fuzzy Fruit, but I've changed bro...
  • 1,233

#1

There are four ways to fix this problem.
First off you need to start eduke32 with out the HRP, so disable the HRP by making sure there is no tick in the
"Enable "autoload" folder" on the startup window so we can see the menu text instead of white boxes.

1. Go to the OPTIONS menu then to the VIDEO sub menu and change the TEXTURE FILTER to either LINEAR or NEAREST.
2. Once the game has started, bring down the console by pressing the tilde key then type "r_texcompr 0" (without the quote marks) and press enter
3. Back date your ATI drivers to 10.5
4. Buy a Nvidia card.
5. Download the latest snapshot, this will fix all issues.
http://dukeworld.duk...ke32_latest.zip

Note: If you choose to do option 2 you do not need to do option 1 and vice versa, although option 2 is the most recommended.
I have only put up option 1 as it is the most user friendly way for people not familiar with console commands.
If you backdate to the 10.5 drivers you do not need to bother with anything else.

Note 2: If you choose option 1 or 2 the down side is that no Polymer spotlights will cast shadows.
(This needs to be confirmed by others)

Posted Image

This post has been edited by The Commander: 08 November 2011 - 11:39 PM

2

User is offline   Lunick 

  • Snazzy Tazzy
  • 4,327

#2

I agree to this being a sticky topic.
0

User is offline   Hank 

  • 976

#3

Thanks! So it's ATI not Eduke. :P You guys rock, I said that before, just in case I was ignored, I say it again, you guys rock!

The things I don't know could fill libraries.
0

User is offline   Micky C 

  • Honored Donor
  • 3,200

#4

Lol I bet some idiots are still going to make threads about this, better yet, miss this forum all together and make a thread in the eduke32 and modifications forum.

I don't know why but I crack up every time I read the thread title... Anyway thanks Commander :P

Polymer wishlist: Global illumination, SSAO, Bloom, reflective surfaces, adjustable specular (wetness), volumetric lighting.
Mapper of the Month December 2014.

Herbs? Tell me more!
0

User is offline   Mike Norvak 

  • Music Producer
  • 504

#5

God exists!!!!!!!!!
0

User is offline   The Commander 

  • I used to be a Brown Fuzzy Fruit, but I've changed bro...
  • 1,233

#6

I have added an extra noting.

Quote

Note 2: If you choose option 1 or 2 the down side is that no Polymer spotlights will cast shadows.
(This needs to be confirmed by others)

If anyone else can confirm this it would be nice to know.

Posted Image
0

User is online   Tea Monster 

  • Polymancer
  • 1,501

#7

Option 4 FTW
0

User is offline   Hank 

  • 976

#8

Update

ATI Catalist version 11.* works with HRP on ATI Mobility HD 4530 Series. My laptop has a Dual-Core Mobile M600 2.4 Ghz chip.

I downloaded it about three hours ago.
http://sites.amd.com/us/game/downloads/Pag...on_win7-64.aspx

I can play with a 1600x900 32bpp screen with complex maps like WGRealms2. And my other games ;)

The things I don't know could fill libraries.
0

User is offline   Plagman 

  • VP of Media Operations
  • 350

  #9

You mean you had the "white boxes" problem with earlier versions, updated to 11.1 without changing any settings and it went away?

EDuke32 - "The corrupt doctrine of terror has begun."
0

User is offline   Hank 

  • 976

#10

View PostPlagman, on Feb 13 2011, 07:33 PM, said:

You mean you had the "white boxes" problem with earlier versions, updated to 11.1 without changing any settings and it went away?

Yes. I could not roll back as The Commander suggested, nor install Nvidia on my laptop. So I simply played non HRP, what's the point for HRP without shadows. - After the talk today, on the Polymer thread, I figured let's test the latest, since you are the only other tester. It still proves nothing, only that, for me and on the machine I defined, the white/grey/black boxes are history; they were not always white b.t.w..

And while I'm making a new post, the latest driver also expedites the loading of tiles. Overall, I'm a very happy camper today. I have shadows and the works. Once, more you guys rock! ;)

The things I don't know could fill libraries.

This post has been edited by Hank: 13 February 2011 - 05:18 PM

0

User is offline   Roma Loom 

  • Loomsday Device
  • 72

#11

Finally. Can't wait to test it when I get back home today...

Crap, I'm already on 11-1_mobility_vista_win7_64_dd_ccc_ocl and still no shadows :\


This post has been edited by Roma Loom: 14 February 2011 - 08:48 AM

0

User is offline   gt1750 

  • 3

#12

Radeon 4850, Vista x64, Catalyst 11.2 - white boxes and no shadows

I guess this shit is never gonna get fixed by AMD.

[\\\]=>My automotive art & design gallery on DeviantArt<=[///]

"There's no Photoshop filter for talent!" - HotShoe, S&D
0

User is offline   themaniacboy 

  • 88

#13

None of these options worked for me, only 3 and 4, but i am too lazy to figure that out.
I am sure i played Duke3D with HRP and polymer on a driver from ati higher then 10.5
0

User is online   TerminX 

  • el fundador
  • 4,534

  #14

I'm tired of hearing about this, so texture compression is now permanently disabled whenever ATI's crippled driver is detected as of svn r1841.

EDuke32 wiki svn builds bugs
Join us in #eduke32 on irc.freenode.net!
0

User is offline   Hank 

  • 976

#15

View PostTX, on Mar 12 2011, 11:56 AM, said:

I'm tired of hearing about this, so texture compression is now permanently disabled whenever ATI's crippled driver is detected as of svn r1841.

What? Permanent as in, I can't play HRP because I own AMD? I'm getting another comp Monday, all AMD because of their thread abilities. Can you list exactly who can not play full HRP? I repeat I have r1840 and NO boxes and shadows! I'll post an image in the shack thingy if you don't believe me. There must be another reason why the cards don't work. ;)

The things I don't know could fill libraries.
0

User is online   Tea Monster 

  • Polymancer
  • 1,501

#16

View PostHank, on Mar 12 2011, 09:45 AM, said:

What? Permanent as in, I can't play HRP because I own AMD? I'm getting another comp Monday, all AMD because of their thread abilities. Can you list exactly who can not play full HRP? I repeat I have r1840 and NO boxes and shadows! I'll post an image in the shack thingy if you don't believe me. There must be another reason why the cards don't work. ;)


Yes, because they are crap. This isn't the only project to have problems with ATI's driver issues. I'm fed up reading about them everywhere, God only knows how TX and Plagman feel having to actually rip their stuff apart to fix ATI's driver errors.

This post has been edited by Tea Monster: 12 March 2011 - 11:59 AM

0

User is online   TerminX 

  • el fundador
  • 4,534

  #17

Forcing texture compression to disabled doesn't affect anyone's ability to use the HRP one way or the other, barring the fact that ATI users won't see white boxes anymore. It's identical to solution 2 in the first post of this thread.

EDuke32 wiki svn builds bugs
Join us in #eduke32 on irc.freenode.net!
0

User is offline   Hank 

  • 976

#18

View PostTea Monster, on Mar 12 2011, 02:57 PM, said:

Yes, because they are crap. This isn't the only project to have problems with ATI's driver issues. I'm fed up reading about them everywhere, God only knows how TX and Plagman feel having to actually rip their stuff apart to fix ATI's driver errors.

My heart bleeds. - As a sample for unrelated problems, a painful lesson I learned writing customs msi
http://www.add-in-express.com/creating-add...ler-error-2908/
The point, unless we know the problem we should not blame one corporation or entity. I'm quite happy with AMD.

View PostTX, on Mar 12 2011, 03:01 PM, said:

Forcing texture compression to disabled doesn't affect anyone's ability to use the HRP one way or the other, barring the fact that ATI users won't see white boxes anymore. It's identical to solution 2 in the first post of this thread.

Thanks. I'll tested it. I can live without shadows.

The things I don't know could fill libraries.
0

User is offline   Plagman 

  • VP of Media Operations
  • 350

  #19

? There's no connection between shadows and texture compression.

EDuke32 - "The corrupt doctrine of terror has begun."
0

User is offline   The Commander 

  • I used to be a Brown Fuzzy Fruit, but I've changed bro...
  • 1,233

#20

View PostHank, on Mar 13 2011, 10:57 AM, said:

Thanks. I'll tested it. I can live without shadows.

I still have shadows with this latest revision.

View PostHank, on Feb 14 2011, 02:17 PM, said:

I could not roll back as The Commander suggested,

Did you find anyway to backdate to driver version 10.5?

Posted Image

This post has been edited by The Commander: 12 March 2011 - 02:33 PM

0

User is offline   Hank 

  • 976

#21

deleted.

The things I don't know could fill libraries.

This post has been edited by Hank: 13 March 2011 - 09:34 AM

0

User is offline   Hank 

  • 976

#22

this is an update and revision from my previous post

View PostThe Commander, on Mar 12 2011, 05:30 PM, said:

I still have shadows with this latest revision.

Did you find anyway to backdate to driver version 10.5?

Posted ImageThis is how it looks right now, on an old comp!!! With the latest drivers from AMD CCC 11.2 and with Eduke32 version r1841

I did not back date the driver; I had no reason to install the old version. I simply optimized my computer, updated all of my drivers, including AMDs. Plagman wrote there are no testers. So I played Duke in HRP; and the boxes, I experienced before, simply had disappeared. I uploaded todays snapshot, for those still lamenting about AMD to show that the stuff works.

Thanks TX, it works either way. ;)

The things I don't know could fill libraries.
0

User is online   TerminX 

  • el fundador
  • 4,534

  #23

Of course the white boxes disappeared... the whole point of the change was to disable the feature that ATI's poor GL driver can't handle, because I got tired of hearing about it. ;) Of course, that means if they ever do fix their driver nobody will even notice.

EDuke32 wiki svn builds bugs
Join us in #eduke32 on irc.freenode.net!
0

User is offline   LeoD 

  • 473

#24

View PostTX, on Mar 13 2011, 06:50 PM, said:

Of course the white boxes disappeared... the whole point of the change was to disable the feature that ATI's poor GL driver can't handle, because I got tired of hearing about it. ;) Of course, that means if they ever do fix their driver nobody will even notice.

Only if you point the default download link to the latest version. ;)

Polymost HRP / Z-Pack: customize your HRP | User Map Maphacks
"Redneck Rampage has chickens. If you put a chicken in Duke3D then it's Duke3D with a chicken."
0

User is online   TerminX 

  • el fundador
  • 4,534

  #25

Yeah, that might have to happen sometime soon.

EDuke32 wiki svn builds bugs
Join us in #eduke32 on irc.freenode.net!
0

User is offline   Micky C 

  • Honored Donor
  • 3,200

#26

http://forums.duke4.net/index.php?s=&s...ost&p=77618

Here's to hoping that this is the last post that will ever be made about this stupid ATI bug. May the 14th of March, 2011, 05:36 PM be a historical moment when idiots who can't be bothered scanning over a forum and/or follow simple instructions fall silent until the end of time.

Polymer wishlist: Global illumination, SSAO, Bloom, reflective surfaces, adjustable specular (wetness), volumetric lighting.
Mapper of the Month December 2014.

Herbs? Tell me more!
0

User is offline   The Dukenator 

  • 3

#27

http://gbxforums.gea...65&postcount=11

Quote

http://sites.amd.com...on_win7-32.aspx

Its the one at the top Catalyst Software Suite and I enabled OpenCL, and now my game works.

---------- Post added at 06:36 AM ---------- Previous post was at 06:34 AM ----------



I reinstalled the Latest Eduke32, Latest HRP and Latest DukePlus. Then I download this Driver :

http://sites.amd.com...on_win7-32.aspx But its for Windows 7 32 Bit, I'm sure you can find it for yours. I enabled OpenCL and tested eduke32. I managed to get it working. Make sure you select the on at the top called "Catalyst Software Suite" and make sure you install OpenCL.


The Dukenator's Raptr
These are English forums; anything the moderators can't read is eligible for deletion. - TerminX
For a second there, I thought you was Basky - Ivan

This post has been edited by The Dukenator: 10 April 2011 - 07:07 PM

0

User is offline   BrentNewland 

  • 5

#28

Are ATI cards still having problems? I saw a post from may (http://forums.duke4....dpost__p__85918) saying ATI cards still have compatibility problems. I saw another post that ATI drivers are causing memory leaks and possibly crashes.



*personal notes* ATI changed their OpenGL implementation after Catalyst version 10.4, which caused lots of compatibility issues with older games. New 11.1a/11.2+ drivers are supposed to include fixes for these issues.

Possibly a work-around by using the atioglxx.dll from ATI's 10.4 drivers (see here with downloads here)
0

User is offline   Drek 

  • 1,070

#29

View PostBrentNewland, on 14 July 2011 - 01:07 PM, said:

Are ATI cards still having problems?

Yeah I decided to check by running duke3dw with its hrp. The start menu has a check box for texture compression. I still get white boxes there with the latest driver (11.6)
I followed your link and the instructions there. Once again had to test with duke3dw because compression is disabled for eduke32. It fixed the white boxes in the menu. Yeah! Then crashed when i picked any menu option. LOL!!

EDIT:
I turned off the texture caching and now it works.

This post has been edited by Drek: 15 November 2011 - 11:06 AM

0

User is offline   duky 

  • 0

#30

:P hey i did the second option and only some letters appear but not all so is there any ideas on why cause i really dont know how to set back my drivers can someone maybe tell me how that works plz thx in advance this only happens on the text and nothing else btw graphics run great also i dont have ati i have amd

This post has been edited by duky: 08 November 2011 - 08:23 PM

0

Share this topic:


  • 2 Pages +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic


All trademarks are property of their respective owners and all comments are owned by their posters. Yes, our forum uses cookies. © 2004-2016 Duke4.net and Voidpoint, LLC

Enter your sign in name and password


Sign in options