Duke4.net Forums: Polymer build publicly released - Duke4.net Forums

Jump to content

  • 8 Pages +
  • 1
  • 2
  • 3
  • 4
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic

Polymer build publicly released

User is offline   WedgeBob 

#31

In the past, before this upgrade mod, the only way you could really make translucent water was to use a bunch of sprites, and make them all transparent, and that was a framerate killer to do that. I'll have to build a sample map with water, and see what happens. I'm wondering if it would be possible to make lava and slime glow on the same token, since that would be a REALLY cool effect.
0

User is online   Trooper Dan 

  • Duke Plus Developer

#32

View PostWedgeBob, on Sep 27 2009, 06:31 PM, said:

In the past, before this upgrade mod, the only way you could really make translucent water was to use a bunch of sprites, and make them all transparent, and that was a framerate killer to do that.


That's not true. And anyway, let's not make the thread any more chaotic with off topic discussions like this.
0

User is offline   Stabs 

#33

what, is it just transparent now by default?
0

User is offline   Master Fibbles 

  • I have the power!

#34

All I know is that the water doesn't look right...
0

User is online   Mark 

  • Honored Donor

#35

I downloaded and installed the latest eduke and polymer HRP tonight. Other than transparent water in the test map I don't see anything new with lights or shadows in regular levels. I'll wait a day or 2 and see if someone starts a new thread with the same problem and I find out where I went wrong in the installs.

EDIT: Never mind. I had the box checked to not show the setup screen when loading the game. That is where you choose to turn on Polymer. Its running fine now. DUH! :o

This post has been edited by Marked: 27 September 2009 - 07:31 PM

0

#36

Did you tick the polymer box before launching? I noticed the only way I could get the Polymer HRP to work was to extract it to my main dir and select the polymer_hrp folder in the eduke32 custom game directory.

It wouldn't load in the autoload folder.

This post has been edited by William Gee: 27 September 2009 - 07:31 PM

0

User is offline   Stabs 

#37

You must unzip the polymer hrp and re-zip it using the "store" compression option

put the new polymer_hrp.zip in the autoload folder and than in a folder called "duke3d.grp" should work then, thats how mine is setup
0

User is offline   leilei 

#38

Congrats on the release.

The parallax can look very ridiculous though, especially the water, looks like i'm dipped into some packaging safety sinewave foam

It's also very slow and sometimes textures can even get corrupt. ATI card of course. My favorite map AQUAPARK.MAP crashes in the bathroom :/

This post has been edited by leilei: 27 September 2009 - 09:25 PM

0

User is online   TerminX 

  • el fundador

  #39

We ask that all reproducible crashes and corruption have proper bugs filed here: http://sourceforge.net/tracker/?group_id=1...amp;atid=706724 with screenshots and logs as appropriate.

Things will of course smooth out performance-wise over time, Plagman has some more ideas he's got written down for when he has time to work on this some more. This is really more of a "well, we're not completely there yet, but things aren't moving along at the moment and we're tired of sitting on it so why don't you play with what we've got" sort of release.

Hopefully it'll build up some more interest in the project and we can pick up another developer or two sometime soon!
0

User is offline   DerickVonD 

#40

I go it to work, however I do not see shadows on enemies like they did in the new polymer trailer and I have this very annoying ticking noise the whole time I'm playing.

This post has been edited by DerickVonD: 27 September 2009 - 11:12 PM

0

User is offline   oakman 

#41

Wow! Bravo!

This looks great! Looks even better with the ambient lighting real low :o
0

User is online   NY00123 

#42

While I've got to see this before, I'd say this is awesome. Both the amount of job and the results.

To the ones who wonder, if you want to use Polymer and the Polymer HRP, I recommend to get something (much) better than the GeForce 7900GS. With this, I could get ~20fps in a few places if not lower, and mirrors don't work most of the time.
Mirrors do work without the HRP, so I suppose it's just a limit of the graphics card.

This post has been edited by NY00123: 28 September 2009 - 02:23 AM

0

User is offline   Chip 

#43

Err....you what? RELEASED? :o

This post has been edited by Chip: 28 September 2009 - 04:33 AM

0

User is offline   Mblackwell 

  • Evil Overlord

#44

View PostNY00123, on Sep 28 2009, 05:23 AM, said:

While I've got to see this before, I'd say this is awesome. Both the amount of job and the results.

To the ones who wonder, if you want to use Polymer and the Polymer HRP, I recommend to get something (much) better than the GeForce 7900GS. With this, I could get ~20fps in a few places if not lower, and mirrors don't work most of the time.
Mirrors do work without the HRP, so I suppose it's just a limit of the graphics card.



What's performance if you halve your resolution?
0

User is offline   Chip 

#45

Right then, I've just been playing it and my God this thing runs fast!
My average FPS on my test map was around 30FPS, with Polymer its like 40+....... what ever it is, its definetly much smoother!
In addition to that - FANTASTIC!!!!!! For the first time ever I can see my models with lighting (since I don't know how to have my model displayed with a texture and shading in Blender3D) and its just amazing!
Well done!




However I appear to have audio related crashes during Polymer. I believe it to be audio related since when I have sound disabled Polymer does not crash even after a long play. With sound on the game can crash within a minute depending on how many .ogg audio files are played.
In my test map there's something like 60 actors all playing .ogg sound files which crahses Polymer (not Polymost) within minutes.
With sound off, (not neccaserly music) Polymer will not crash for me.

Also I have the old horrible clicking on .ogg sound files which I had on the last non-polymer public release which was then removed from the site shortly after TX uploaded it.

This post has been edited by Chip: 28 September 2009 - 05:25 AM

0

User is offline   lycanox 

#46

The game crashes hangs when trying to load a level then the music begins to stutter for a short while. Starts to play normally again. And than crashes.

Odd, as last time I checked. Ati X1600 Radeon should be able to run Polymer.

This post has been edited by lycanox: 28 September 2009 - 06:00 AM

0

User is online   NY00123 

#47

View PostMblackwell, on Sep 28 2009, 04:09 PM, said:

What's performance if you halve your resolution?


Maybe I should test again as, apparently, saving texture cache to disk was disabled :o
Well initially I tried this with 1280x1024; Many other graphical-related settings (if not all) should be set high quality.
Then I got the frame-rate of ~20fps 'in the outside', and in the main room where you can go from there to bathrooms and the theatre.
This is basically the case I mentioned before, just with a little more info.

Then I changed to 640x512 (same ratio of 5:4). Could be quite quick, even above 100fps, in places without too many details/lights.
It got to run at 20-30fps in the same two sections I mentioned before.
There were a few cases it got 'stuck', maybe for loading new textures.

Finally, I actually tried 320x240. Was 30-40fps in the 'heavy' sections this time. Also quicker to quit the game.

In all cases, mirrors weren't fully working as expected (being plain black most of the time). Could be the hardware here.
0

User is offline   asdasd 

#48

I have an ATI radeon HD 4570, 4gb ram....and the game its going slow!!! WTF! 1366*768 is my resolution
does my graphic card isn't enough?

This post has been edited by asdasd: 28 September 2009 - 06:34 AM

0

User is offline   corpy 

#49

O. HELLYEAH! ;) THANKS THANKS AND MORE THANKS!
:o
0

User is offline   Parkar 

  • Honored Donor

#50

View Postleilei, on Sep 28 2009, 07:25 AM, said:

Congrats on the release.

The parallax can look very ridiculous though, especially the water, looks like i'm dipped into some packaging safety sinewave foam

It's also very slow and sometimes textures can even get corrupt. ATI card of course. My favorite map AQUAPARK.MAP crashes in the bathroom :/


Note that quiet a few of the textures in the Polymer HRP are quick dirty tests, including the water. All I did with it was run the hrp textures through crazy bump to get displacement and normal maps.
0

User is offline   Mikko 

  • Honored Donor

#51

So, where are instructions on how to use (in Mapster) the new lighting system?
0

User is online   Trooper Dan 

  • Duke Plus Developer

#52

View PostMikko_Sandt, on Sep 28 2009, 07:51 AM, said:

So, where are instructions on how to use (in Mapster) the new lighting system?


I wrote some instructions in the first post of the Polmer and EDuke32 thread about placing lights.
0

User is offline   HellFire 

#53

Ive got some problems with polymer too. Some build tricks that have heavy use of parallax doesnt seem to work with polymer. It also misalign walls with the "bottom texture swap tile bit" , the key '2' in build. Heres 2 shots from an simple map im working on:
Bugs with parallax:(first sshot with classic renderer, second shot with polymer)
http://img223.imageshack.us/img223/2507/duke0003.th.jpghttp://img19.imageshack.us/img19/7673/duke0002.th.jpg
Misaligned textures:
http://img223.imageshack.us/img223/2668/duke0000.th.jpghttp://img180.imageshack.us/img180/4108/duke0001.th.jpg
And i found another very strange thing, now using the polymer hrp plagman posted:
http://img182.imageshack.us/img182/1346/duke000.th.jpg
Just go to the cinema room, and walk crouched and take a look at the parallax mapping in the floor texture, its all weird. And it only happens in this room, outside in the street where the same texture is used this doesnt happen, maybe its caused by the texture expansion flag ('E' in build). if it only happens in my system then i think ill record a video of it cause a picture cant show much... tell me if its an issue here or if it happens for everyone...
0

User is offline   Chip 

#54

After playing around with the lighting I just want to say it just gets better and better!

However spotlights for me don't seem to be very bright. They're dull at best and so the shadows don't stand out much at all and that's with all 3 RGB values set to 256. Is there any other way to make them brighter?

Also sprites with the con command "spritenoshade" (if that's what it was called) doesn't seem to work anymore and get shaded in the same way as other sprites.

This post has been edited by Chip: 28 September 2009 - 10:47 AM

0

User is offline   Plagman 

  • Former VP of Media Operations

#55

For the messed up parallax for the water and the cinema floor: the parallax scale currently depends on the texture scale, which is a bug and needs to be fixed. That means the parallax will look good on some occurences of the textures but glitch with others. Try messing with r_pr_overrideparallax and r_pr_parallaxscale (0.1 is a good starting value) to see how it would look with the proper value defined.

Thanks for any map glitches and misaligned textures reports, please attach/link the maps whenever you encounter such a problem or a crash so that I can fix any remaining oversights.

Chip: what card are you using? Can you post a screenshot of the spotlight dullness? Does it go away if you disable shadows? (r_pr_shadows) It might be a case of shadow texture aliasing.
0

User is offline   Spiker 

#56

Nice work guys! Keep it up :o
0

User is offline   WedgeBob 

#57

Since it works so well on Duke 3D, when'll other BUILD-engine based games get this treatment? Lo Wang would be rather happy in a new light, literally.
0

User is offline   Jesus is King 

  • Jeffrey Epstein didn't kill himself

#58

View PostWedgeBob, on Sep 28 2009, 04:58 PM, said:

Since it works so well on Duke 3D, when'll other BUILD-engine based games get this treatment? Lo Wang would be rather happy in a new light, literally.

Don't count on it.
0

User is offline   Omni 

#59

Registered to say thanks for the solid release, getting 130-300 fps with polymer + HRP in level 1. The lighting looks very good so far. No idea if the sound is buggy tho, I broke my headphones =p
0

User is offline   Plagman 

  • Former VP of Media Operations

#60

130 fps with the E1L1 maphacks that Parkar did is pretty impressive. What's your system like?

Anyway, share your best screenshots people :-)
0

Share this topic:


  • 8 Pages +
  • 1
  • 2
  • 3
  • 4
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners. Instead of reading this text, you could be playing Ion Fury! ;) © 2019 Voidpoint, LLC

Enter your sign in name and password


Sign in options