Duke4.net Forums: Polymer build publicly released - Duke4.net Forums

Jump to content

  • 8 Pages +
  • « First
  • 2
  • 3
  • 4
  • 5
  • 6
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic

Polymer build publicly released

User is offline   Plagman 

  • Former VP of Media Operations

#91

Are you sure the E1L1 maphacks are properly enabled? For example, is the Cinema sign emitting a red light like on the second screenshot of that picture?

http://img21.imageshack.us/img21/5826/dukepolymer8.jpg

You need to make sure Polymer is enabled before E1L1 is loaded and that the renderer doesn't get reinitialized after E1L1 loads or else the static lights (and shadows) will disappear; don't alt-tab or minimize EDuke32 as this will reinitialize the renderer. If after doing all that and making sure the Cinema sign is lit you still don't get the grating shadow, please attach your log after running the `glinfo` command into the console as this could be a problem with hardware shadow rendering.

This post has been edited by Plagman: 30 September 2009 - 09:44 AM

0

User is offline   Alan 

  • Hellspawn

#92

Is there a difference in running Polymost and Polymer in the settings? It seems the only options are software and OpenGL. I can't run Polymer, but the second I turn on 32 bit mode, all of the menu graphics are trashed and the levels are solid black. I'm just trying to run Polymost.
0

User is offline   Stabs 

#93

k heres a pic, nothing special, just the md3 light iam using now, i used glow maps on the bulb for a much more realistic effect


0

User is offline   LeoD 

  • Topic #3513

#94

View PostAlan, on Sep 30 2009, 09:40 PM, said:

Is there a difference in running Polymost and Polymer in the settings? It seems the only options are software and OpenGL. I can't run Polymer, but the second I turn on 32 bit mode, all of the menu graphics are trashed and the levels are solid black. I'm just trying to run Polymost.

You can enable it in the startup window or edit eduke32.cfg : Polymer = 1
0

User is offline   DerickVonD 

#95

How do you get this to work multiplayer? Also on these demo videos I keep seeing Duke with a shadow and the enemies with shadows. I don't see the shadows on the enemies or Duke. I even turned shadowing on. It really doesn't look as good as it does in the demos. If it wasn't for the glow from the fire and darkness of the levels I wouldn't know it was on. Why does it not look as good as on the demo videos I've seen?

This post has been edited by DerickVonD: 30 September 2009 - 04:28 PM

0

#96

I made a video of WGRealms with polymer. http://www.youtube.c...h?v=O39tXFlASXY
I guess I should edit the maps add some spotlights and put together a easy to install full polymer pack.
0

User is offline   DerickVonD 

#97

Nevermind I got it to work. How do I get this to work multiplayer? Also is it better to have the polymer in its own folder or extracted to the main folder? I extracted everything to the main directory and it works single player now, but I would really like it to work multiplayer.
0

User is offline   Alan 

  • Hellspawn

#98

View PostLeoD, on Sep 30 2009, 06:28 PM, said:

You can enable it in the startup window or edit eduke32.cfg : Polymer = 1


I wanted it turned off, actually. I was assuming it was using Polymer by default since everything was, well.. fucked up. I wanted to use Polymost (OpenGL that my computer can handle).

View PostDanM, on Sep 30 2009, 05:12 PM, said:

k heres a pic, nothing special, just the md3 light iam using now, i used glow maps on the bulb for a much more realistic effect


Looks nice. Only complaints are the skins look flat in terms of color and the depth given to the floor is too much.
0

User is offline   DerickVonD 

#99

Okay how come I can only see shadows in E1L1?

This post has been edited by DerickVonD: 30 September 2009 - 05:55 PM

0

User is offline   Sobek 

  • There's coffee in that nebula!

#100

View PostDerickVonD, on Oct 1 2009, 12:25 PM, said:

Okay how come I can only see shadows in E1L1?


As far as I know, maphacks are only in place for E1L1 so far. It's more of a test, and a performance-hogging one at that.

This is not a final, perfect release of Polymer, everyone understands that, right?
0

User is offline   Doomfrost 

#101

Congrats on the public release! Ran into a few bumps though. I've been getting some lag when I approach an area that uses lighting or when I switch to a weapon that has a light source (shrink ray for one) I've also been getting screen flickering when using models and sometimes items or enemies will turn into a jagged mess polygons. Other than that shadows and lightning works fine.

I can send you my log file if you need it. There's a slew of error messages in there that reads: "Error: glGetTexLevelParameteriv returned GL_FALSE!" followed by: "No cached tex for tile X pal Y." (X and Y being the numbers)

Again congrats on the release.
0

User is offline   Devon 

#102

someone please tell me how to make this work ?


I never had any problems running the hrp until now when the polymer is public.

i got the latest hrp zip, latest eduke32 and the polymer hrp zip from this forum.



tried to put them in the autoload map but nothing happens :) not even the normal hrp works i tried with and without polymer box checked amung other things.


someone please tell me in simple steps how to make it work ?
0

#103

Extract the polymer HRP to your duke folder, then select the polymer HRP folder in the Eduke32 custom game directory, it is shown on the eduke32 startup menu.
0

#104

View PostWilliam Gee, on Oct 1 2009, 02:32 AM, said:

I guess I should edit the maps add some spotlights and put together a easy to install full polymer pack.


Maybe you should do that after WGRealms2 is out.

This post has been edited by KillerBudgie: 01 October 2009 - 03:06 AM

0

User is offline   Devon 

#105

View PostWilliam Gee, on Oct 1 2009, 03:04 AM, said:

Extract the polymer HRP to your duke folder, then select the polymer HRP folder in the Eduke32 custom game directory, it is shown on the eduke32 startup menu.





thing is that the the option to choose directorys etc in the startup menu isnt there anymore i can see the text but nothing more. i tried to rezise the window to see it but cant do that either.



in other words i cant change the *custom game content directory* in the start menu cause it isnt there. i see the text but the list isnt there to view or do anything with.


i used the hrp since the first versions so this is so lame.

This post has been edited by Devon: 01 October 2009 - 03:11 AM

0

#106

Delete eduke32 and your cfg files install eduke32 again and select the directory.
0

User is offline   Devon 

#107

View PostWilliam Gee, on Oct 1 2009, 03:30 AM, said:

Delete eduke32 and your cfg files install eduke32 again and select the directory.




didnt work.


give me an directory explanation for example c:/duke3d/autoload/polymer.zip

i just wanna be totally sure if i put the stuff in the right folder deleting the game and repack it didnt work.



cause everything works fine when i dont use the new build with polymer.



edit: i still cant understand why i cant check/uncheck custom files in the startup menu it doesnt show at all i tried to delete and unpack it again and again etc etc etc. still i cant choose what to have like for example dukeplus or the hrp.

This post has been edited by Devon: 01 October 2009 - 03:58 AM

0

User is offline   Stabs 

#108

autoload/duke3d.grp/polymer_hrp.zip

unzip the polymer hrp zip and re-zip using STORE compression option.
0

User is offline   Devon 

#109

View PostDanM, on Oct 1 2009, 04:08 AM, said:

autoload/duke3d.grp/polymer_hrp.zip

unzip the polymer hrp zip and re-zip using STORE compression option.



done that now too didnt work either.


seriously im not new at computers and the hrp this is very strange.
0

User is offline   Stabs 

#110

hmm try this

eduke32.cfg

[Setup]
ConfigVersion = 195
ForceSetup = 1
NoAutoLoad = 0 <== try changing that to 0 if its 1
SelectedGRP = "duke3d.grp"
ModDir = "DukePlus"
0

User is offline   Devon 

#111

View PostDanM, on Oct 1 2009, 04:35 AM, said:

hmm try this

eduke32.cfg

[Setup]
ConfigVersion = 195
ForceSetup = 1
NoAutoLoad = 0 <== try changing that to 0 if its 1
SelectedGRP = "duke3d.grp"
ModDir = "DukePlus"




still nothing m8.

what amazes me here is that i cant see anyone else having this problem.

Hrp just wont work when i use the newest eduke32 build with or without polymer.. doesnt matter where i put the files doesnt matter what i do with the config doesnt matter what i do with the filepaths or names of the files nothing works.

guess i have to stick with the old hrp 4.0 installer version of the game.. =(:::



speccs.

xp 32 sp3
8800gts
8gb ram

well whatever it shouldnt make any differnce besides my computer is clean and nice i actually foramted it yesterday and everything is perfectly updated etc.

This post has been edited by Devon: 01 October 2009 - 04:51 AM

0

User is offline   Stabs 

#112

strange, you seem to know what your doing so iam not sure what could be stopping this

not in any long directorys or anything i take it?
0

User is offline   Devon 

#113

View PostDanM, on Oct 1 2009, 06:04 AM, said:

strange, you seem to know what your doing so iam not sure what could be stopping this

not in any long directorys or anything i take it?




nope just in c:/duke3d/autoload/duke3d.grp


i really hope they make a new offical hrp installer cause this is ridicilus really.
0

User is offline   corpy 

#114

View PostPlagman, on Sep 30 2009, 09:44 AM, said:

Are you sure the E1L1 maphacks are properly enabled? For example, is the Cinema sign emitting a red light like on the second screenshot of that picture?

Not sure.
Here is Glinfo:
http://www.upload.ee/image/210137/eduke32_2009-10-01_17-33-03-10.jpg
:)
0

User is offline   Chip 

#115

Back on the 3DRealms forum, TerminX said that sectors can cast lighting and shown a picture of Zoo.map with light coming through an opening in the ceiling which caused the player to cast a shadow - basically a ceiling was working like a spotlight.

How do I make my sectors do this too? I want to make my lava floors glow red!
0

#116

@Devon
Did you mean the custom directory box isn't showing? After seeing everything you tried, I can only think of one thing, the "Controls" (I can't remember what they are really called - hope you know what I am on about) might be messed up, do you have another system to try it on?

A lot of software installs its own versions (Like sliders, text fields and that drop down box that is missing) - have you installed something that might have done that and possibly overridden the originals recently? Like software with it's own custom ones? if so, try re-installing that software.

This isn't likely at all, but I have seen it happen once before on one of my systems, it's just a thought.
0

User is online   NightFright 

  • The Truth is in here

#117

I take it this current Polymer HRP is based on standard HRP v4.0, so no update pack stuff is integrated. I will have feedback from Park to see whether we can issue a pack with latest contents and also Polymer stuff. This should probably not happen before we have everything we need, so it could take some more time. However, at the moment it is a good opportunity since no new entries to the HRP are made.
0

#118

Found and clicked the Polymer setting "on" on the EDuke launcher and it rendered correctly, Had to repack the polymer_hrp.zip as it is not compressed correctly as posted. It all runs well now, so I am off to enjoy it :)

This post has been edited by Another Duke Fan: 01 October 2009 - 08:55 AM

0

User is offline   Parkar 

  • Honored Donor

#119

View PostNightFright, on Oct 1 2009, 05:36 PM, said:

I take it this current Polymer HRP is based on standard HRP v4.0, so no update pack stuff is integrated. I will have feedback from Park to see whether we can issue a pack with latest contents and also Polymer stuff. This should probably not happen before we have everything we need, so it could take some more time. However, at the moment it is a good opportunity since no new entries to the HRP are made.


My plan is to get the new SVN repository structure sorted out so we can use it for a complete Polymer HRP. With Complete I mean that it will have both Polymer and Polymost content. Even if it results in a pack thats a few 100 megs bigger I think it's worth it.

We can then just strip this pack from all the Polymer specific content to generate a HRP like the old ones with simple textures.

We could also do the oposite to create a Polymer only pack that is a few 100 megs smaller.

I will update the HRP wiki with naming conventions etc so it's easy to tell what type of texture an image is.

As has been said beofre the plan is to have a more open SVN now where each artist (the most active at least) can put in their content right away instead of always going by me and Nightfright.
0

User is offline   Devon 

#120

View PostParkar, on Oct 1 2009, 09:15 AM, said:

My plan is to get the new SVN repository structure sorted out so we can use it for a complete Polymer HRP. With Complete I mean that it will have both Polymer and Polymost content. Even if it results in a pack thats a few 100 megs bigger I think it's worth it.

We can then just strip this pack from all the Polymer specific content to generate a HRP like the old ones with simple textures.

We could also do the oposite to create a Polymer only pack that is a few 100 megs smaller.

I will update the HRP wiki with naming conventions etc so it's easy to tell what type of texture an image is.

As has been said beofre the plan is to have a more open SVN now where each artist (the most active at least) can put in their content right away instead of always going by me and Nightfright.



sounds like a very good idea too me :)
0

Share this topic:


  • 8 Pages +
  • « First
  • 2
  • 3
  • 4
  • 5
  • 6
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks not owned by Voidpoint, LLC are the sole property of their respective owners. Play Ion Fury! ;) © Voidpoint, LLC

Enter your sign in name and password


Sign in options