Duke4.net Forums: flashlight mod not working - Duke4.net Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

flashlight mod not working

User is offline   Mark 

#1

I haven't narrowed it down to a specific version yet but the popular flashlight mod based on Darkus's original mod has stopped working. No light is shone. I have tested in my Graveyard and Suburbs mods so far. I re-bound the key for it in the menu just to rule it out. No good. This is using the latest eduke32 from a day or 2 ago.

I'm also noticing some of my swing doors that haven't been touched for many months in an area that hasn't been touched for months are glitching and showing parallaxed floors as though they are crossing over sectors.. And the sequence that the map starts with is not running it's con commands. IDK if those are related to the newer eduke or not. I'll be doing further testing and report back.

Flashlight and doors issues are gone using 9305 from Jan of this year. So the problem is fairly recent. I'll bisect to find the start of the problem. However, I have noticed again that polymer lights disappear if you exit to the menu and reload the map. So there is more to hunt down.

This post has been edited by Mark: 22 November 2021 - 07:42 PM

0

User is offline   TerminX 

  • el fundador

  #2

Polymer is currently under semi-active development and some things may be broken. I think for that flashlight mod I'll probably have to check what it's doing in CON and see if there's a way I can get it working again without having to change the mod any. Polymer lights have interpolation etc now and the way the mod is moving the light around probably isn't compatible.
3

User is offline   Mark 

#3

9782 is the last good working flashlight and the swing door parallaxed floor was juuust starting to barely flicker. Next revision 9787 has no flashlight and has wonky door floors.

I still need to find the version that polymer lights disappear on map reload from the menu.

This post has been edited by Mark: 22 November 2021 - 09:02 PM

0

User is offline   Jimmy 

  • Let's go Brandon!

#4

Good to hear Polymer is being worked on.
0

User is offline   Mark 

#5

For whatever reason, I'm no longer getting the problem of the polymer lights disappearing on map reload on any revision. Lets hope it stays that way. It seemed to happen seldom and randomly so I kind of ignored it.
0

User is offline   TerminX 

  • el fundador

  #6

Can you put one of the glitchy doors into a separate .map file and attach it here? One of the changes I made to Polymer replaces the polygon tessellation code with something different and it seems to be having trouble with a couple of maps.
0

User is offline   Mark 

#7

I gave a very close look at the doors that were glitching. The pivot corner verts were so close to the wall corner verts it was hard to see they were separate. Those doors were made by the previous mapper before I took over. I always space mine out a teeny bit further. So I turned off grid locking and I spaced them like I normally do and no problems. I guess I was just lucky they weren't glitching in previous eduke32 revisions. I wonder if the other doors you've mentioned have been built with verts closer than recommended.

If I go any closer than this it will glitch. I moved the pivot SE out of the way so you could see the verts. Its usually packed tightly in that corner. Before my fix the vert bodies were partially overlapping instead of touching like they are now. This is maximum zoom in Mapster.

So IMO your changes are fine and glitching doors may be poorly made. There is no need to get any closer than this.

Attached thumbnail(s)

  • Attached Image: DOOR CORNER.png


This post has been edited by Mark: 23 November 2021 - 10:03 AM

0

User is online   Aleks 

#8

View PostMark, on 23 November 2021 - 09:57 AM, said:

I gave a very close look at the doors that were glitching. The pivot corner verts were so close to the wall corner verts it was hard to see they were separate. Those doors were made by the previous mapper before I took over. I always space mine out a teeny bit further. So I turned off grid locking and I spaced them like I normally do and no problems. I guess I was just lucky they weren't glitching in previous eduke32 revisions. I wonder if the other doors you've mentioned have been built with verts closer than recommended.

If I go any closer than this it will glitch. I moved the pivot SE out of the way so you could see the verts. Its usually packed tightly in that corner. Before my fix the vert bodies were partially overlapping instead of touching like they are now. This is maximum zoom in Mapster.

So IMO your changes are fine and glitching doors may be poorly made. There is no need to get any closer than this.


If the changes would break swing doors that are spaced closer than that, it would glitch a lot of maps which make doors like that. I also usually leave just 1 unit between doors and the lintel, if the SE sprite is place correctly (tip: turning off effector descriptions in 2D mode), it works well. Also when your door glitchs, it's good to DNDEBUG the map with the door in open state then check in Mapster what went wrong.
1

User is offline   Mark 

#9

Leaving the gap at 1 unit away like you do would be too much for me. As you can see I usually have them less than 1/2 unit away, closer to 1/4 unit away. So if mappers are making them even closer than in my pic I think they are asking for trouble.

This post has been edited by Mark: 23 November 2021 - 07:40 PM

0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks not owned by Voidpoint, LLC are the sole property of their respective owners. Play Ion Fury! ;) © Voidpoint, LLC

Enter your sign in name and password


Sign in options