Duke4.net Forums: AMC TC 3.6 released! - Duke4.net Forums

Jump to content

  • 3 Pages +
  • 1
  • 2
  • 3
  • You cannot start a new topic
  • You cannot reply to this topic

AMC TC 3.6 released!  "Now with Polymost support!"

#1

Posted Image

https://www.moddb.co...tc-v36-released
15

User is online   Radar 100 Watts 

  • Zionist Shill

#2

POLYMOST HERE I COME!!!
0

#3

Make sure you run opengl when starting the game too. ;)
0

#4

View Postsebabdukeboss20, on 29 September 2019 - 09:52 AM, said:

Make sure you run opengl when starting the game too. ;)


If I do that, it always crashes, no matter its upon starting or within the menu, windowed or fullscreen T_T
It must be the EDuk32 version since polymost always worked with other mods >_>

0

#5

View PostTheDragonLiner, on 29 September 2019 - 10:46 AM, said:

If I do that, it always crashes, no matter its upon starting or within the menu, windowed or fullscreen T_T
It must be the EDuk32 version since polymost always worked with other mods >_>


What is the error message?
Are you using the included .exe?
What are your CPU/GPU specs?
0

#6

Quote

If I do that, it always crashes, no matter its upon starting or within the menu, windowed or fullscreen T_T
It must be the EDuk32 version since polymost always worked with other mods >_>


Same issue, also, it would problematic if the included custom .exe is 64-bit only from now on. At least I identify those who have the typical "window" icon as one of them.

A similar thing happened for Kickass Duke, fixed after Richardstorm changed the snaphot.

This post has been edited by Fantinaikos: 29 September 2019 - 05:19 PM

0

User is offline   supergoofy 

#7

EDuke32 Fork for the AMC TC (windows binaries for 64 bit and 32 bit architectures)

https://github.com/c...indows-binaries

This post has been edited by supergoofy: 29 September 2019 - 06:13 PM

2

User is offline   Forge 

#8

View Postsupergoofy, on 29 September 2019 - 06:12 PM, said:

EDuke32 Fork for the AMC TC (windows binaries for 64 bit and 32 bit architectures)

https://github.com/c...indows-binaries

gonna go out on a limb here and say that it maybe should have been distributed with both amc_tc.exe files
0

User is offline   Jblade 

#9

no point adding more confusion since people seem to struggle even running the 1 exe in there.
3

#10

I don't think we're having the same 64-32 missap as last time because my CFG record specifies this is 32 and not 64 >_>

Doom64Hunter, I don't have any special warning, it's the same deal as with the previous versions HOWEVER, just like the previous version, the only warnings I have are a bunch of "Tile##.PNG doesn't exist" but I never saw anything out of the ordinary regardless, until now ...

I played through Megabase in Classic, and I had trasparent/missing textures on the tall pipes in the base, and in the reactor chamber with the Protector Drones. Also mirrors make the game lagg like crazy now.

But if there's one thing postivie I can say, it is the fact the game seems to run better than before, for the few I witnessed. Saving is immediate, and the cursed EDuke32's handling lagg like shit is no more. AMC Base 1 runs slow but very steady ! While it was irritatingly jittering and thus hard to navigate before so extreme kuddos for that EDuke guys !

EDIT : I have tried Supergoody's idea. It doesn't change anything, therefore, the included EDuke really is 32, it confirms what I say on my first line.


This post has been edited by TheDragonLiner: 29 September 2019 - 11:05 PM

0

User is offline   Jim 

#11

Hello, since polymost is now supported, can you guy put out a version of the custom eduke with texture filtering renabled? I want to see how the AMC tc looks with texture filtering. Thanks!
0

User is offline   Jblade 

#12

it's not 32bit dragon, I don't know what the hell you're going on about.

Jim I hate the texture filtering so that won't happen, sorry.

This post has been edited by Jblade: 29 September 2019 - 11:12 PM

0

#13

View PostJblade, on 29 September 2019 - 11:11 PM, said:

it's not 32bit dragon, I don't know what the hell you're going on about.

Jim I hate the texture filtering so that won't happen, sorry.


Hey it's not my fault if the log tells me it's 32 while you've included 64 !
Anyway, using the 32 from Supergoody's link gives out the same results, so the problem must not come from the fact it's either 32 or 64. It has to be something else ...

0

User is offline   Jblade 

#14

you're not running the proper exe then, use amctc.exe that comes with the zip and nothing else. The exe is NOT going to mistakenly tell you it's 32bit, that is not something that occurs.
0

#15

View PostJblade, on 30 September 2019 - 12:47 AM, said:

you're not running the proper exe then, use amctc.exe that comes with the zip and nothing else. The exe is NOT going to mistakenly tell you it's 32bit, that is not something that occurs.


I have tried both the included .exe and the one from goofy's link, the logs of both tell me it's Eduke32. So either you really included a 32 by mistake or the "something" that never occurs is occuring O_o
As I said, using the included one or the 32 one from goffy's link give the exact same results. I didn't try the 64 from the link but I doubt it's gonna behave any differently >_>

As I said, I think the problem mustn't come from the fact it's either a 64 or a 32, there must be something else ...

I have an idea. Would it be possible to provide an .exe, in which the Polymost settings are as minimal as possible ? Maybe there's something in the default setting that causes a problem ?
Just a thought >_>

0

User is offline   conoklast 

#16

I have to say that the new intro is badass! hat's off to the devs and sebab for all his great work.
2

User is offline   Jblade 

#17

View PostTheDragonLiner, on 30 September 2019 - 02:05 AM, said:

I have tried both the included .exe and the one from goofy's link, the logs of both tell me it's Eduke32. So either you really included a 32 by mistake or the "something" that never occurs is occuring O_o
As I said, using the included one or the 32 one from goffy's link give the exact same results. I didn't try the 64 from the link but I doubt it's gonna behave any differently >_>

The included exe is 64bit. This is not an argument. I don't know what you're doing. Just use the exe included in the mod, how can I drill this into your head.
0

User is online   Micky C 

  • Honored Donor

#18

View PostTheDragonLiner, on 30 September 2019 - 02:05 AM, said:

I have tried both the included .exe and the one from goofy's link, the logs of both tell me it's Eduke32.


Is one of them an "amctc.log", and does it say "EDuke32 (AMC Custom) r8133" at the top? The custom bit being the important part here.
0

#19

I would like to first mention that the custom eduke32 build is only intended for use with the AMC TC, and not for use with Duke Nukem 3D.
It makes a small number of changes that might interfere with how Duke3D works (although precautions have been taken to limit the effect) and it has been extensively labelled as such to prevent potential confusion. Do not report bugs you find with this modified exe to the EDuke32 developers -- report them to us instead, and we will relay it if we can confirm that it is an issue in the unmodified executable. (of course you can also test this yourself if you so wish)

Originally it started as a simple raise of the sound limit, but it has allowed us to upgrade the engine version without having to bother the eduke32 devs with requests for special cases and exceptions -- especially in light of the recent collision changes. We do not intend to make particularly heavy changes (such as altering the renderer) -- we will only add what is feasible and makes sense to have. Texture filtering is not one of those things.

View PostTheDragonLiner, on 29 September 2019 - 10:21 PM, said:

I don't think we're having the same 64-32 missap as last time because my CFG record specifies this is 32 and not 64 >_>


The CFG does not determine the architecture for which the binary was built. If you look at the very first two lines of the log, it should say the following for the included exe:
EDuke32 (AMC Custom) r8133
Built Sep 27 2019 12:03:49, GCC 9.2.0, 64-bit 


View PostTheDragonLiner, on 29 September 2019 - 10:21 PM, said:

Doom64Hunter, I don't have any special warning, it's the same deal as with the previous versions HOWEVER, just like the previous version, the only warnings I have are a bunch of "Tile##.PNG doesn't exist" but I never saw anything out of the ordinary regardless, until now ...

Those errors can be ignored, these are definitions for episode 4 tiles that haven't been removed from the DEF file properly, and won't cause adverse effects on the game.

View PostTheDragonLiner, on 29 September 2019 - 10:21 PM, said:

I played through Megabase in Classic, and I had trasparent/missing textures on the tall pipes in the base, and in the reactor chamber with the Protector Drones. Also mirrors make the game lagg like crazy now.

This is a bug in unmodified eduke32, which I reported here: https://forums.duke4...les-are-loaded/
As for the mirror, I'm not sure what's happening there. Might be hardware-dependent problems.

View PostTheDragonLiner, on 29 September 2019 - 10:21 PM, said:

But if there's one thing postivie I can say, it is the fact the game seems to run better than before, for the few I witnessed. Saving is immediate, and the cursed EDuke32's handling lagg like shit is no more. AMC Base 1 runs slow but very steady ! While it was irritatingly jittering and thus hard to navigate before so extreme kuddos for that EDuke guys !

Apart from our custom changes (which should hopefully have minimal effects on how the game performs) the build is now roughly on the same revision as Ion Fury. They have done great work on making the game perform better, and on porting classic mode features into polymost.

View PostTheDragonLiner, on 29 September 2019 - 10:21 PM, said:

EDIT : I have tried Supergoody's idea. It doesn't change anything, therefore, the included EDuke really is 32, it confirms what I say on my first line.

Included in the zip is the 64 bit version, the 64 bit version on the git repo should be the same apart from the build date (I compiled that one later, on the same codebase). The 32 bit version on the repo has been compiled using MinGW32, over MSYS on Windows, and the second line of the autogenerated log reflects this.

View PostJblade, on 30 September 2019 - 12:47 AM, said:

you're not running the proper exe then, use amctc.exe that comes with the zip and nothing else. The exe is NOT going to mistakenly tell you it's 32bit, that is not something that occurs.


Considering he downloaded the exe from the repo, he is running the correct one. In that case the issue must be related to something else, again potentially hardware related.
Which is why I originally asked about the CPU/GPU specs, we know of certain GPUs and CPU configurations where the recent revision wouldn't run properly, even with a unmodified EDuke32.
2

User is offline   Forge 

#20

View PostDoom64hunter, on 29 September 2019 - 12:27 PM, said:

What is the error message?

What are your CPU/GPU specs?

^ This info and the amc_tc log file should be included with the error being reported when the game is not launching, game is crashing, or serious graphical / performance issues occur.
Failure to do so means your problem can't / won't be addressed.

Thank you for your cooperation.

This post has been edited by Forge: 30 September 2019 - 09:12 AM

0

#21

Firstly, it is only now that I notice the line in the log that says "64 Bit" with the included one, I just wasn't looking at the correct line. Also I think I was looking at the EDuke log, not at the AMC log which also brought to the confusion ... Thanks Micky, you made me realize that mistake.


Secondly, Thank you Doom64Hunter for your enlightenment, it helps me understand some stuff better.

Concerning mirrors, I don't see how this would depend on hardware since older versions of AMC, or even EDuke as a whole didn't lag with mirrors (or the impact was highly negligible.) The last time I had problems with mirrors was with freaking JF-Duke ! For Missing textures it seems it can be helped. So far only Megabase has this issue, I didn't notive anything wrong with other levels.

BTW, Mikko's Mech Suit is severely glitched : the view keeps jittering up and down and I can't do anything against it O_o Haven tried on his other level yet.

BTW 2, Do you think it will help if I post my log file, now that I know I wasn't looking at the right one, will help ? Will it actually write in stuff upon crashing ? Because I am forced to use "Stop Process" every time it happens >_>

EDIT : I made a test or two for Polymost. 1 launching with and 1 launching without and turning it on in the menu.

In both cases the logs end at "executing settings.cfg" and a bunch of "videoSetGamma(): " with nothing after the two dots. The second test has an additional "Setting" line at the end.

I don't think these give out any clue, I think Forge's scenario is the one happening with this case.


This post has been edited by TheDragonLiner: 30 September 2019 - 10:29 AM

0

User is offline   Forge 

#22

View PostTheDragonLiner, on 30 September 2019 - 09:39 AM, said:

I think I was looking at the EDuke log, not at the AMC log which also brought to the confusion

there shouldn't be an eduke32.log file unless you unzipped the new game over the top of an older install - in which case you're going to subject yourself to all kinds of problems.
Bad practice. If you want to keep your progress from earlier games, Copy only your DATA folder over.

get the patch from the modDB site to resolve some of the issues like bobbing on ziplines or in the mech suit
https://www.moddb.co...oads/amctc-v361

This post has been edited by Forge: 30 September 2019 - 10:41 AM

1

#23

View PostForge, on 30 September 2019 - 10:39 AM, said:

there shouldn't be an eduke32.log file unless you unzipped the new game over the top of an older install - in which case you're going to subject yourself to all kinds of problems.
Bad practice. If you want to keep your progress from earlier games, Copy only your DATA folder over.

get the patch from the modDB site to resolve some of the issues like bobbing on ziplines or in the mech suit
https://www.moddb.co...oads/amctc-v361


I don't know, I think the confusion has just made me as blind as a mole, I can be so stupid when that happens >.<


There's a patch already O_o !?
Thanks for telling me, I most probably would have missed it for a long time !

0

User is offline   Sangman 

#24

@TheDragonLiner I don't speak for the team but I think your polymost problem will be ignored cause you're apparently unwilling to post your system specs.

This post has been edited by Sangman: 30 September 2019 - 11:09 AM

2

#25

I also found this strange bug regarding Highwire's Support Radio description. It's like it's conflicting with someone else's item description.

Attached thumbnail(s)

  • Attached Image: duke0000.png

0

#26

Well it is pretty obvious that OpenGL is involved in the issues, the last official Eduke32 release working for me was r6650 and despite the previous version of AMC used an higher r6775 the only mode available was Sotware so no major problem for no one.

Despite someone got triggered by polymer/polymost absence.


BTW the bug of the cultist that does not drop the skull key for the upstair door in Providence got fixed in this version? There was even a visual error in the AS VAL preview in purchase window and in Thunder Sword preview in characters equipment selection.
0

User is offline   Sangman 

#27

View PostFantinaikos, on 30 September 2019 - 12:16 PM, said:

Well it is pretty obvious that OpenGL is involved in the issues


Well, yeah. But stating this kind of thing is not constructive. It should be noted that, so far, the counter of the amount of people having problems with OpenGL that have provided log files or hardware information instead of making shit up is at exactly 0.

How people expect us to figure anything out without that kind of information is beyond me.


@TheDragonLiner Agux on our Discord has deduced that for him the presence of the "settings.cfg" file was causing problems. Maybe you can try removing it, it might be a legacy file left over that's no longer needed

This post has been edited by Sangman: 30 September 2019 - 12:33 PM

1

#28

To generate a log which should tell you what's wrong you have to activate the engine processing. To activate the engine processing you have to click on the START button of the GRP selection window. To reach the GRP selection window Eduke32 must not crash before this.

For what I remember, any other file that describe an issue ("error" something I guess) is generated only if something crash when you are ingame.

This post has been edited by Fantinaikos: 30 September 2019 - 01:07 PM

0

User is offline   Sangman 

#29

I'll only be convinced of that once somebody actually *shares* a log file when they encounter this problem. Eduke32 starts generating a log file as soon as it launches even before you press any kind of confirmation button

Aside from that there's (though this is a bit more advanced admittedly) windows event logs for example that can also indicate what's wrong
0

#30

View PostTheDragonLiner, on 30 September 2019 - 10:57 AM, said:

I don't know, I think the confusion has just made me as blind as a mole, I can be so stupid when that happens >.<


There's a patch already O_o !?
Thanks for telling me, I most probably would have missed it for a long time !

Like Forge pointed out, there shouldn't be an eduke32.log file anymore unless you extracted the new folder over the old one, which is a bad idea and is most likely causing the crashes.
settings.cfg is autogenerated, so you're probably still using one associated with EDuke32 r6775, which will cause problems.

Unpack 3.6 into a clean folder and copy ONLY eduke32.cfg (or the relevant gamevars section inside it) as well as the DATA folder from your old folder to the new one, then install the patch.
0

Share this topic:


  • 3 Pages +
  • 1
  • 2
  • 3
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks not owned by Voidpoint, LLC are the sole property of their respective owners. Play Ion Fury! ;) © Voidpoint, LLC

Enter your sign in name and password


Sign in options