Duke4.net Forums: disable saving to appdata - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

disable saving to appdata  "how do i do it?"

User is offline   Lazy Dog 

#1

how do i disable this? current EDuke saves settings to C:\Users\username\AppData\Roaming\EDuke32\,

installing it in my desktop or in a folder in C: makes no difference

how do i make it save in the same folder as the exe is?

This post has been edited by Lazy Dog: 02 March 2019 - 09:28 AM

0

User is offline   Mark 

  • Honored Donor

#2

It was done intentionally to make eduke32 like other games. My guess is its here to stay. <_<
0

User is offline   Hendricks266 

  • Weaponized Autism

  #3

Create a file in the same folder as your EDuke32 binary called "user_profiles_disabled" (no extension).
1

User is offline   Mark 

  • Honored Donor

#4

Ah, I saw that file show up in a project folder and had no idea why or how or what it was for.
0

User is offline   Lazy Dog 

#5

doesn't seem to work

https://media.moddb.com/images/members/5/4281/4280876/profile.png

https://media.moddb.com/images/members/5/4281/4280876/user.png

i deleted the folder before testing

This post has been edited by Lazy Dog: 02 March 2019 - 12:50 PM

0

User is offline   LeoD 

#6

View PostLazy Dog, on 02 March 2019 - 12:02 PM, said:

doesn't seem to work
Confirmed. In the meantime the command line parameter -usecwd should help.
0

User is offline   Lazy Dog 

#7

View PostLeoD, on 02 March 2019 - 02:36 PM, said:

Confirmed. In the meantime the command line parameter -usecwd should help.


just tested, it doesn't work

This post has been edited by Lazy Dog: 02 March 2019 - 02:47 PM

0

User is offline   LeoD 

#8

View PostLazy Dog, on 02 March 2019 - 02:43 PM, said:

just tested, it doesn't work
Indeed, but it should.

This post has been edited by LeoD: 02 March 2019 - 02:54 PM

0

User is offline   Mark 

  • Honored Donor

#9

never mind

This post has been edited by Mark: 02 March 2019 - 03:08 PM

0

User is offline   TerminX 

  • el fundador

  #10

This problem should be fixed in r7381.
0

User is offline   Lazy Dog 

#11

View PostTerminX, on 02 March 2019 - 03:53 PM, said:

This problem should be fixed in r7381.


can confirm fixed
0

User is offline   3D Master 

#12

Nope, it's not fixed, just tried the user_profiles_disabled file method, and it didn't help one bit, it still pulls some global settings from somewhere, I can't tell where, because although there is no roaming directory, it still tries to compile WT con files, in a directory that has no WT stuff.

Which comes the next request; remove it altogether! It shouldn't exist for eDuke32', eDuke32 is an engine for 23 year old game, with a whole host of expansion packs, mods, TCs, and user created campaigns, all of which who can have their own edits, con files and art assets; obviously it shouldn't have any global settings, it needs to pick the settings in the directory it starts at and that's that...

Unless you want to go the Doomsday Engine route and have eDuke start up in a GUI that can recognize different versions of Duke Nukem 3D and in what directories they are installed, can recognize the vast majority of the expansions and mods on its own, and automatically create entries for each one recognized, and have the ability to manually create your own entries, but even than, the global nonsense shouldn't be there until that entire GUI is up and functional.
0

User is offline   Forge 

#13

View Post3D Master, on 06 July 2019 - 12:18 PM, said:

Nope, it's not fixed, just tried the user_profiles_disabled file method, and it didn't help one bit, it still pulls some global settings from somewhere, I can't tell where, because although there is no roaming directory, it still tries to compile WT con files, in a directory that has no WT stuff.

files not created
can't find the user profile files anywhere

https://emojipedia-us.s3.dualstack.us-west-1.amazonaws.com/thumbs/60/google/40/thinking-face_1f914.png
then it must have worked.

before you ramble on any more, try emptying your autoload folder of ALL items and run a vanilla game.
add the items back in until you find the one that breaks things.

my guess would be using the wt_hrp and wt_stopgap files outside of the world tour game folder.

https://forums.duke4...post__p__324995

This post has been edited by Forge: 06 July 2019 - 08:25 PM

0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners. Instead of reading this text, you could be playing Ion Fury! ;) © 2019 Voidpoint, LLC

Enter your sign in name and password


Sign in options