Duke4.net Forums: NAM M16 auto-aim isn't correct - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

  • 2 Pages +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

NAM M16 auto-aim isn't correct

User is offline   Jimmy 100MPH 

  • Trooper
  • 4,489

#31

Just my two cents, but mods can always have patches released. I wouldn't worry about mods.

Coke costs a lot of money you know. - oasiz
1

User is offline   Little Tijn 

  • 27

#32

View PostHendricks266, on 07 May 2018 - 04:04 PM, said:

r6880 amends the problematic commit and another one I'm unsure of to only apply in WWII GI mode. Do the issues that affected Duke before r6879 also apply to WWII GI in r6880?


The might boot is still working correctly in Duke and NAM with r6880, so that is fixed :) The "knife" in WW2GI animates now the same as the original, although with the problem that when tapping the fire button, it doesn't register a hit. Only when keeping the button down. That was the problem with the revisions before 6879.

But I don't mind it. And I guess nobody does, seeing that this is the first time this game can actually be played now at all with a very nice port. I would say, keep it as it is now. It's working fine for Duke3D and these games. Maybe someone can revisited this topic again later when the time is right. Try to focus now on something that matter and that gives positive energy, instead of fixing some silly commercial mods ;)

And remember, what started as a simple bug report of the auto-aim turned thanks to your hard work into a full-blown recreation of the logic of the game.

This post has been edited by Little Tijn: 08 May 2018 - 09:43 AM

1

User is offline   Little Tijn 

  • 27

#33

Couldn't edit my post anymore. Notices that the BAR (4) also has this problem somehow.
0

User is online   Hendricks266 

  • Weaponized Autism
  • 6,405

  #34

View PostLittle Tijn, on 24 April 2018 - 03:06 AM, said:

Maybe it is possible to add a OPL3 emulator, also for authentic sounding music in Duke as well. Although that would be quite a change for a game (NAM) that isn't that great. Maybe for Duke :)

I am happy to report that I have secured the necessary permissions to add Nuked OPL3 to EDuke32. :)
5

User is offline   Little Tijn 

  • 27

#35

View PostHendricks266, on 09 May 2018 - 10:45 AM, said:

I am happy to report that I have secured the necessary permissions to add Nuked OPL3 to EDuke32. :)


Wow! Didn't expecting that. That is great news! Eager to hear a version with that added. :) Btw. A option to choose between the OPL3 emulation or the current midi player would be nice.
0

User is offline   Little Tijn 

  • 27

#36

Sorry to bother with this again. Just found out that all automatic weapons (and the KNEE_WEAPON) in WW2GI have the problem when tapping the fire button.

I might make a new forum thread for it, if desired.

I guess I found the offending line:
if (TEST_SYNC_KEY(playerBits, SK_FIRE) == 0 && (PWEAPON(playerNum, pPlayer->curr_weapon, Flags) & WEAPON_RESET || WW2GI))


It's in player.c. I just do not know at the moment how to fix this, because I gladly would if I could.

If someone has some time to check this out someday, that will be great!

This post has been edited by Little Tijn: 15 May 2018 - 11:22 AM

0

Share this topic:


  • 2 Pages +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners. Instead of reading this text, you could be playing Ion Maiden! ;) © 2018 Voidpoint, LLC

Enter your sign in name and password


Sign in options