Duke4.net Forums: Bugs & Problems - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

  • 33 Pages +
  • « First
  • 26
  • 27
  • 28
  • 29
  • 30
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic

Bugs & Problems

User is online   Zaxx 

  • 540

#811

I have the same issue malvado and Mr. Death is having with the new version: the game's stuttering when it's loading in stuff. Running from an HDD and it's certainly not a faulty one, right now I don't have an SSD with me to try it on that sadly.

This post has been edited by Zaxx: 16 December 2018 - 08:21 AM

0

User is offline   Tekedon 

  • 63

#812

Crosshair also seems a bit "squashed" in this version compared to original.
0

User is offline   fgsfds 

  • 216

#813

I'm surprised by what you are saying. I've been bugging m210 about these stutters for a while, and the latest version seems like a huge improvement for me. I have stutters for about 5 seconds after loading a game, and there doesn't seem to be any stutters later on.

This post has been edited by fgsfds: 16 December 2018 - 11:27 AM

0

User is online   Zaxx 

  • 540

#814

View Postfgsfds, on 16 December 2018 - 11:25 AM, said:

I have stutters for about 5 seconds after loading a game, and there doesn't seem to be any stutters later on.

I always had those early stutters too but not this.
0

User is offline   Mr. Death 

  • 5

#815

View Postfgsfds, on 16 December 2018 - 11:25 AM, said:

I'm surprised by what you are saying. I've been bugging m210 about these stutters for a while, and the latest version seems like a huge improvement for me. I have stutters for about 5 seconds after loading a game, and there doesn't seem to be any stutters later on.

Let me reiterate, the newer versions of BloodGDX are definitely an improvement and much more smooth than the previous ones for me. The load times for saved games and in-between levels are longer, but the gameplay is overall much smoother and less "stuttery" than it was before. All I'm saying is that I've always had these 1 second long freezes/stutters that happen randomly in both BloodGDX and EDuke32. I don't know what's causing them, but I have noticed that they never seem to happen when I use the software or polymer renderers in EDuke32, so I think it might be something related to polymost.
0

User is offline   axl 

  • 195

#816

View PostMr. Death, on 16 December 2018 - 01:50 PM, said:

Let me reiterate, the newer versions of BloodGDX are definitely an improvement and much more smooth than the previous ones for me. The load times for saved games and in-between levels are longer, but the gameplay is overall much smoother and less "stuttery" than it was before. All I'm saying is that I've always had these 1 second long freezes/stutters that happen randomly in both BloodGDX and EDuke32. I don't know what's causing them, but I have noticed that they never seem to happen when I use the software or polymer renderers in EDuke32, so I think it might be something related to polymost.


Indeed I noticed them too in both BloodGDX and EDuke32. And like you said it only happens in Polymost.

Are you using new skyboxes ? I begin to think it is related to polymost loading additional skyboxes... I could be mistaken though...
0

User is offline   Newken 

  • 24

#817

No stuttering here.

Crosshair placement is being changed during saving or loading the game.
0

User is offline   Mr. Death 

  • 5

#818

View Postaxl, on 16 December 2018 - 02:14 PM, said:

Indeed I noticed them too in both BloodGDX and EDuke32. And like you said it only happens in Polymost.

Are you using new skyboxes ? I begin to think it is related to polymost loading additional skyboxes... I could be mistaken though...

I am using the custom skyboxes that were originally included w/ older versions of BloodGDX. However, I've never used skyboxes for EDuke32 and it freezes/stutters just the same...
0

User is offline   malvado 

  • 10

#819

View PostZaxx, on 16 December 2018 - 01:18 PM, said:

I always had those early stutters too but not this.

This is exactly my experience. With previous GDX versions I'd get some slight stutters only at the very beginning when starting the game. It wasn't a big deal at all and I didn't care much for it. With this new version however I get these really bad and noticeable freezes like this http://webm.land/w/Y2gX/ randomly while playing and they keep happening.
0

User is offline   m210 

  • 547

#820

Ok, what's about other GDX ports?
Can you try 0.795 and 0.796? Which is better?

http://m210.duke4.ne...oodGDX_0795.jar
http://m210.duke4.ne...oodGDX_0796.jar
http://m210.duke4.ne...X_0797debug.jar

Also you need try BloodGDX_0797debug, I made a microoprimisations in texturecaching...maybe it helps.
And there is "Info: cache" text on screen each times when bloodgdx accesses hard disk

M210 Projects - My personal site

BuildGDX
1

User is online   Zaxx 

  • 540

#821

Haven't tried the old versions yet but the debug is better, during the frist 3 levels of the first episode I only very rarely had stutter when the info text popped up (btw. it was surprising to see how many times the game accesses the HDD).

Btw. I don't know what you're doing but apart from this stuttering issue BloodGDX feels remarkably smooth these days: in EDuke32 (and in older versions of BloodGDX) I always get ugly tearlines even when my fps is high as fuck but if I lock BloodGDX to a nice high number I see no tearing. Good job, you fixed an issue that was bugging me for an eternity in EDuke32.

This post has been edited by Zaxx: 17 December 2018 - 02:22 AM

0

User is offline   m210 

  • 547

#822

View PostZaxx, on 17 December 2018 - 02:21 AM, said:

Haven't tried the old versions yet but the debug is better, during the frist 3 levels of the first episode I only very rarely had stutter when the info text popped up (btw. it was surprising to see how many times the game accesses the HDD).

Btw. I don't know what you're doing but apart from this stuttering issue BloodGDX feels remarkably smooth these days: in EDuke32 (and in older versions of BloodGDX) I always get ugly tearlines even when my fps is high as fuck but if I lock BloodGDX to a nice high number I see no tearing. Good job, you fixed an issue that was bugging me for an eternity in EDuke32.

Yeah, I trying :) And btw, it's not a limit, Im feeling, that I can make it better

M210 Projects - My personal site

BuildGDX
1

User is offline   malvado 

  • 10

#823

View PostM210, on 16 December 2018 - 10:16 PM, said:

Ok, what's about other GDX ports?
Can you try 0.795 and 0.796? Which is better?

http://m210.duke4.ne...oodGDX_0795.jar
http://m210.duke4.ne...oodGDX_0796.jar
http://m210.duke4.ne...X_0797debug.jar

Also you need try BloodGDX_0797debug, I made a microoprimisations in texturecaching...maybe it helps.
And there is "Info: cache" text on screen each times when bloodgdx accesses hard disk

Cool I tried these versions. On all three I was getting the freezes. Here is a capture from the 0.797 debug version: http://webm.land/w/Ia9H/
As you can see, the text didn't come up so I guess GDX wasn't accessing the hard drive when the stutter happened.

When I went back to 0.794 the stuttering stopped. With 0.794, I only get a few stutters right at the beginning when the game starts, then it's fine.

These new versions in general have a much smoother feel than 0.794 though. I don't get any screen tearing with them even with unlimited FPS. Unfortunately that general smoothness is marred by the stutters. Seems it's not a widespread issue though... I'll just stay on 0.794 if it can't be fixed.

Btw any chance this could be happening because of the new sounds since 0.795 and beyond? Idk.

This post has been edited by malvado: 17 December 2018 - 05:26 AM

0

User is offline   Mr. Death 

  • 5

#824

View Postmalvado, on 17 December 2018 - 05:23 AM, said:

Cool I tried these versions. On all three I was getting the freezes. Here is a capture from the 0.797 debug version: http://webm.land/w/Ia9H/
As you can see, the text didn't come up so I guess GDX wasn't accessing the hard drive when the stutter happened.

When I went back to 0.794 the stuttering stopped. With 0.794, I only get a few stutters right at the beginning when the game starts, then it's fine.

These new versions in general have a much smoother feel than 0.794 though. I don't get any screen tearing with them even with unlimited FPS. Unfortunately that general smoothness is marred by the stutters. Seems it's not a widespread issue though... I'll just stay on 0.794 if it can't be fixed.

Btw any chance this could be happening because of the new sounds since 0.795 and beyond? Idk.

Yeah, I agree these new versions of BloodGDX are definitely an improvement over the older ones, and they run very smooth overall. To me, these 1 second long freezes (they seem more like freezes rather than "stuttering") don't seem to be the same as the precache stuttering that occurs early on.

Do you experience these same freezes/stutters in EDuke32? It's very interesting that the game was not accessing your HDD when it happened. It's also weird that you say they don't happen for you w/ 0.794, yet me (and some others) have always had these strange freezes in both BloodGDX & EDuke32 when using polymost.
0

User is offline   m210 

  • 547

#825

View Postmalvado, on 17 December 2018 - 05:23 AM, said:

Btw any chance this could be happening because of the new sounds since 0.795 and beyond? Idk.

I have an idea to compile 0.794 with my latest buildengine, I will give you a link tomorrow.

Also you can try to disable new sounds driver. Open bloodgdx.jar as zip file and delete two files:
nOpenAL32.dll
nOpenAL.dll

After delete bloodgdx should launching with old driver - openal 1.15.1

M210 Projects - My personal site

BuildGDX
0

User is offline   malvado 

  • 10

#826

View PostMr. Death, on 17 December 2018 - 08:02 AM, said:

Yeah, I agree these new versions of BloodGDX are definitely an improvement over the older ones, and they run very smooth overall. To me, these 1 second long freezes (they seem more like freezes rather than "stuttering") don't seem to be the same as the precache stuttering that occurs early on.

Do you experience these same freezes/stutters in EDuke32? It's very interesting that the game was not accessing your HDD when it happened. It's also weird that you say they don't happen for you w/ 0.794, yet me (and some others) have always had these strange freezes in both BloodGDX & EDuke32 when using polymost.

I haven't experienced this in eduke, no, however in eduke I would use the polymer renderer.
0

User is offline   malvado 

  • 10

#827

View PostM210, on 17 December 2018 - 09:57 AM, said:

I have an idea to compile 0.794 with my latest buildengine, I will give you a link tomorrow.

thank you!

Quote

Also you can try to disable new sounds driver. Open bloodgdx.jar as zip file and delete two files:
nOpenAL32.dll
nOpenAL.dll

I tried by extracting the folder and deleting the two files, but I don't know how to turn the folder back into a .jar file. Sorry I'm tech illiterate. I used some compressor but when I click on the newly made bloodgdx.jar file I get a message saying "Error: Invalid or corrupt jarfile." I'll try out your link tomorrow m8.
0

User is offline   m210 

  • 547

#828

View Postmalvado, on 17 December 2018 - 10:14 AM, said:

thank you!


I tried by extracting the folder and deleting the two files, but I don't know how to turn the folder back into a .jar file. Sorry I'm tech illiterate. I used some compressor but when I click on the newly made bloodgdx.jar file I get a message saying "Error: Invalid or corrupt jarfile."

Ok, here:
http://m210.duke4.ne...DX_0797deb2.jar

M210 Projects - My personal site

BuildGDX

This post has been edited by M210: 17 December 2018 - 12:15 PM

0

User is offline   Fantinaikos 

  • 319

#829

View Postm210®, on 17 December 2018 - 12:14 PM, said:



The sounds, the music and framerate returned normal and stable with this version, so I can confirm that nOpenAL32.dll nOpenAL.dll are involved indeed. It is possible add an old Openal driver option in the selectable sound devices? Manual deletion is not the best approach.

This post has been edited by Fantinaikos: 17 December 2018 - 01:23 PM

0

User is offline   Mr. Death 

  • 5

#830

Unfortunately I'm still experiencing the same freezing/hitching with the debug version of 0.797. Reverting to the older sound driver did NOT fix the issue for me...

Just like with malvado, the text that indicates the HDD is being accessed did not appear when I experienced the freezes. Like I said before, this happens in both BloodGDX & EDuke32 for me, and I don't think that it's related to "texture caching". It always happens randomly, and it's not consistent at all. Sometimes when I play I'll only experience a few freezes/hitches now and then, and other times they will happen A LOT. I originally thought that it was probably a hardware issue on my end, but now I see that a few others have them as well. I'm starting to think that it may have something to do with polymost.

I will however say that besides these random freezes, whatever M210 is doing to optimize the precaching, keep it up! I was FLYING through the first few levels w/ the highest density of enemies, just to "stress test" the game, and it was super smooth the whole time! Great work as usual M210 :)
0

User is offline   m210 

  • 547

#831

View PostFantinaikos, on 17 December 2018 - 01:20 PM, said:

The sounds, the music and framerate returned normal and stable with this version, so I can confirm that nOpenAL32.dll nOpenAL.dll are involved indeed. It is possible add an old Openal driver option in the selectable sound devices? Manual deletion is not the best approach.

Yes, Im planning to make it choosable. Maybe the next release will be with this feature

So, there is no need to compile 0.794 now?

M210 Projects - My personal site

BuildGDX

This post has been edited by m210: 17 December 2018 - 07:22 PM

0

User is offline   SonicB00M 

  • 29

#832

Have you guys tried to turn 'true color textures' off? It fixes all stuttering issues on my system. Unfortunately the enhanced skyboxes won't work with that option turned off.
0

User is offline   malvado 

  • 10

#833

View Postm210, on 17 December 2018 - 12:14 PM, said:


This fixes it for me! This version runs great! No more freezes here.

It seems indeed then that there is some issue in the nOpenAL32.dll and nOpenAL.dll files.
0

User is offline   axl 

  • 195

#834

View PostSonicB00M, on 17 December 2018 - 09:18 PM, said:

Have you guys tried to turn 'true color textures' off? It fixes all stuttering issues on my system. Unfortunately the enhanced skyboxes won't work with that option turned off.


Same here. If I don't use the additional skyboxes all stuttering is gone. Turning off "true color textures" also does the trick cause it disables the use of skyboxes.
0

User is offline   Mr. Death 

  • 5

#835

Well I have no idea what's going on then...

I've reverted back to the old sound driver, I've deleted the skyboxes, and I've disabled "True Color Textures" and nothing works for me. I get the same freezing/hitching that malvado showed in his video in BOTH BloodGDX & EDuke32 :(

I guess maybe it's just some kind of hardware issue on my end, who knows...

Glad to hear that everything's working properly for others though :) BloodGDX is a great port, and it keeps getting better w/ each release!
0

User is offline   Tekedon 

  • 63

#836

I get an error when trying to load map/ini files from zips. It's bloodmapedit's mappack if that matters. The pack is divided into many folders by letter and then by author if that's the reason.

It says "error found in mapname.zip NULL".
0

User is offline   supergoofy 

  • 60

#837

bug????

enemies of the same type are not supposed to attack each other (???)
https://youtu.be/jlwiyNzd3YE?t=126
0

User is offline   m210 

  • 547

#838

View Postsupergoofy, on 18 December 2018 - 12:42 PM, said:

enemies of the same type are not supposed to attack each other (???)
https://youtu.be/jlwiyNzd3YE?t=126


As I remember, yes. I will check it.


View PostTekedon, on 18 December 2018 - 11:56 AM, said:

I get an error when trying to load map/ini files from zips.

Can you give me a link?

M210 Projects - My personal site

BuildGDX
0

User is offline   Tekedon 

  • 63

#839

View Postm210, on 18 December 2018 - 07:49 PM, said:

As I remember, yes. I will check it.



Can you give me a link?


http://blood.freemin...ion=maps&id=569

this was the pack I happened to test.
0

User is offline   m210 

  • 547

#840

View PostTekedon, on 19 December 2018 - 09:28 AM, said:

http://blood.freemin...ion=maps&id=569

this was the pack I happened to test.


This zip file doesn't show in menu as addon or mappack, as it should.
So, still no problem here o_O

M210 Projects - My personal site

BuildGDX

This post has been edited by m210: 19 December 2018 - 12:28 PM

0

Share this topic:


  • 33 Pages +
  • « First
  • 26
  • 27
  • 28
  • 29
  • 30
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners. Instead of reading this text, you could be playing Ion Fury! ;) © 2019 Voidpoint, LLC

Enter your sign in name and password


Sign in options