Duke4.net Forums: EDuke32 2.0 and Polymer! - Duke4.net Forums

Jump to content

  • 211 Pages +
  • « First
  • 117
  • 118
  • 119
  • 120
  • 121
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic

EDuke32 2.0 and Polymer!  "talk about the wonders of EDuke32 and the new renderer"

User is offline   Hendricks266 

  • Weaponized Autism

  #3541

Got a good reason for that?
0

User is offline   Fox 

  • Fraka kaka kaka kaka-kow!

#3542

I guess it's for mods that don't use duke3d.grp.

This post has been edited by Fox: 24 March 2013 - 01:23 PM

0

User is offline   Plagman 

  • Former VP of Media Operations

#3543

Also, mapster32 will save maps directly into the GRP, so you might end up altering your pristine copies. It would probably better to do an import, like the old installer that came with JfDuke3d used to do, when you run it for the first time?
0

User is offline   Skulldog 

#3544

When I run Eduke32 without Polymer and enable autoload folder. It used hires from Duke Nukem 3D Megaton Edition. GOG no problems.

This post has been edited by Skulldog: 24 March 2013 - 01:34 PM

0

User is offline   Hendricks266 

  • Weaponized Autism

  #3545

OK, I'll remove it in my next push. More discussion is pending among the devs.

JonoF uploaded the source to his data installer to his forums but they are closed, so I made a mirror: http://hendricks266....datainst-r8.zip

A completely separate Mac data installer is on GitHub: https://github.com/jonof/datainst-osx
0

User is offline   Jblade 

#3546

Will there be a way in the future to load more palettes? I mean completely new ones like the NVG palette and such.
0

User is offline   Diaz 

#3547

I don't know if this is a bug or a limitation, but it looks like spotlights and point lights are not being occluded properly.

I have a map where there is a huge spotlight for a water caustics effect on a big area. If the light radius encompasses other areas from the map that are completely isolated from the area the light is on (separated by a closed door), it won't get 100% occluded inside the isolated areas. Sprites inside those areas will be affected by the light, but sectors will not.

This post has been edited by Diaz: 28 March 2013 - 11:02 AM

0

User is offline   Helixhorned 

  • EDuke32 Senior Developer

#3548

View PostJames, on 27 March 2013 - 10:43 AM, said:

Will there be a way in the future to load more palettes? I mean completely new ones like the NVG palette and such.

Yes, this is a thing for the future.
1

User is offline   Hendricks266 

  • Weaponized Autism

  #3549

I felt like building a new 64-bit build so I did. Helix fixed the bugs with CON gamearrays about a month ago.

http://hendricks266....est_20130329.7z
3

User is offline   Plagman 

  • Former VP of Media Operations

#3550

View PostDiaz, on 28 March 2013 - 10:57 AM, said:

I don't know if this is a bug or a limitation, but it looks like spotlights and point lights are not being occluded properly.

I have a map where there is a huge spotlight for a water caustics effect on a big area. If the light radius encompasses other areas from the map that are completely isolated from the area the light is on (separated by a closed door), it won't get 100% occluded inside the isolated areas. Sprites inside those areas will be affected by the light, but sectors will not.


Hi Diaz,

You're right, sprites get affected regardless of which sector they're in. When we keep better track of which sector(s) sprites are into, this will be solved. I added it to this:

http://wiki.eduke32....er_Deficiencies
0

User is offline   Diaz 

#3551

Thank you :)
0

User is offline   supergoofy 

#3552

@Hendricks266, I have tested the new eduke64 binary. I'm playing Attrition v1.50 beta with Polymer renderer enabled. The speed increase is significant (I would say about 50% increase in speed). I haven't found any issues with eduke64, it works like eduke32 only it is a lot faster when using Polymer renderer.

Do you have any suggestions that I should check ?


By the way, many thanks for this.
1

User is offline   Diaz 

#3553

I didn't notice such a performance increase with Polymer, in fact there's no difference at all :)
0

User is offline   Hendricks266 

  • Weaponized Autism

  #3554

View Postsupergoofy, on 29 March 2013 - 10:10 PM, said:

Do you have any suggestions that I should check ?

Nothing big comes to mind. Could you check if 32-bit and 64-bit savegames are labeled as such correctly in both builds? Also, one remaining item on the to-do list is to make readarrayfromfile/writearraytofile consistent between architectures (i.e. save in one; load in the other); at present I don't think it works correctly. Networking compatibility between architectures is something we'll also have to look out for.

View Postsupergoofy, on 29 March 2013 - 10:10 PM, said:

By the way, many thanks for this.

No problem. We've tried a couple times to move synthesis to a different toolchain that could build 64-bit binaries but each time it ends up making the 32-bit builds crash. It might be because of nedmalloc.

One way to help would be to help diagnose these crashes. This is the most recent build with "i686-w64-mingw32-gcc-4.7.2-release-linux64 + native NASM". Try it with and without nedmalloc in all three renderers.
0

User is offline   supergoofy 

#3555

I can confirm that the saves are shown correctly, but I cannot use the save from eduke32 with eduke64, thus I started a new game.

I will check later with the build you told me (http://dukeworld.duk.../20121230-3350/)

[edit]

I have tested eduke32_win32_20121230-3350.zip

When nedmalloc.dll is present, then eduke32.exe doesn't even start (no crash message of eduke32.log)

When I deleted nedmalloc.dll, then eduke32 started ok.

This post has been edited by supergoofy: 30 March 2013 - 05:15 AM

0

User is offline   m210 

#3556

I have one question: How can I disable using steam version of duke3d at launch? This setting is disrupting work of my BloodTC

This post has been edited by M210: 03 April 2013 - 09:33 AM

0

User is offline   TerminX 

  • el fundador

  #3557

Use an older version for now, I'll try to address this problem today.
1

User is offline   Fox 

  • Fraka kaka kaka kaka-kow!

#3558

Is it possible to increase the values for sprite such as x-yrepeat or clipdist, even if not avaiable in the editor? For example, a while ago I noticed while trying to recreate the Doom monsters that the Spider Mastermind would require a clipdist of 512 while the current limit is of 255.
0

User is offline   Mblackwell 

  • Evil Overlord

#3559

You could always make a clipshape box.
1

User is offline   Jblade 

#3560

Any chance of a flag for walls being added that lets us hide it from the map-screen? Or sectors, if not that? There's something similar in Zdoom and it would be a handy feature to have to hide secrets, or signatures, or effect sectors if we wanted to add an auto-map pickup for example.
0

User is offline   Danukem 

  • Duke Plus Developer

#3561

View PostJames, on 04 April 2013 - 03:49 AM, said:

Any chance of a flag for walls being added that lets us hide it from the map-screen? Or sectors, if not that? There's something similar in Zdoom and it would be a handy feature to have to hide secrets, or signatures, or effect sectors if we wanted to add an auto-map pickup for example.


Either that or exposing to CON the array which determines which sectors have been automapped, so that it can be manipulated directly.
0

User is offline   Fox 

  • Fraka kaka kaka kaka-kow!

#3562

I fear it may be not so simply to add it in CON. It seems the values stored are per-sector per-player, something unprecedented in current CON code.

http://i1110.photobucket.com/albums/h441/Fox_969/coopmap.png

I suppose a work-around would be to convert the player id to a bitfield, since it is only for a true or false check. If the sector is visible for player n, add 2ⁿ to the sector structure or array.

===//===//===

Is it possible to add a display respawn toggle in Mapster?

http://i1110.photobucket.com/albums/h441/Fox_969/respawn.gif

This post has been edited by Fox: 05 April 2013 - 07:27 AM

0

User is offline   Helixhorned 

  • EDuke32 Senior Developer

#3563

View PostFox, on 04 April 2013 - 09:39 AM, said:

IIs it possible to add a display respawn toggle in Mapster?

It's already there, coded in a.m32, but you have to "lock" onto the RESPAWN sprite with SPACE unless you set the showrespawn_always gamevar to 1. Also, it sometimes doesn't work due to an m32-script interpreter bug.
1

User is offline   Spirrwell 

  • tile 1018

#3564

View PostHendricks266, on 29 March 2013 - 02:05 PM, said:

I felt like building a new 64-bit build so I did. Helix fixed the bugs with CON gamearrays about a month ago.

http://hendricks266....est_20130329.7z

Yeah, it runs far faster for me as well with Polymer. It's about a 75% increase for me in a steady frame rate... It'd be cool to have 64 bit Windows binaries in the synthesis. It seems according to the wiki that a 64 bit binary can be compiled with MinGW-w64, is this right?
0

User is offline   TerminX 

  • el fundador

  #3565

Yeah, that's correct, but the 64-bit Windows builds aren't really stable yet and still have a few problems that aren't present in the 32-bit builds (though they're mostly corrected now).
1

User is offline   TerminX 

  • el fundador

  #3566

Committed r3654 a few minutes ago... should be of interest to a few people. :D
3

User is offline   Mateos 

#3567

Thank you very much! Installed! :D
0

User is offline   Skulldog 

#3568

View PostTerminX, on 08 April 2013 - 10:35 AM, said:

Committed r3654 a few minutes ago... should be of interest to a few people. :o


Nice update TX. :D
0

User is online   Micky C 

  • Honored Donor

#3569

I remember replacing the duke3d.exe from megaton with eduke32, then when I fired it up, the mouse wasn't working. I remember the Commander also had some control issues.
0

User is offline   Gambini 

#3570

View PostHelixhorned, on 05 April 2013 - 08:18 AM, said:

It's already there, coded in a.m32, but you have to "lock" onto the RESPAWN sprite with SPACE unless you set the showrespawn_always gamevar to 1. Also, it sometimes doesn't work due to an m32-script interpreter bug.


I remember suggesting that idea and being happy to know it was implemented. But I never managed to make it work.

Just tried with "include a" in the console but nothing happened. Tried that showrespawn 1 but nothing happened. Tried pressing space on a respawn but nothing agian.

Would you give detailed instructions to make it work?
0

Share this topic:


  • 211 Pages +
  • « First
  • 117
  • 118
  • 119
  • 120
  • 121
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks not owned by Voidpoint, LLC are the sole property of their respective owners. Play Ion Fury! ;) © Voidpoint, LLC

Enter your sign in name and password


Sign in options