Duke4.net Forums: How to replace the .ANM videos with .IVF videos with sound. - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

  • 2 Pages +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

How to replace the .ANM videos with .IVF videos with sound.  "A tutuorial on how to replace them crappy looking ANM videos."

User is offline   Nevander 

  • 7

#31

I cannot for the life of me get the sound to work with this. Not even the built-in sounds will play. I'm positive I've done everything right here, but the sounds refuse to play. I did the DEF file and everything just as the tutorial describes. Setting up and defining a new OGG sound from the video also doesn't work. Just doesn't play at all.

Only thing I see in the log is this: Error: expected a hardcoded anim file name (sans extension) on line duke3d.def:1

Sorry to bump but this is kinda pissing me off. I just want to know why the sounds won't play here. I was going to forget about it but I'd love to know why it's not playing.
0

User is offline   LeoD 

  • 531

#32

View PostNevander, on 28 November 2015 - 03:34 PM, said:

I cannot for the life of me get the sound to work with this.
IIRC it's broken. Seems I never got to hunting this one down to the specific source revision because it somehow disappeared from my to-do list.
0

User is offline   Hendricks266 

  • Weaponized Autism
  • 6,435

  #33

Try either adding or subtracting the .ivf extension to/from your def syntax. I forget which.
0

User is offline   LeoD 

  • 531

#34

View PostLeoD, on 28 November 2015 - 04:44 PM, said:

IIRC it's broken. Seems I never got to hunting this one down to the specific source revision because it somehow disappeared from my to-do list.
Found it. Broken as of r4987. Nearest synthesis versions are r4980 (OK) and r5001 (broken). Example DEF + IVF attached. It works, however, if you remove the extension from the actual IVF file in your CWD, which is surely not what's intended. The game doesn't seem to care if an extension is DEFined or not.

Attached File(s)




This post has been edited by LeoD: 29 November 2015 - 05:54 AM

1

Share this topic:


  • 2 Pages +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners. Instead of reading this text, you could be playing Ion Fury! ;) © 2019 Voidpoint, LLC

Enter your sign in name and password


Sign in options