Duke4.net Forums: [RELEASE] Duke Nukem 3D Upscale Pack - Duke4.net Forums

Jump to content

  • 8 Pages +
  • « First
  • 5
  • 6
  • 7
  • 8
  • You cannot start a new topic
  • You cannot reply to this topic

[RELEASE] Duke Nukem 3D Upscale Pack

User is offline   Phredreeke 

#181

the new Liztroop has the same palswaps as the regular Liztroop.

As for the babes, the babes caught in slime have NOT been upscaled. I was referring to the strippers/hooker/dancer.

Edit: Upscaled the linked sprites

Attached Image: newxpupscale.png

Attached File(s)



This post has been edited by Phredreeke: 25 April 2020 - 12:30 PM

2

#182

View PostPhredreeke, on 25 April 2020 - 12:00 PM, said:

the new Liztroop has the same palswaps as the regular Liztroop.

As for the babes, the babes caught in slime have NOT been upscaled. I was referring to the strippers/hooker/dancer.

Edit: Upscaled the linked sprites

Attachment newxpupscale.png


Yeah, i see now, about the Lizard troop i misunderstood the part "inspered by DN64", that's why i was confused by reading "the new default version"., i thought was replaced by the blue one.


The babes: yes, i confirm what i said, the ones on most of the posters look fine and the dancer... well we can finally see a face when she shake them ;)


Do you think that the chaingun the RPG and the Shrinker/Expander can be improved even more? They look upscaled but, for some reason, they does not feel upscaled like the other ones? (imo)


Still a nice job, keep it up!
0

User is offline   Phredreeke 

#183

Tireheb on Discord reported that the RPG and freezethrower upscales don't load when using the World Tour stopgap in EDuke32 - after further testing I realised none of the tiles with widescreen replacements in WT have upscales loaded. Worse, when firing the freezethrower there is a gap between the upper and lower sprites. I have made a modified DEF which fixes this. This is not needed for running World Tour in DukeGDX, which uses the original tile numbers for the weapons.

http://s000.tinyuplo...467385577462202
0

User is offline   Phredreeke 

#184

A trio of portable medkits

https://i.imgur.com/oGnjKv6.png
4

User is offline   MrFlibble 

#185

The pill one looks kinda blurry, the other two are top notch.
0

User is offline   Phredreeke 

#186

I didn't put much effort into the pill one. The others I actually bothered switching to a different model for the cross/heart and text
0

User is offline   Mark 

#187

I downloaded the upscale pack because I was curious to see how it handled one of the animated flames sprite sets starting at 2271. But I see those were not done. Was it because they didn't look usable upscaled or were they passed over for another reason? I was hoping to use an upscaled version because it seems that one of the pros of the process is reducing jagged edges.
0

User is offline   Phredreeke 

#188

Is that the one from ROTT? I thought it wasn't used in the game.

Edit: Checking the sprite, it is upscaled in my latest version of the upscale pack

Attached Image: tile2271.png

This post has been edited by Phredreeke: 08 June 2020 - 04:20 PM

0

User is offline   Mark 

#189

I downloaded from the first post of this thread. Is there a link to the latest version?
0

User is offline   Phredreeke 

#190

If you click the Upscale packs by me link in my signature you get a list including the latest versions

Anyway here's the moddb link https://www.moddb.co...upscale-pack-12
1

User is online   Lunick 

  • Snazzy Ex Tazzy

#191

I'll change the link in the first post to that one
2

User is offline   Phredreeke 

#192

A preview of what's being added to the upscale pack

https://i.imgur.com/VE1jEi8.png
https://i.imgur.com/yuCH66L.png
5

User is offline   szaman 

#193

View PostPhredreeke, on 26 April 2020 - 02:30 AM, said:

Tireheb on Discord reported that the RPG and freezethrower upscales don't load when using the World Tour stopgap in EDuke32 - after further testing I realised none of the tiles with widescreen replacements in WT have upscales loaded. Worse, when firing the freezethrower there is a gap between the upper and lower sprites. I have made a modified DEF which fixes this. This is not needed for running World Tour in DukeGDX, which uses the original tile numbers for the weapons.

http://s000.tinyuplo...467385577462202


I also have the same problem... The RPG and freezethrower does not upscale. I have downloaded the DEF file from your link, it dosen't seems to work. Maybe im putting it the wrong place? The funny thing is i don't use WT, have it on steam, but it's not connected in any way with Eduke32.

I have putted the file in disk C-->Duke Nukem Eduke32 Upscale pack (my own file name, where i have installed Eduke and upscale) and put it in the same folder where is the dukeupscale.bat file.

I'm doing something wrong then?
0

User is offline   Phredreeke 

#194

Do you have any other mods installed? This would include any in the WT folder (as EDuke32 autodetects it)
Also a copy of eduke32.log may help

This post has been edited by Phredreeke: 25 October 2020 - 06:08 AM

0

User is offline   szaman 

#195

View PostPhredreeke, on 25 October 2020 - 06:05 AM, said:

Do you have any other mods installed? This would include any in the WT folder (as EDuke32 autodetects it)
Also a copy of eduke32.log may help


Yes i have some mods installed. Your old upscale pack (don't remember what version) and HRP pack, duke3d_music-sc55, duke3d_psx, duke3d_xxx.

Also.. here the eduke32.log i hope it helps..

Attached File(s)


0

User is offline   Phredreeke 

#196

Quote

Could not find file "duke3dupscale-fixed.zip".


From what I can tell you're launching it with a BAT file from an old version.
0

User is offline   randir14 

#197

I have the same problem with those weapon upscales not loading. All the other weapons are upscaled fine. I'm using the latest eDuke32 + stopgap + World Tour with the current upscale pack from Moddb. I did notice that the weapons in question upscale properly when I used regular Duke 3D Atomic Edition. I downloaded the modified def and replaced the one in wtupscale.zip, I assume that's where I was supposed to put it.

Attached File(s)



This post has been edited by randir14: 25 October 2020 - 06:45 AM

0

User is offline   Phredreeke 

#198

when you run dukeupscale.bat do you get a fourth option? Because judging by the log you launched with the first option which doesn't load the WT specific def (this doesn't explain why you don't get upscales in GDX though)
1

User is offline   szaman 

#199

View PostPhredreeke, on 25 October 2020 - 06:33 AM, said:

From what I can tell you're launching it with a BAT file from an old version.


Fixed... Forgot that in some "ancient times" i have installed Eduke32 in WT folder, and for some reason the priority has the "WT EDUKE32". After deleting WT from steam, everything work fine now;)
0

User is offline   randir14 

#200

View PostPhredreeke, on 25 October 2020 - 06:54 AM, said:

when you run dukeupscale.bat do you get a fourth option? Because judging by the log you launched with the first option which doesn't load the WT specific def (this doesn't explain why you don't get upscales in GDX though)


Ah...for some reason I didn't even notice the fourth option. Everything's working now, thanks.
0

User is offline   Phredreeke 

#201

I've released a new version of the upscale pack

https://www.moddb.co...upscale-pack-13

* Liztroop has fullbright eyes
* Pigcop tank was updated
* Faces updated on babes
* Dev pictures in Faces of Death and Pigsty have been upscaled using vintage photos as reference
* First person weapon sprites have generally cleaner palette swaps
* DEFs added for indexed hightile support
* DN64 style liztroop added to Life's a Beach
* The beach babes have had their blue sunglasses recolored grey
* Nuclear Winter has been fixed to load images from the correct folder
* The elves have been given new faces.
* Several tiles have been given new holiday themed versions in NW
* This list is not comprehensive, there's been additional changes besides these
4

#202

Somebody did not like her smile? ;(
Spoiler



She need a denture now, that's why looks angry xD (or it is just lipsitck maybe)
Spoiler



You are trying to make things based on the in-game pixels, to be as close as possible to the original ones, right?


Personally i like the idea to give a bit of your personal touch if it looks better (or our the mind interprets it at least).


So far eveything looks amazing, nice job!

This post has been edited by The Battlelord: 03 December 2020 - 03:22 PM

1

User is offline   Phredreeke 

#203

If you had any idea how many iterations that sprite went through XD and yeah that's meant to be lipstick.
0

#204

Well, in the particular case of that sprite, idk if "going through many iterations" can mean something else https://forums.duke4.net/public/style_emoticons/default/biggrin.gif.
But yeah most of times modding is something like this: Start, use that program to open that thing, convert it to open it with another program, mod/change it at your like, open it with another program to improve it even more, done? Now convert it to the original format and insert it again in the game, cross your fingers that everything will work well, test, done.

And that is just the short way, repeat the process for almost e-v-e-r-y other modding process and countless hours will pass, but passion never die, hats off to you guys, great respect.



View PostThe Battlelord, on 03 December 2020 - 03:07 PM, said:

(or our the mind interprets it at least).


Correction to my drunk words: (or how our mind interprets it at least)

This post has been edited by The Battlelord: 04 December 2020 - 02:39 AM

0

User is offline   Phredreeke 

#205

I mean more like how many attempts I made
0

User is offline   GemaH 

#206

This doesn't work for me. I'm placing the zip in the Autoload folder but i see no difference in enemies textures.

Do i have to do more steps?

Edit: I'm using the latest version of eDuke32

This post has been edited by GemaH: 06 January 2021 - 06:00 PM

0

User is offline   Phredreeke 

#207

It doesn't load from autoload folder. Place it in the EDuke32 folder then extract the BAT file found in the archive (this is both so you can use the upscale pack with the voxel pack without having to modify DEF files, as well as to allow Vaca and NW upscales to be loaded from the same archive)
0

User is offline   szaman 

#208

@Phredreeke Does your mod is compatible with Duke Nukem: World Tour?

1.I have dowloaded World Tour via steam..
2. Installed newest Eduke32. (unpack the content to the "main world tour folder" where is the grp of the game).
3. Dowloaded the stopgap file needed for World Tour. (See: https://forums.duke4...bility-stopgap/ )
3. Dowloaded your upscale pack (1.3 Version).
4. The "dukeupscale " zip file i put it the main folder of the game (where is the grp file).
5. Extracted the wtupscale.zip to the main folder of the game.
6. Extracted the dukeupscale.bat to the main folder of the game.
7. launched the dukeupscale.bat, the bat file detects World Tour (numer 4) and the Eduke32 stopgap.

But.. when i choose a episode/campaing the sprites are defeult.. what im doing wrong?

Here is the Eduke32 log file if that helps...

Attached File(s)



This post has been edited by szaman: 14 January 2021 - 10:16 AM

0

User is offline   Phredreeke 

#209

Backstory, for the last version of the upscale pack, I made separate DEFs for Life's a Beach and Nuclear Winter that defined all the tiles used for those, including those defined in the main game.

However, since BuildGDX would always load the def file with the main game's upscale file anyway I skipped including those, the idea being that the port would load both DEF files anyway. For the other ports all I needed to do was load both the main DEF file and the expansion DEF file.

So where did it go wrong? Most of the testing was done using a special dev build of eduke32 supporting indexed textures. Shortly before release, I tested with Raze, as that port had previously had issues with upscaled weapon sprites. What I neglected to do was test with eduke32, as I had assumed it would work fine given the testing that had been done with indexed textures... turns out I forgot to add the main def file for it except when option 1 is chosen.

Try replacing dukeupscale.bat with the one I attached

Attached File(s)



This post has been edited by Phredreeke: 14 January 2021 - 12:25 PM

0

User is offline   szaman 

#210

View PostPhredreeke, on 14 January 2021 - 11:01 AM, said:

Backstory, for the last version of the upscale pack, I made separate DEFs for Life's a Beach and Nuclear Winter that defined all the tiles used for those, including those defined in the main game.

However, since BuildGDX would always load the def file with the main game's upscale file anyway I skipped including those, the idea being that the port would load both DEF files anyway. For the other ports all I needed to do was load both the main DEF file and the expansion DEF file.

So where did it go wrong? Most of the testing was done using a special dev build of eduke32 supporting indexed textures. Shortly before release, I tested with Raze, as that port had previously had issues with upscaled weapon sprites. What I neglected to do was test with eduke32, as I had assumed it would work fine given the testing that had been done with indexed textures... turns out I forgot to add the main def file for it except when option 1 is chosen.

Try replacing duke3dupscale.bat with the one I attached


Sadly the duke3dupscale.bat doesn't work.
Replaced the dukeupscale.bat with duke3dupscale.bat and nothing change...

Here is the log..

Attached File(s)


0

Share this topic:


  • 8 Pages +
  • « First
  • 5
  • 6
  • 7
  • 8
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks not owned by Voidpoint, LLC are the sole property of their respective owners. Play Ion Fury! ;) © Voidpoint, LLC

Enter your sign in name and password


Sign in options