Duke4.net Forums: eduke32: digital joystick axes configuration broken - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

eduke32: digital joystick axes configuration broken

User is offline   gaula92 

  • 3

#1

Hi there,

I am using the latest SVN version of Eduke32, and joystick digital axis configuration seems very broken: as soon as I set axis0 as digital and assign a digital action to it (turn left, turn right), Duke starts turning insanely FAST in a totally unplayable way.
Same happens with axis1.
Also, going back to te game to test the configuration and going into the joystick configuration menu again, there are actions again set to the analog field of the axis, but I removed them previously.
So it's currently broken and ususable.

I am using a PSX pad (not analog, not dual-shock, just a plain PSX) with a PSX->USB converter. It works with every SDL2 game I have tried so far, except eduke32.
0

User is offline   Hendricks266 

  • EDuke32 Senior Developer
  • 5,631

  #2

Yeah, our joystick stuff is broken. It will be fixed by year's end.
4

User is offline   Duke Legacy 

  • 1,008

#3

There is a work around that you can use xpadder for now intil they fix the joypad stuff.

Duke4 Supporter
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners. Yes, our forum uses cookies. © 2017 Voidpoint, LLC

Enter your sign in name and password


Sign in options