Duke4.net Forums: Boot device not found, Windows 10 - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Boot device not found, Windows 10  "having bit of trouble narrowing it down"

User is online   Jblade 

  • 1,410

#1

Starting last week I had a message when I tried to start up my PC saying Boot device not found - turning it off and on again fixed it. It happened again the last couple of days, I did check inside my PC and couldn't see any loose cables or anything like that. I've ran like 3 different programs and scanned my SSD and none of them show any problems coming up; I also checked inside the BIOS but it says that windows boot manager is handling the startup.

Any ideas on what might be causing this? I've had this PC for 2 years now but once the PC starts up (which happens on the next attempt) it works absolutely fine. I can play games like XCOM2 or PUBG and I haven't had any crashing issues (that weren't related to the games themselves at least) so I feel if it was a more serious issue I would have more symptoms. I've heard the problem may be my SSD isn't starting up quick enough which is why it fails the first time but works fine the next attempt, is there anything I can do about that or is that a power supply problem?

I appreciate any help on this.
0

User is online   Mark. 

  • Honored Donor
  • 1,949

#2

Maybe to set a small delay to give the ssd time to power up,not sure if it will make a diff, is set the boot order to the cd or usb port before the ssd. Just a shot in the dark on that. If it does work its still just a bandaid, not a proper fix.

This post has been edited by Mark.: 17 September 2017 - 04:07 PM

1

User is offline   Micky C 

  • Honored Donor
  • 3,382

#3

Either way I would certainly make sure everything on your HD is properly backed up if it isn't already.

Polymer wishlist: Global illumination, SSAO, Bloom, reflective surfaces, adjustable specular (wetness), volumetric lighting.
Mapper of the Month December 2014.

Herbs? Tell me more!

This post has been edited by Micky C: 17 September 2017 - 04:43 PM

1

User is offline   Forge 

  • 4,914

#4

repair your MBR

windows 10 "Windows Settings" control panel menu (notification tray icon -> all settings)
updates & security
recovery
advanced start up -> restart now

reboots to 'Windows Recovery Menu' screen

troubleshoot
advanced options
command prompt

type then ht enter each command:

bootrec /ScanOs
bootrec /RebuildBcd
bootrec /fixMbr
bootrec /fixboot

exit & reboot system
1

User is online   Jblade 

  • 1,410

#5

I've been suspecting it's been the MBR, I'll defo give that a shot - thanks a lot Forge (and to Mark and Micky as well)
0

User is offline   Person of Color 

  • Senior Unpaid Intern at Viceland
  • 2,748

#6

<snip>

try this:

-Update the BIOS.

-Remove other boot devices from the list.

-Add boot devices to the list to increase the boot time. If this fixes it, buy a new SSD. Long initialization times are a bad omen with drives. I know it costs six months of work in Brittainistan to get one, but trust me it's worth it.

Posted Image
There is no race, only racists.
Proud trigendered babysexual pan-Korean anarcho-transhumanist
Muslims are peaceful people oppressed by cis white males! Hillary for presidynt!
WE WILL NOT BE SILENCED BY DONALD TRUMP'S VIOLENCE!

This post has been edited by oasiz: 03 October 2017 - 11:49 PM
Reason for edit: Not really the right forum for these jokes.

1

User is offline   Paul B 

  • 347

#7

View PostJblade, on 17 September 2017 - 10:14 AM, said:

I've heard the problem may be my SSD isn't starting up quick enough which is why it fails the first time but works fine the next attempt, is there anything I can do about that?


Your suspicion above is what it sounds like to me as well. The MBR isn't accessed until after the boot device is found. I kind of doubt it is an MBR thing when the message is clearly coming from the BIOS indicating the physical disk isn't present to boot. If it was a problem with the MBR you'd most likely see error messages pertaining to : Missing Operating System or Operating System Not Found.

Could be a SSD timing issue with the BIOS. Sometimes this might be resolved through a BIOS update or a firmware upgrade on the SSD drive or by adding a delay to HDD detection as I think Mark suggested. Perhaps changing your boot order so your CD/DVD ROM boots before your SSD might be enough. My guess is you've got an older motherboard with a newer SSD drive. Sometimes in the BIOS you can set the controller to SSD Generation2 or 3 for compatibility with SSD drives.

If you happen to have your head in your tower, check the CMOS battery. Make sure its 3 volts. If it can't retain BIOS settings it might not properly detect the SSD in time.

If your current hardware configuration has been working for a long time before today, then all of a sudden this started happening I'd suspect something is going weird with the hardware controller\SSD\SATA cable and has nothing to do with a firmware/bios update of any kind. You could always try a different SATA port if you don't suspect the SSD. Unfortunately these annoying problems are usually solved through a process of elimination. =S Make sure you always have a backup!


This post has been edited by Paul B: 11 October 2017 - 03:55 PM

1

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners. Yes, our forum uses cookies. © 2017 Voidpoint, LLC

Enter your sign in name and password


Sign in options