Duke4.net Forums: Simple way to install eDuke32 in Linux? - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Simple way to install eDuke32 in Linux?

User is offline   xlucas 

#1

Hi, guys! I'm new here in the forum.
I've long wanted to install eDuke32 on my computer. When I first found it online, I remember the web page included an Ubuntu icon together with the Windows, Mac and source code ones. Back then, unfortunately, I was quite a newbie with GNU/Linux and even that way, I wasn't able to install it. Since then, I have made several different attempts and I've noticed there doesn't seem to be a package for Ubuntu or Debian anymore. I've tried to compile the source but the dependencies kill me, I get completely lost (for example, I can't find the SDL2 packages... SDL1.2 supposedly should work, but I'm still getting lost with other dependencies).

I swear I've given more tries and more time to eDuke32 than to any other game in Linux to try to get it installed. I've read forums and watched videos on YouTube, but they seem old and use the packages that seem no longer available.

Is there a simple way I can get the game installed? Why have the Ubuntu packages been removed? Why is there so little support for GNU/Linux? I know some Linux users are pros and can handle anything, but many are not. Finally.... is there anything I can do to help? Like test something on my system so that somebody will find it easier to support it? I'm running a Xubuntu. I've got both the 32bit and the 64bit distros (having both has proved useful for a couple of programming tricks). Any help will be highly appreciated!
0

User is online   Micky C 

  • Honored Donor

#2

Have you looked through this page? http://wiki.eduke32....Duke32_on_Linux

I managed to build it from source on Ubuntu fairly easily with very little Linux knowledge. The page is fairly long, but really there's very little you actually need to type into the console, and it's just a matter of copy and paste.

Long story short it takes a bit of time to maintain frequent up to date linux packages for the distributions, and that time is better spent elsewhere.
0

User is offline   Hendricks266 

  • Weaponized Autism

  #3

sudo apt-get install build-essential nasm libgl1-mesa-dev libglu1-mesa-dev libsdl1.2-dev libsdl-mixer1.2-dev libsdl2-dev libsdl2-mixer-dev flac libflac-dev libvorbis-dev libpng-dev libvpx-dev libgtk2.0-dev freepats
svn checkout http://svn.eduke32.com/eduke32/
cd eduke32
make
0

User is offline   xlucas 

#4

Thank you, guys, for your prompt reply! Unfortunately, this has not helped and I had already visited that page and read it thoroughly. I had already tried installing that way. Here I share what I get when I attempt to use that install command:
(using italics instead of code because lines are too long and doesn't look good in a code block)

~$ sudo apt-get install build-essential nasm libgl1-mesa-dev libglu1-mesa-dev libsdl1.2-dev libsdl-mixer1.2-dev libsdl2-dev libsdl2-mixer-dev flac libflac-dev libvorbis-dev libpng-dev libvpx-dev libgtk2.0-dev freepats
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libpng12-dev' instead of 'libpng-dev'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
build-essential : Depends: g++ (>= 4:4.4.3) but it is not going to be installed
Depends: dpkg-dev (>= 1.13.5) but it is not going to be installed
libflac-dev : Depends: libflac8 (= 1.3.0-2) but 1.3.0-2ubuntu0.14.04.1 is to be installed
libgl1-mesa-dev : Depends: mesa-common-dev (= 10.1.0-4ubuntu5) but it is not going to be installed
Depends: libdrm-dev (>= 2.4.52) but it is not going to be installed
Depends: libxdamage-dev but it is not going to be installed
Depends: libxfixes-dev but it is not going to be installed
libgtk2.0-dev : Depends: libgtk2.0-0 (= 2.24.23-0ubuntu1) but 2.24.23-0ubuntu1.4 is to be installed
Depends: libglib2.0-dev (>= 2.27.3) but it is not going to be installed
Depends: libgdk-pixbuf2.0-dev (>= 2.21.0) but it is not going to be installed
Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
Depends: libatk1.0-dev (>= 1.29.2) but it is not going to be installed
Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed
Depends: libxi-dev (>= 1:1.0.1-4) but it is not going to be installed
Depends: libxcursor-dev but it is not going to be installed
Depends: libxfixes-dev (>= 1:3.0.0-3) but it is not going to be installed
Depends: libxcomposite-dev (>= 1:0.2.0-3) but it is not going to be installed
Depends: libxdamage-dev (>= 1:1.0.1-3) but it is not going to be installed
Recommends: debhelper but it is not going to be installed
libpng12-dev : Depends: libpng12-0 (= 1.2.50-1ubuntu2) but 1.2.50-1ubuntu2.14.04.2 is to be installed
libsdl1.2-dev : Depends: libsdl1.2debian (= 1.2.15-8ubuntu1) but 1.2.15-8ubuntu1.1 is to be installed
Depends: libpulse-dev but it is not going to be installed
libsdl2-dev : Depends: libdbus-1-dev but it is not going to be installed
Depends: libegl1-mesa-dev but it is not going to be installed
Depends: libgles2-mesa-dev but it is not going to be installed
Depends: libpulse-dev but it is not going to be installed
Depends: libudev-dev but it is not going to be installed
Depends: libxcursor-dev but it is not going to be installed
Depends: libxi-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


This post has been edited by xlucas: 25 April 2017 - 02:24 PM

0

User is offline   Hendricks266 

  • Weaponized Autism

  #5

Something is broken with your personal setup that is outside the scope of our project instructions. "Why is there so little support for GNU/Linux?" could not be further from the truth. Maybe TerminX or Mblackwell could help you here.
0

User is offline   TerminX 

  • el fundador

  #6

All I can guess is that you have a screwed up, mixed-and-matched repository configuration. What does the output of "apt-cache policy g++" say?
0

User is offline   xlucas 

#7

Hendricks: Sorry if what I asked didn't sound good. When I say "little support", I mean something like compatibility or things working smoothly and I understand this doesn't just have to do with the game developers, but also with the OS developers, the library developers and the fact that they are so many and each doing their thing separately. It's difficult to get all the pieces together in the huge GNU/Linux community. I just feel so frustrated with the dependency-hell! Really, if I can help in any way, I'll be happy to give a hand.

TerminX: Thanks for your help. The strange thing is that this has happened to me with at least two different versions of Ubuntu and Xubuntu and the one I'm using now has just been installed. What I'm getting from the apt-cache command is this:

~$ apt-cache policy g++
g++:
Installed: (none)
Candidate: 4:4.8.2-1ubuntu6
Version table:
4:4.8.2-1ubuntu6 0
500 http://mirror.fcaglp....edu.ar/ubuntu/ trusty/main i386 Packages


Do you recommend that I keep trying to install it here or would it be better to try on the 64bit one (which I also have installed)? When I tried there, it seemed to be I was getting even more errors, but maybe it's just I don't know what the errors are about.

Oh... one more thing. I've been taking a look (but not changing anything) with aptitude and upon selecting the first package (build-essentials) it brings a list of dependencies but "suggests" keeping everything in its current version (which, for all those packages means keeping them uninstalled). If I go to the next suggestions, I progressively get more and more downgrades and even some software such as GIMP uninstalled, but nothing seems to be installed, so I cancelled that.

This post has been edited by xlucas: 25 April 2017 - 05:47 PM

0

User is offline   TerminX 

  • el fundador

  #8

What does your /etc/apt/sources.list file look like, and what are the contents of /etc/apt/sources.list.d/ ?
0

User is offline   xlucas 

#9

View PostTerminX, on 25 April 2017 - 07:11 PM, said:

What does your /etc/apt/sources.list file look like, and what are the contents of /etc/apt/sources.list.d/ ?


Removing the comments, the sources.list file looks like this:
deb http://mirror.fcaglp....edu.ar/ubuntu/ trusty main restricted universe
deb-src http://mirror.fcaglp....edu.ar/ubuntu/ trusty main restricted universe

deb http://mirror.fcaglp....edu.ar/ubuntu/ trusty multiverse
deb-src http://mirror.fcaglp....edu.ar/ubuntu/ trusty multiverse

deb http://archive.canonical.com/ubuntu trusty partner
deb-src http://archive.canonical.com/ubuntu trusty partner

deb http://extras.ubuntu.com/ubuntu trusty main
deb-src http://extras.ubuntu.com/ubuntu trusty main


The directory /etc/apt/sources.list.d exists, but is empty. Not even hidden files.
0

User is offline   Hendricks266 

  • Weaponized Autism

  #10

Are those http://mirror.fcaglp....edu.ar/ubuntu/ addresses a Xubuntu thing? They stand out as potential causes for trouble.
0

User is offline   xlucas 

#11

View PostHendricks266, on 26 April 2017 - 02:19 PM, said:

Are those http://mirror.fcaglp....edu.ar/ubuntu/ addresses a Xubuntu thing? They stand out as potential causes for trouble.


Judging by the addresses, they do look very Ubuntu-specific. Yet, I haven't made any changes to the OS. This is how the file is set up when you just install Xubuntu. The Ubuntu family is the most widely used set of Linux distros, so I'm surprised not to see many people having the same problem :S
0

User is offline   Hendricks266 

  • Weaponized Autism

  #12

Not an Ubuntu thing, a Xubuntu thing. Ubuntu and Debian have no problem with the commands on the wiki page. Maybe remove the two .edu.ar addresses, and do the usual: sudo apt-get update; sudo apt-get dist-upgrade; sudo apt-get install -f; sudo apt-get autoremove

Then try our commands again.
0

User is offline   TerminX 

  • el fundador

  #13

View PostHendricks266, on 26 April 2017 - 03:13 PM, said:

Not an Ubuntu thing, a Xubuntu thing. Ubuntu and Debian have no problem with the commands on the wiki page. Maybe remove the two .edu.ar addresses, and do the usual: sudo apt-get update; sudo apt-get dist-upgrade; sudo apt-get install -f; sudo apt-get autoremove

Then try our commands again.

That's horrible advice as it would leave him without any repositories containing the main set of packages.

However, I think the problem here has more to do with "trusty" being something like 6 major OS releases behind (one every 6 months). No idea how you'd go about upgrading something that old, so you're on your own for that one.
0

#14

View Postxlucas, on 26 April 2017 - 03:11 PM, said:

Judging by the addresses, they do look very Ubuntu-specific. Yet, I haven't made any changes to the OS. This is how the file is set up when you just install Xubuntu. The Ubuntu family is the most widely used set of Linux distros, so I'm surprised not to see many people having the same problem :S


Last year I installed Eduke on a notebook running Linux Mint 17.3, then last week on a proper laptop running Mint 18.1, the instructions worked like a charm.

Dunno if the following will help - I'm still a bit of a Linux Noob - but as previous posts have been looking at repositories, I thought I'd list the ones I have for Mint 18.1 for comparison; I think there can be multiple files, not just /etc/apt/sources.list and using ... :

grep -h ^deb /etc/apt/sources.list /etc/apt/sources.list.d/* >> current.repos.txt


... gave the following list

deb http://packages.linuxmint.com serena main upstream import backport #id:linuxmint_main
deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ xenial partner


TTFN,
Jon
0

User is offline   xlucas 

#15

I see what you guys mean. Now I notice all the references to "trusty" in my sources. Why would this be? It's the latest LTS from Xubuntu. Maybe I should make a switch to Mint... although I really like Xfce (even though Mate was made by a fellow Argentinean).

Anyway... I kind of "solved" the issue partially. I installed Wine and then the windows version of eDuke32 on top of it and it runs fine. Not sure if the network capabilities will work transparently through that layer. Also, I've read that this was broken for the moment and that I should use an old version if I wanted to do multiplayer. Is this still the case?
0

User is offline   Mblackwell 

  • Evil Overlord

#16

Trusty is 14.04 LTS. You should be able to upgrade to 16.04 LTS.

This is what you should have set up if it's a new installation of Xubuntu:
https://xubuntu.org/release/16-04/

The resulting repositories would point to Xenial.

You can do a release upgrade (literally do-release-upgrade) to get there from Trusty however.
1

User is offline   TerminX 

  • el fundador

  #17

View PostMblackwell, on 27 April 2017 - 05:21 PM, said:

Trusty is 14.04 LTS. You should be able to upgrade to 16.04 LTS.

This is what you should have set up if it's a new installation of Xubuntu:
https://xubuntu.org/release/16-04/

The resulting repositories would point to Xenial.

You can do a release upgrade (literally do-release-upgrade) to get there from Trusty however.

This sounds like the solution to me. I'm very "old school" (15 years of Debian/Ubuntu experience) and tend to just edit my sources.list to point to the newer release manually, but the solution provided here looks to be the best suited for this case.
0

User is offline   xlucas 

#18

Oh! I've just seen what's going on! I was sure I had the latest LTS so I didn't understand how come the links pointed to trusty, but instead of installing from the just burnt DVD, I used the one I had from before! I'll have to install everything again or sooner or later, I will have more problems. It's not letting me just upgrade because of a couple of things I have installed. Looks like I should never keep old DVDs
0

User is online   NY00123 

#19

View Postxlucas, on 27 April 2017 - 07:23 PM, said:

Oh! I've just seen what's going on! I was sure I had the latest LTS so I didn't understand how come the links pointed to trusty, but instead of installing from the just burnt DVD, I used the one I had from before! I'll have to install everything again or sooner or later, I will have more problems.

Hopefully things will settle after installing 16.04, although this still looks a bit weird; I'm currently running a 3-years old Ubuntu 14.04 (Trusty) installation and I don't think I've experienced such issues, at least not so often.

After installing 16.04, if you get similar errors from apt-get, maybe try running "sudo apt-get update" first, just to refresh some packages lists.

Quote

It's not letting me just upgrade because of a couple of things I have installed.

I know it's not the easy solution, but I tend to prefer doing a clean install, especially after a few/some years. Yeah, software will have to be manually re-installed and a lot of data has to be manually set up (depending on the way it's arranged), but at least you get something clean. I may still try upgrades if it's for shorter period, although I haven't really done this recently.

Quote

Looks like I should never keep old DVDs

Nah, you should still keep your old data, just in case you won't regret it later :)

Or at least, when it comes to other kinds of discs (e.g., stuff differing from Linux distributions), make local backups (in the form of disc images). But that's truly a bit off-topic and I won't get into details now.

This post has been edited by NY00123: 27 April 2017 - 10:05 PM

0

#20

View Postxlucas, on 27 April 2017 - 04:56 PM, said:

Maybe I should make a switch to Mint... although I really like Xfce (even though Mate was made by a fellow Argentinean).


There are four Mint flavors, one of which is xfce, which I'm using.

TTFN,
Jon
0

User is offline   TerminX 

  • el fundador

  #21

View Postxlucas, on 27 April 2017 - 07:23 PM, said:

Oh! I've just seen what's going on! I was sure I had the latest LTS so I didn't understand how come the links pointed to trusty, but instead of installing from the just burnt DVD, I used the one I had from before! I'll have to install everything again or sooner or later, I will have more problems. It's not letting me just upgrade because of a couple of things I have installed. Looks like I should never keep old DVDs

I wouldn't bother burning DVDs at all in this day and age--just convert the .iso into a bootable USB drive using a tool like Rufus.
0

User is offline   xlucas 

#22

Thank you, guys. Yeah, I'll do a clean install, if not today, tomorrow. Besides, it's good to get used to reinstalling everything from time to time or else, one tends to forget some things and then it takes longer to reinstall. I'm using DVDs because they're cheap and I can afford discarding them, but the flash drive option is good too.

So, after I reinstall, I will try to get eDuke32 native running. Anyway, before I do that, I still would like to know these two things:

- Is the LAN/internet multiplayer game mode code still broken as it says in the site and I need to download an older version if I want to play multiplayer?
- If I run the Windows version under Wine, like I'm doing now, would that prevent the multiplayer system from working in any way?

Cheers :)
0

User is offline   McMarius11 

#23

i made a simple tutorial how to install eduke32 + DukePlus on Ubuntu based Distro

https://youtu.be/t3gkWAAiNwE

This post has been edited by McMarius11: 22 July 2019 - 06:36 AM

0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners. Instead of reading this text, you could be playing Ion Fury! ;) © 2019 Voidpoint, LLC

Enter your sign in name and password


Sign in options