Duke4.net Forums: EDuke32 2.0 and Polymer! - Duke4.net Forums

Jump to content

  • 213 Pages +
  • « First
  • 109
  • 110
  • 111
  • 112
  • 113
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic

EDuke32 2.0 and Polymer!  "talk about the wonders of EDuke32 and the new renderer"

User is offline   Hendricks266 

  • Weaponized Autism

  #3301

 Drek, on 15 December 2012 - 06:22 PM, said:

It works. I'm dizzy. Keyboard and mouse for me.

Thanks.

Could you retest the three problems you mentioned earlier using both the 64-bit you used to test joysticks and the latest (32-bit) synthesis build? I need to know if these are problems actually caused by 64-bit.
0

User is offline   supergoofy 

#3302

r3300 win32 binary build includes ebacktrace1-x64.dll,

probably for the directinput fix ion 64bit Windows.

This post has been edited by supergoofy: 15 December 2012 - 11:15 PM

0

User is offline   Hendricks266 

  • Weaponized Autism

  #3303

No, the DirectInput fix is internal to the executable. I committed the ebacktrace 64 dll to the package directory for convenience, so I wouldn't have to redistribute it with every new 64-bit build I make, and because I shrunk the size of the 32-bit dll from 5 MB to 1 MB anyway.

I didn't know it then, but we'll be seeing 64-bit builds in synthesis soon, so it will be useful.
1

User is offline   supergoofy 

#3304

Many thanks for the info and all your efforts for the 64bit binary :)
0

User is offline   Kyanos 

#3305

Just reading this now, sorry. I did test out the other issues. Save games fixed. Other issues stay the same.

I will do some more testing with both 32 and 64bit builds and add to my findings soon. Although I did go back to 32 bit to confirm before I posted bugs.

This post has been edited by Drek: 16 December 2012 - 11:34 AM

0

User is offline   Helixhorned 

  • EDuke32 Senior Developer

#3306

Revision 3303 includes more classic-like fog/visibility code, toggled with "r_usenewshading 2". It's actually the new default, so if you stuck with the deficient "r_usenewshading 1" before, you might not need to change anything. The difference is clearly seen in maps like E3L4, or wide open maps. Visibility 240 should now also work as expected. Check it out and tell me what you think!

edit: you also may want to set the other shade/visibility-related options to neutral values. That is, "r_ambientlight 1", "r_shadescale 1".
2

User is offline   Fox 

  • Fraka kaka kaka kaka-kow!

#3307

Is it me or it seems palmaps are not working in newer versions?
0

User is offline   Mike Norvak 

  • Music Producer

#3308

View PostHelixhorned, on 16 December 2012 - 11:32 AM, said:

Revision 3303 includes more classic-like fog/visibility code, toggled with "r_usenewshading 2". It's actually the new default, so if you stuck with the deficient "r_usenewshading 1" before, you might not need to change anything. The difference is clearly seen in maps like E3L4, or wide open maps. Visibility 240 should now also work as expected. Check it out and tell me what you think!

edit: you also may want to set the other shade/visibility-related options to neutral values. That is, "r_ambientlight 1", "r_shadescale 1".


Missed this!! Thank you Helix, gonna check it later.

EDIT: Now vis 240 works like expected, the problem comes with higher visibility values (241-255) where it becomes even more foggy. For example a 243 value in newshading = 2 looks like 254 in newshading = 0, a 253 value in ns = 2 looks like 64 in ns= 0. You may wonder: why he needs to use higher visibility values and not stick to 240?, the reason is that in 240 there's not fog at all so to make it a little bit more foggy you need to use higher visibilities, is like if the scale beginning at 255 and ends at 240.

I have maps with 250 vis that now looks even more foggy, there's no problem on turning to 243 or so, but if for some reason the system is changed again the map will look different again, and that's not the way vis should work anyway.
Hope you could check this issue. Thank you! :)

This post has been edited by Norvak: 18 December 2012 - 10:06 AM

0

User is offline   Hendricks266 

  • Weaponized Autism

  #3309

View PostFox, on 18 December 2012 - 08:47 AM, said:

Is it me or it seems palmaps are not working in newer versions?

Do you mean highpal? Palmaps got nuked years ago for sucking.
0

User is offline   Helixhorned 

  • EDuke32 Senior Developer

#3310

View PostNorvak, on 18 December 2012 - 09:25 AM, said:

but if for some reason the system is changed again the map will look different again, and that's not the way vis should work anyway.

Agreed! I should have better said "fog that's almost perfectly close to classic", so the intent is to never change it again. And the old visibility determination can be toggled with the mentioned cvar, after all. FYI, classic's fog can be expressed in terms of a starting and ending distance, interpolating linearly in between (and clamping to full visibility on the near side and full darkness/fog on the far side):

diststart = -D*shade/combvis
distend = D*(numshades-1-shade)/combvis,

where

numshades := 32,
combvis := globalvisibility * mod(visibility+16, 256),
D = const.

In contrast, the old Polymodes' fog calculation used a totally different kind of equation, making it impossible to always look the same as classic.

edit: corrected and edited the equations.
0

User is offline   Fox 

  • Fraka kaka kaka kaka-kow!

#3311

View PostHendricks266, on 18 December 2012 - 10:17 AM, said:

Do you mean highpal? Palmaps got nuked years ago for sucking.

Yeah, I meant highpals.
0

User is offline   Micky C 

  • Honored Donor

#3312

Seems that .ogg music files reverberate along with sounds around the ecco effect in maps. I'm guessing it's because the music is played through the sound system and this can't be changed?
0

User is offline   Hendricks266 

  • Weaponized Autism

  #3313

By all means it should be changed. Is there a location in the original game where I can test this?
0

User is offline   Micky C 

  • Honored Donor

#3314

Well I tried it out in the sewers in E1L2 and you can't really tell the difference, which might explain why this bug has gone unnoticed or whatever. I was playing a (beta) user map which had the effect turned up really high and it made the music incredibly tinny.
0

User is offline   Fox 

  • Fraka kaka kaka kaka-kow!

#3315

While working in a mod, the limtations and inconsistencies with the screen drawing commands often became a problem. Normally I use rotatesprite16, but gametext is necessary for drawing a text and it doesn't have the same accuracy. And frankly, overall the screen drawing seems very primitivee.

I would propose to have a new command that covers both fuctions of displaying tiles and text, and by having an entry for the quote which would display a text whenever the value doesn't equal -1. I also would like to define the horizontal and vertical scale independently, accuracy (which a value of 65536 would make it work like rotatesprite16), text spacing, and translucency (even if the function itself has not been implemented yet in Eduke32).

Other than that, I would look forward new orientation flags, which would control the text-align, and compatibility with hard-coded alphabets (by default gametextz will use STARTALPHANUM character set, which diffs from BIGALPHANUM).

This post has been edited by Fox: 22 December 2012 - 11:34 PM

0

User is offline   Mblackwell 

  • Evil Overlord

#3316

http://wiki.eduke32....iki/Orientation has bits for translucency? Not sure what else you'd like to do with it that means it wouldn't work for it, you'd have to post an example. Also you define the tile set you'd like to use with gametextz, so you can easily make a completely new font.

As for screen position, the different bits to set screen/tile orientation are important for accurate positioning, but in addition it is already possible to get the current screen size and with math magic do the positioning based on that.

http://wiki.eduke32.com/wiki/Xdim
http://wiki.eduke32.com/wiki/Ydim
0

User is offline   Fox 

  • Fraka kaka kaka kaka-kow!

#3317

View PostMblackwell, on 23 December 2012 - 07:14 AM, said:

http://wiki.eduke32....iki/Orientation has bits for translucency? Not sure what else you'd like to do with it that means it wouldn't work for it, you'd have to post an example.

Gradual translucency, ranging from 0 to 255. Even if the function doesn't exists yet in Eduke32 for tile on screen, it would be good to have it already predicted.

View PostMblackwell, on 23 December 2012 - 07:14 AM, said:

Also you define the tile set you'd like to use with gametextz, so you can easily make a completely new font.

I am speaking of character set, not tile set. Gametextz only work properly with STARTALPHANUM out of the default fonts in the game, because it uses only the Microsoft standard character set.

View PostMblackwell, on 23 December 2012 - 07:14 AM, said:

As for screen position, the different bits to set screen/tile orientation are important for accurate positioning, but in addition it is already possible to get the current screen size and with math magic do the positioning based on that.

http://wiki.eduke32.com/wiki/Xdim
http://wiki.eduke32.com/wiki/Ydim

All those forms are ugly hacks with side-effects.

This post has been edited by Fox: 23 December 2012 - 05:06 PM

0

User is offline   Mblackwell 

  • Evil Overlord

#3318

Side effects? I'm using it without side effects to erase unwanted portions of images at any resolution. The trick is to multiply by 65536 before doing your math.

Unless you can post a good use-case/example I don't think the request is going to get much attention, since there are quite a few ways of doing what it sounds like you'd like to do already.
0

User is online   blizzart 

#3319

Is there a reason why ifvrate.exe is removed from the samples directory in the newer builds (rev. 3245 and newer)?
0

User is offline   LeoD 

  • Duke4.net topic/3513

#3320

View Postblizzart, on 29 December 2012 - 03:50 PM, said:

Is there a reason why ifvrate.exe is removed from the samples directory in the newer builds (rev. 3245 and newer)?
Its handling has been adapted to the other Build utilities:
-No distribution of binaries within the EDuke32 synthesis builds.
-No automatic build with make unless you use a certain command, I think make utils.

IIRC Hendricks266 distributes Windows binaries of the utilities every now and then, but I can't find them right now.
0

User is offline   supergoofy 

#3321

http://hendricks266....dtools_r3164.7z
0

User is offline   Hendricks266 

  • Weaponized Autism

  #3322

I build new set of the tools every time there is a change to the tools themselves. Which reminds me, I am overdue with building a new kextract. (I added functionality so that the modification time of the GRP is propagated to all extracted files. It's handy if you keep your collection of all the GRPs with the original file modification dates intact.)

I keep the Win32 binary link updated here: http://wiki.eduke32....iki/Build_tools

There should be some way for Helix, rhoenie, and I to access Dukeworld so we could store important stuff there, like Helix and rhoenie's OS X builds, and my builds of the Build tools and EDuke32 Wii.
0

User is online   Mark 

#3323

I forgot how to turn off shadow casting from the SE50 spotlight. Can someone refresh my memory. I couldn't find the info after searching around.
0

User is offline   Micky C 

  • Honored Donor

#3324

You press 1 on the SE to make it one sided. It's just a few pages back in this thread.
0

User is online   Mark 

#3325

Thanks. Sometimes I guess I don't punch in the proper search words.
0

User is offline   Kyanos 

#3326

The latest build isn't starting under windows 7 again. Debug builds seem to work.

Added: Using latest build (3350) Eduke32.debug.exe to play todays new release.
Mirrors turned black when not aiming at them and close to them.

Attached Image: duke0000.png

This post has been edited by Drek: 31 December 2012 - 03:28 PM

0

User is offline   Plagman 

  • Former VP of Media Operations

#3327

God damnit; sorry about that, we were hoping that this toolchain would be good. Testing from TX and H266 on Win7 and 8 seemed to be conclusive, but I guess not. Reverted, so the new build should be good again.
0

User is offline   TerminX 

  • el fundador

  #3328

Does 3350 work if you delete nedmalloc.dll?
0

User is offline   Hank 

#3329

View PostTerminX, on 31 December 2012 - 04:12 PM, said:

Does 3350 work if you delete nedmalloc.dll?

Yes! http://forums.duke4.net/public/style_emoticons/default/smile.gif
but now I've got to go, all the best to the duke fam ........................................... http://forums.duke4.net/public/style_emoticons/default/smile.gifhttp://forums.duke4.net/public/style_emoticons/default/smile.gifhttp://forums.duke4.net/public/style_emoticons/default/smile.gifhttp://forums.duke4.net/public/style_emoticons/default/smile.gifhttp://forums.duke4.net/public/style_emoticons/default/smile.gifhttp://forums.duke4.net/public/style_emoticons/default/smile.gif
0

User is offline   Kyanos 

#3330

View PostPlagman, on 31 December 2012 - 03:40 PM, said:

God damnit; sorry about that, we were hoping that this toolchain would be good. Testing from TX and H266 on Win7 and 8 seemed to be conclusive, but I guess not. Reverted, so the new build should be good again.


I'll link tortoise svn up to the eduke repository and try to test things every so often on 64bit win 7. Feel free to ask me to test specific builds.

View PostTerminX, on 31 December 2012 - 04:12 PM, said:

Does 3350 work if you delete nedmalloc.dll?


Confirmed.
0

Share this topic:


  • 213 Pages +
  • « First
  • 109
  • 110
  • 111
  • 112
  • 113
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks not owned by Voidpoint, LLC are the sole property of their respective owners. Play Ion Fury! ;) © Voidpoint, LLC

Enter your sign in name and password


Sign in options