Duke4.net Forums: THE IMPERIUM RELEASED! - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

  • 6 Pages +
  • « First
  • 4
  • 5
  • 6
  • You cannot start a new topic
  • You cannot reply to this topic

THE IMPERIUM RELEASED!

User is offline   Trooper Dan 

  • Duke Plus Developer
  • 3,939

#151

 Forge, on 05 November 2017 - 02:09 PM, said:

used the dukeplus that came with it
used the eduke32.exe that came with it
used the imperium.bat to launch the game
started playing the episode (when asked to update to the latest eduke32 - selected 'No')

Everything seemed to work just fine. (in full screen 1280x960).

Start messing with the included dukeplus & eduke32 - then wonder why things don't work.


Yeah, the only component that you could probably update would be eduke32.exe. The other stuff is too risky without any benefit.

We can't be expected to endlessly maintain old projects to work with updated stuff. We are individuals with lives, not software companies. Heck, even software companies don't do that.
1

User is offline   Paul B 

  • 499

#152

 Forge, on 05 November 2017 - 02:09 PM, said:

People start messing with the included dukeplus & eduke32 - then wonder why things don't work.
Lurve that shit.


Well, I guess i'm the only one running Imperium on Windows 10 where it doesn't work with the supplied EDuke32. In any case, my site will offer a version that will work. I am not even too concerned about getting the HRP working. I was just interested in actually getting a functional vanilla Imperium working. Otherwise a default install of Imperium places me in a state where i can barely use windows after I run the Imperium batch file as it disables my mouse input as well. To top it all off Microsoft Windows Defender also wants to prevent the old supplied Eduke from running. While I was at it earlier I had updated the Imperium download to the latest DukePlus. The version of Imperium I am using is the one downloaded from the first post in this forum. Is there a better version somewhere else I might be missing? Perhaps i'm running a beta?

What I can do is re-release the project without any additional code changes and just provide the updated Eduke32.exe version. That will fix my only concern making it compatible on my Windows 10 and for anyone else who might be running my windows 10. Otherwise i'm not seeing any real problems other than the outdated Eduke program. I'm not familiar with DukePlus to know how its suppose to play out. Over the next little while I will need to get acquainted with it.

I suppose the Episode selection also displays just fine on everyone else's computer without a hidden episode selection which takes you back to the start screen.


This post has been edited by Paul B: 05 November 2017 - 04:22 PM

0

User is offline   Forge 

  • 8,665

#153

 Paul B, on 05 November 2017 - 03:59 PM, said:

Well, I guess i'm the only one running Imperium on Windows 10 where it doesn't work with the supplied EDuke32.

true.

 Paul B, on 05 November 2017 - 03:59 PM, said:

In any case, my site will offer a version that will work.

soo....the original version - since it works for everyone, except you and your special computer with video card/driver issues and built in anti-virus software that tries to prevent it from running.

 Paul B, on 05 November 2017 - 03:59 PM, said:

I was just interested in actually getting a functional vanilla Imperium working.

you mean...like the original version in the op? good idea.

 Paul B, on 05 November 2017 - 03:59 PM, said:

Otherwise I end up in a state where i can barely use windows after I run the Imperium batch file. To top it all off Microsoft Windows Defender also wants to prevent the old supplied Eduke from running. While I was at it earlier I had updated the Imperium download to the latest DukePlus.

sooo...you intend on implementing a "fix" for your computer that everyone else can enjoy while it breaks theirs? good idea.


 Paul B, on 05 November 2017 - 03:59 PM, said:

The version of Imperium I am using is the one downloaded from the first post in this forum. Is there a better version somewhere else I might be missing? Perhaps i'm running a beta?

that's the one and only official version that i'm aware of

 Paul B, on 05 November 2017 - 03:59 PM, said:

So what I will do is re-release the project without any additional code changes and just provide the updated Eduke32.exe version. That will fix my only concern making it compatible on my Windows 10 and for anyone else who might be running my windows 10.

or you could just leave it alone and put a note on your download page to update their eduke32 to the latest if they have problems.
logistically, you're attaching a version of eduke32 that will also be outdated some day - which may cause potential problems for goobacks.

This post has been edited by Forge: 05 November 2017 - 04:25 PM

1

User is offline   Paul B 

  • 499

#154

 Forge, on 05 November 2017 - 04:24 PM, said:

true.

or you could just leave it alone and put a note on your download page to update their eduke32 to the latest if they have problems.
logistically, you're attaching a version of eduke32 that will also be outdated some day - which may cause potential problems for goobacks.


Well i find it hard to believe that the old Version of Eduke works on Windows 10. So I have half a dozen computers all running windows 10 at my disposal. I'll see what happens on them and go from there. If it appears that only one computer has the problem then I will just leave it in tact and place a note on my download page mentioning that an update might be required to Eduke to play this mod properly in Windows 10. Otherwise 'll leave it with the updated version of Eduke32 to prevent problems.

*** Updated ***

Alright, so I tried the mod on another Windows 10 PC and it worked just fine with the exception of a Windows Defender Message that pops up, but it didn't render the computer almost useless which was nice. So chances are its a problem with the Nvidia Driver that is installed and the version of Eduke32 that is supplied with the mod.

Thanks for all your input, Forge has a way to take a problem and make it simple. =) I'll take down my separate download and only supply the original file with a note to possibly update Eduke should a problem arise. ( I'm not trying to create more problems).


This post has been edited by Paul B: 05 November 2017 - 05:00 PM

0

User is offline   Forge 

  • 8,665

#155

 Paul B, on 05 November 2017 - 04:30 PM, said:

Thanks for all your input, Forge has a way to take a problem and make it simple

I ran into similar issues at CGS when I was dealing with some of the older TCs like Platoon & Starship Troopers.
Found it was best just to leave the TC in its original state & post up a block of instructions on how to get it to work.

Sorry if I came across as a dick. Real life issue frustration creep. Still uncalled for though, so my apologies.

This post has been edited by Forge: 05 November 2017 - 07:52 PM

1

User is online   Jim 

  • 32

#156

So its seems that there needs to be an older version of the HRP and patch to work correctly? I am not sure where to get it. Can somebody link it here?
0

User is offline   LeoD 

  • 531

#157

 Jim, on 20 July 2018 - 11:33 PM, said:

So its seems that there needs to be an older version of the HRP and patch to work correctly?
No, not really.

 Jim, on 20 July 2018 - 11:33 PM, said:

I am not sure where to get it. Can somebody link it here?
Just get the latest HRP and add the corresponding Polymost HRP Override Pack (follow my signature) to your autoload folder. Imperium wasn't made for Polymer, therefore you should use the Polymost renderer for playing.
1

User is online   Jim 

  • 32

#158

Thanks, what about the Dukebot crouching model problem?
0

User is online   Jim 

  • 32

#159

Just to answer my own question and help others, the code posted by LeoD above worked for the crouching dukebot
1

User is online   Jim 

  • 32

#160

So I am now playing through imperium properly, and I just want to ask, are octobrains supposed to be that tough? two blasts and duke is done?
0

User is offline   Trooper Dan 

  • Duke Plus Developer
  • 3,939

#161

It should take at least 3 hits, not 2. The default value for COOL_EXPLOSION_STRENGTH is 38. There could be a glitch, depending on the snapshot you are using and the scripts. I think there was a bug at one point with eduke32 where FIRELASER would do extra damage because multiples of the sprite chain would hit, but I don't recall if the octabrain projectile ever did extra damage.
1

User is online   Jim 

  • 32

#162

where do I go from here? this is level 4, the alien mothership

Attached thumbnail(s)

  • Attached Image: 65428215_528325251300082_7044475586462351360_n.jpg

0

User is online   Jim 

  • 32

#163

Nevermind, missed a button, figured it out
0

User is online   Jim 

  • 32

#164

Having Finished imperium properly, I can say it is great. Definitely agree that the levels feel huge despite them being medium sized. The Highlights for me were levels 3 and 4. A monster computer is definitely required for that last level tho. Playing it with the HRP gave me some "what if DNF 2001" feel.
1

Share this topic:


  • 6 Pages +
  • « First
  • 4
  • 5
  • 6
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners. Instead of reading this text, you could be playing Ion Fury! ;) © 2019 Voidpoint, LLC

Enter your sign in name and password


Sign in options