Duke4.net Forums: BUG REPORTS - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

  • 3 Pages +
  • 1
  • 2
  • 3
  • You cannot start a new topic
  • You cannot reply to this topic

BUG REPORTS

User is offline   Trooper Dan 

  • Duke Plus Developer

#1

Post bug reports here. Thanks!
0

User is offline   Forge 

#2

Open Season

Less than 5 minutes into the map. Shot by one of those half-bodied creatures that launch rockets.
When hit by the rocket, the sound locked into a buzz and the computer crashed (similar to what used to happen with the old sound crashes).
All drivers are up to date.

Attached all files associated with the event in a zip.
0

User is offline   The Commander 

  • I used to be a Brown Fuzzy Fruit, but I've changed bro...

#3

I completed Medievil Cress and looking at my stats I noticed that I had not found an apple, while still on the stats screen with the flyby of the area I reloaded a save game just before the cyberdemon boss fight so I could find that apple.
It was then I noticed that noclip had been enabled. Possibly due to the flyby camera on the stat screen?
But I then also thought reloading a save game should return everything to that exact state and not have cheats as such enabled.
0

User is offline   Trooper Dan 

  • Duke Plus Developer

#4

View PostThe Commander, on Feb 26 2011, 07:59 AM, said:

I completed Medievil Cress and looking at my stats I noticed that I had not found an apple, while still on the stats screen with the flyby of the area I reloaded a save game just before the cyberdemon boss fight so I could find that apple.
It was then I noticed that noclip had been enabled. Possibly due to the flyby camera on the stat screen?
But I then also thought reloading a save game should return everything to that exact state and not have cheats as such enabled.


Your analysis seems correct. I'm not sure whether to consider this an eduke bug or not.
I can fix that, but it means that clipping will be on whenever a saved game is loaded, regardless of whether it was on when you saved the game.
0

User is offline   Trooper Dan 

  • Duke Plus Developer

#5

View PostForge, on Feb 26 2011, 05:58 AM, said:

Open Season

Less than 5 minutes into the map. Shot by one of those half-bodied creatures that launch rockets.
When hit by the rocket, the sound locked into a buzz and the computer crashed (similar to what used to happen with the old sound crashes).
All drivers are up to date.

Attached all files associated with the event in a zip.


Maybe one of the eduke developers will see this and be able to do something, but I doubt it. I'm only capable of fixing CON related stuff, and this clearly isn't. The good thing is that it seems to be extremely rare now, as you are the only person it happened to and it only happened once.
0

User is offline   Plagman 

  • Former VP of Media Operations

#6

Did the old sound crashes actually cause blue screens on your end? They should only have caused EDuke32 to terminate. :P
Anyway, I suggest playing with eduke32.debug.exe in the future, so that any future crashes can be caught more efficiently.
0

User is offline   Forge 

#7

Yes. Suffered a BSOD.

Is there a debug.exe for the version of eduke that came with this beta. I don't want to go mixing my drinks before noon.
0

User is offline   Plagman 

  • Former VP of Media Operations

#8

I don't know which version of eduke32 DT included, but it's probably one of the synthesis builds.
0

User is offline   Trooper Dan 

  • Duke Plus Developer

#9

I included the one that was the most recent at the time I put together the package, but I always use the latest synthesis build and recommend everyone do the same.

A bug was fixed since the initial package which fixes the quad damage palette, so definitely use the latest.
0

User is offline   Plagman 

  • Former VP of Media Operations

#10

BTW, the bug was just that DREALMSPAL and TITLEPAL were inverted for their setgamepalette meaning, so if you just make the quad damage palette take both of these you'll also be compatible with old versions.
0

User is offline   The Commander 

  • I used to be a Brown Fuzzy Fruit, but I've changed bro...

#11

Is it me or do the Heros and 6800 (what ever his name his) have a hard time killing the slime golems, I just made a small test map and 3 heros were killed by one slimer... yet when I tried it again they had no trouble killing it the second time round.

This post has been edited by The Commander: 27 February 2011 - 02:39 AM

0

User is offline   Trooper Dan 

  • Duke Plus Developer

#12

View PostThe Commander, on Feb 27 2011, 02:35 AM, said:

Is it me or do the Heros and 6800 (what ever his name his) have a hard time killing the slime golems, I just made a small test map and 3 heros were killed by one slimer... yet when I tried it again they had no trouble killing it the second time round.


Yeah the problem is they attack by shooting short range bullet type projects to simulate melee, but the slimers get short and they become hard to hit. I'll try to adjust things.
0

User is offline   The Commander 

  • I used to be a Brown Fuzzy Fruit, but I've changed bro...

#13

http://img715.imageshack.us/img715/2668/duke0000.jpg

Looks good and normal.

http://img541.imageshack.us/img541/4108/duke0001.jpg

The bottom line is cut off on the sides, it might be readable on a wide screen monitor but I can't see it on my CRT.

This post has been edited by The Commander: 28 February 2011 - 07:18 AM

0

User is offline   Trooper Dan 

  • Duke Plus Developer

#14

Yeah I play in widescreen almost all the time, I'll have to shrink that down.
0

User is offline   E.C.S 

#15

DT, do you remember that little bug in Attrition?, well...

http://img232.imageshack.us/img232/4256/56127365.jpg
0

User is offline   Trooper Dan 

  • Duke Plus Developer

#16

Haha, ok.

You have to admit, that is a very small bug. But I'll fix it.
0

User is offline   E.C.S 

#17

Yeah, sorry, but a bug, is a bug :huh:.
0

User is offline   Taamalus 

#18

better image as my English
http://img146.imageshack.us/img146/9952/doublekey.th.jpg
when you start playing, conflicting key assignments are either ignored or you will do two actions simultaneously. You only will notice that after you start playing, not while you set up your keys. The image shows the incorrect setup side by side. When the user makes that error overriding key assignments he/she does not use, say '[' change weapons and 'R' POW Key, you experience mystery effects during game play. It's probably Eduke32 stuff and technically not a real bug, but then I need to define the cause, and, and, and play Duke, will not happen, your TC is much more fun.

It's fixed for now, I made a list of all possible assignments, and typed it in.
0

User is offline   Trooper Dan 

  • Duke Plus Developer

#19

Yeah, that's an eduke32...uh...feature that has been around forever. It might even go back all the way to DOS Duke.
0

User is online   Mike Norvak 

  • Music Producer

#20

Not a big bug, but when the level ends and starts the victory lap sequence there isn't any music change, it is supposed to play "endlevel" MIDI track right?
0

User is offline   Plagman 

  • Former VP of Media Operations

#21

Some people actually use key conflicts, like binding the medkit to strafe left to always be using it in multiplayer.
0

#22

I found a very minor bug in "Utter Chaos". At the temple after jumping across the rock pillars, one of the Chaos Serpents somehow slipped under a door and got itself squished. It only happened once, but I find it odd (and hilarious). Complete with "SQUISH!" message.

Also, handling of music changes has been broken in the entire Siege Breaker episode. Victory music plays at the Nexus at the very start of the game, the "Game Over" theme plays as soon as I walk into the area with the first Sabreclaw enemies, the music that plays when you leave the room where enemies really start pouring out plays as soon as I walk into the room, and such. Really strange bug there.
0

User is offline   Trooper Dan 

  • Duke Plus Developer

#23

View PostSerious Cacodemon, on Mar 5 2011, 03:24 PM, said:

Also, handling of music changes has been broken in the entire Siege Breaker episode. Victory music plays at the Nexus at the very start of the game, the "Game Over" theme plays as soon as I walk into the area with the first Sabreclaw enemies, the music that plays when you leave the room where enemies really start pouring out plays as soon as I walk into the room, and such. Really strange bug there.


I wish you had been a beta tester. The testers we had didn't remember enough of Siege Breaker to spot anything like that. This problem may be caused by a change I made to the MUSICSWITCH effect to achieve something in the new episode. I'll be sure to fix it as part of the patch that I'm working on.

EDIT: The victory music does play during the character selection screen, but that's not a bug. I'll look into the rest.

EDIT2: And...I just looked at the MUSICSWITCH for the Sabreclaw area and it does indeed tell the game to play the Game Over theme. So from a code standpoint, it is working correctly (nor do I think the map has been modified). Do you know which track it played there before?

EDIT3: Now I see what is going on. It really is fucked up. All the MUSICSWITCH sprites are acting like touchplates and are activating as soon as you enter their sectors, instead of waiting for the appropriate activation.

This post has been edited by DeeperThought: 05 March 2011 - 04:04 PM

0

User is offline   Micky C 

  • Honored Donor

#24

Edit: I started writing this post before you replied DT.

View PostNorvak, on Mar 6 2011, 07:54 AM, said:

Not a big bug, but when the level ends and starts the victory lap sequence there isn't any music change, it is supposed to play "endlevel" MIDI track right?


It plays for the Siege Breaker episode, but it didn't play for the WGRealms episode. I can't remember if it played for Utter Chaos and Castle Demonhorn though.


View PostSerious Cacodemon, on Mar 6 2011, 08:54 AM, said:

...snip...
Also, handling of music changes has been broken in the entire Siege Breaker episode. Victory music plays at the Nexus at the very start of the game, the "Game Over" theme plays as soon as I walk into the area with the first Sabreclaw enemies, the music that plays when you leave the room where enemies really start pouring out plays as soon as I walk into the room, and such. Really strange bug there.


The victory music only plays at the start with jedric, not with Duke. I also noticed with jedric that at the end of the episode when the victory music was meant to play, the normal nexus music played, I'm not sure if it does this with Duke as well or not.

Also with Axon, I remember something about him telling Duke about getting through the stalagmites as his first test, and he doesn't seem to say that anymore. He also gives Duke the 'gift' before getting through the stalegmites as opposed to before when he gave it when duke reached the vicinity of the first chest.
When playing with Jedric, Axon gives him the 'gift' immediately, which might not be so bad in itself but he says "a gift for you" at the same time as doing his normal speech so both voice clips are playing at the same time.

This post has been edited by Micky C: 05 March 2011 - 04:05 PM

0

User is offline   Trooper Dan 

  • Duke Plus Developer

#25

I'm working on the music bug, guys. It's unfortunate that it got through to the released version, but at least it doesn't break gameplay or crash the game or anything like that.
0

#26

I found a very bizarre bug that occurs in the "Open Season" level, involving a Cyberdemon shooting at the sky for no apparent reason. I've only been able to catch it in the act in screenshot, and I don't know how easy it is to reproduce this.

I also noticed texture problems in "Open Season" where one of the chairs in the room where you activate the drill has a gap in it, and "Temple Cress" with texture problems on the slopes before the final twisting cave passage containing tons of treasure chests in it. I do have screenshots of the offending bugs and texture issues if you want to see what I mean.
0

User is offline   Trooper Dan 

  • Duke Plus Developer

#27

View PostSerious Cacodemon, on Mar 6 2011, 08:01 PM, said:

I found a very bizarre bug that occurs in the "Open Season" level, involving a Cyberdemon shooting at the sky for no apparent reason. I've only been able to catch it in the act in screenshot, and I don't know how easy it is to reproduce this.

I also noticed texture problems in "Open Season" where one of the chairs in the room where you activate the drill has a gap in it, and "Temple Cress" with texture problems on the slopes before the final twisting cave passage containing tons of treasure chests in it. I do have screenshots of the offending bugs and texture issues if you want to see what I mean.



The cyberdemon was very far away when he was shooting the sky, right? If so, that's not a bug I can fix, it's an engine limitation and it's not a big problem. The other stuff falls into the category of details that should be fixed some day. No need to send screens at this time, your descriptions should be enough to find the problems when someone gets around to it.
0

User is offline   Micky C 

  • Honored Donor

#28

That reminds me of one of the levels from WGRealms episode that wasn't in the original WGRealms 1, I can't remember the name of it but it had crucifix tombstones made out of sprites, and maybe some of the sprites (which I'm guessing are one-sided) were oriented around the wrong way because they were invisible. I hope that helps.
0

User is offline   Trooper Dan 

  • Duke Plus Developer

#29

View PostMicky C, on Mar 6 2011, 10:51 PM, said:

That reminds me of one of the levels from WGRealms episode that wasn't in the original WGRealms 1, I can't remember the name of it but it had crucifix tombstones made out of sprites, and maybe some of the sprites (which I'm guessing are one-sided) were oriented around the wrong way because they were invisible. I hope that helps.


I know which part you mean, but I just assumed the sprites were missing completely on some sides.
0

#30

While not a particularly useful bug to exploit, it can actually happen that, when you kill yourself with the rocket launcher by using it's altfire (fully loaded), the ammo you have for that weapon starts increasing on and on and on.. (might have to toy with this a tiny bit to get it to work)
Just an amusing thing, I guess, nothing that bad.

Saw it first in WGR 1.2 I believe.

This post has been edited by Ryan Cordell: 09 March 2011 - 07:09 AM

0

Share this topic:


  • 3 Pages +
  • 1
  • 2
  • 3
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners. Instead of reading this text, you could be playing Ion Fury! ;) © 2019 Voidpoint, LLC

Enter your sign in name and password


Sign in options