Duke4.net Forums: Compiling EDuke32 for Wii - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Compiling EDuke32 for Wii

User is offline   TDRR 

  • 9

#1

I want to compile EDuke32 for the Wii so as to bring it up to date and maybe even experiment with it, but i don't see wiibuild.bat anywhere and a search for it gave no results.

Indie game developer along with my friends, usually i'm making maps both for my games and for Duke.
Mapping is fun, if you find it interesting, don't hesitate to open up Mapster32 and free your creativity!
0

User is online   TerminX 

  • el fundador
  • 4,923

  #2

Check platform/wiibuild.sh. :)

EDuke32 ? wiki ? svn builds ? bugs
Join us in #eduke32 on irc.freenode.net!
0

User is online   Hendricks266 

  • EDuke32 Senior Developer
  • 5,252

  #3

Hey, yeah I converted wiibuild.bat to wiibuild.sh because I was sick of batch file hacks and I can easily run bash on Windows.

But that's more for the sake of me packaging builds. All you technically need to do is have devkitPro set up properly and invoke `make PLATFORM=WII`.

I must warn you though, that something about the most recent devkitPro versions has produced binaries that always crash, and there are also issues with running on the Wii U's vWii. I could talk at length about the technical details involved of what I know about the problem if you would like.

That said, as long as you're using our SVN, you will be up to date as far as EDuke32 is concerned. It should still build out of the box.

I have not had time to test on my Wii recently, let alone reserve development time. I did some unrelated work that may have changed the symptoms I last experienced.
0

User is offline   TDRR 

  • 9

#4

Really? Okay, but one more thing, why is it that after a while, the graphics in the game look like this, has this been fixed or it has something to do with the Wii's VRAM?
So i don't have to run wiibuild.sh but instead just run `make PLATFORM=WII` on the source's directory? (I have compiled stuff for Wii before, but the setup was already done and i didn't have to fiddle with command line stuff)

Indie game developer along with my friends, usually i'm making maps both for my games and for Duke.
Mapping is fun, if you find it interesting, don't hesitate to open up Mapster32 and free your creativity!

This post has been edited by TDRR: 15 July 2017 - 11:46 AM

0

User is online   Hendricks266 

  • EDuke32 Senior Developer
  • 5,252

  #5

I have not experienced the corruption you describe so I can't diagnose it. :(

Yes, that should build. On my setup the build is currently broken, so let me push a quick fix. EDIT: Pushed.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners and all comments are owned by their posters. Yes, our forum uses cookies. © 2004-2017 Duke4.net and Voidpoint, LLC

Enter your sign in name and password


Sign in options