Duke4.net Forums: Two problems with Mapster32 in Ubuntu - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Two problems with Mapster32 in Ubuntu  "Window keeps Focus / Level start point doesn't work"

User is offline   Big Bene 

  • Youngloov
  • 8



After having done some mapping back in the early 2000's with the original Build.exe, I recently came back to the Duke. You can read more of it here.

I have not much time for this, so progress is steady, but slow.
(I'm at work until 6 pm most days, and have only a thin client computer with very restricted rights here. I can devote a few minutes every now and then to the project, but the only things I can do are artwork (The Gimp is installed here), and internet research, including posting in this forum. All actual mapping has to be done at home, and I share the computer there with my wife (who runs a small business at Ebay) and my little son, who wnats to do games or watch Youtube with me, whenever I sit on the computer, and having had nothing of him during the day, I just cannot deny this).

I'm still in the beginning steps of two small maps I started rather for learning purposes, but now I'm beginning to encounter problems, which I will post here.
I have compiled Mapster32 from the source code under Ubuntu Linux, following the description on the Eduke Website, and it works fine, with some really bad exceptions.

I cannot place the Level starting point. Manual says I can do so by pressing CapsLock, but this just doesn't work. The brown arrow just stays at the default place in the center of the map.

The Mapster window forcefully keeps the focus.
I can't move the mousepointer outside the window, and cannot use another window / application other than by exiting Mapster. The only way to circumvent this is pressing the System / Windows-key to open the system manager, and then clicking at some other window (ignoring the system manager). Mostly, I can resume Mapster after this by clicking in the Window again, but often enough, it acts errately after such treatment. Even when it doesn't, this is a "dirty" and inconvenient workaround, and certainly not the way it was ment to work.
Also, I can't move the window out of the canter of the screen. It also can'T be minimized.

I have asked the second question in another thread, and already got the answers:

View PostMike Norvak, on 16 May 2017 - 05:56 AM, said:

Press the console key in the keyboard, you know, the one to the left of "1" that releases the application window.

Thanks, man, but I tested it and it didn't have any effect.
(We are talking about the ° and ^ key on the Qwertz keyboard = the ~ and ' key on the Qwerty keyboard, is this correct?)

I remember there was another answer, which seems to have disapeared. Something about the settings of Mapster...
If the author of this answer reads this, please answer again. Even the slightest hint could be useful.

This post has been edited by Big Bene: 18 May 2017 - 01:17 AM


User is online   Mark. 

  • Honored Donor
  • 2,299


What manual? Its ScrLk key, not CapsLock key.

User is offline   Big Bene 

  • Youngloov
  • 8


View PostMark., on 18 May 2017 - 02:49 AM, said:

What manual? Its ScrLk key, not CapsLock key.

My fault. Just misread that - the ScrlLk is so rarely used nowadazs, I just read "CapsLk".
Good thing I asked - I prefer a minor error on my side to a software bug that would probably be more difficult do resolve.

Share this topic:

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

All copyrights and trademarks are property of their respective owners. Instead of reading this text, you could be playing Ion Maiden! ;) © 2018 Voidpoint, LLC

Enter your sign in name and password

Sign in options