Duke4.net Forums: Mapster display issue - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Mapster display issue

User is offline   conoklast 

  • 5

#1

I've recently come across this problem since getting a new PC; basically mapster is displaying voxels at double their in-game size. This isn't a massive issue, as they display correctly in game, but it does make editing in 3d mode a bit clumsy.

Attached Image: voxel_display.png

I didn't re-install or update my mapster version. I literally copied the entire folder from my old PC to my new one. I didn't have this issue previously, but in case it matters I'm using version r5056 (the one that came with AMC TC episode 2)

Thanks
0

User is online   Micky D 

  • Honored Donor
  • 3,341

#2

Have you tried toggling between wall-aligned and view-aligned? Also, what's that map there?

Polymer wishlist: Global illumination, SSAO, Bloom, reflective surfaces, adjustable specular (wetness), volumetric lighting.
Mapper of the Month December 2014.

Herbs? Tell me more!
0

User is offline   conoklast 

  • 5

#3

View PostMicky C, on 23 February 2017 - 04:10 AM, said:

Have you tried toggling between wall-aligned and view-aligned? Also, what's that map there?


I hadn't tried that; just did then but it didn't rectify the sizing issue. I've left most of my voxel models view aligned; is it preferable to use wall aligned?

This issue doesn't occur with sprites; they display as they should both in mapster and in-game.

Map is my own personal project, I just prefer to use the AMC version of mapster because of the extra functionality.
0

User is offline   conoklast 

  • 5

#4

Just figured it out. Turns out when I changed mapster's display settings (because of new PC setup) I set 3d mode to 32bit display. I changed this back to 8bpp and now it displays as it should.
0

User is online   Micky D 

  • Honored Donor
  • 3,341

#5

View Postconoklast, on 23 February 2017 - 10:35 PM, said:

Just figured it out. Turns out when I changed mapster's display settings (because of new PC setup) I set 3d mode to 32bit display. I changed this back to 8bpp and now it displays as it should.



That means there's inconsistency between the renderers, which is a bug and should be fixed. I'm not sure which is preferable between view aligned and wall aligned.

Does the problem continue when you're using the latest mapster32 executable?

Polymer wishlist: Global illumination, SSAO, Bloom, reflective surfaces, adjustable specular (wetness), volumetric lighting.
Mapper of the Month December 2014.

Herbs? Tell me more!
0

User is offline   conoklast 

  • 5

#6

View PostMicky C, on 24 February 2017 - 02:29 AM, said:

That means there's inconsistency between the renderers, which is a bug and should be fixed. I'm not sure which is preferable between view aligned and wall aligned.

Does the problem continue when you're using the latest mapster32 executable?


Yep just checked, and even with latest version (r6068) the voxels only display correctly in 3d view at 8bpp.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners and all comments are owned by their posters. Yes, our forum uses cookies. © 2004-2017 Duke4.net and Voidpoint, LLC

Enter your sign in name and password


Sign in options