Duke4.net Forums: Build/Mapster keys not working under Linux - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Build/Mapster keys not working under Linux

User is offline   wapiti 

  • 0

#1

Oy!

Iím running Lucid and I installed EDuke32 and Mapster32 with the official APT repos.

I have a pretty annoying issue with my keyboard (full-size USB QWERTY). So far the following keys just wonít work in Mapster32:

` [ ] \ . /

I thus cannot make slopes in the editor or automatically pan tiles. These keys wonít work in JonoFís Build either. I can type those characters in the mapís filename though. When configuring the keys in EDuke32, they are recognized as numbers.

Can anyone help me? I could not find any answer on the web.
0

User is offline   William Gee 

  • 98

#2

Its posible to remap (Change) your keys, open mapster32.cfg in notepad to make the changes, go to the bottom and see the instructions.

Example.
remap = 10-3A,52-4C,53-B8
0

User is offline   Forge 

  • 8,436

#3

And after you've made those changes to the cfg file, change the property of the file to "read only" so it won't change the keys every time you launch mapster.

This post has been edited by Forge: 24 November 2010 - 02:51 PM

0

User is offline   wapiti 

  • 0

#4

Wow thanks that worked!

Could you tell me which keys are not used in Mapster32? I wouldnít like my keys to overlap. :P
0

User is offline   Jhect 

  • -111

#5

i changed my keys too because of the stupid numlock button setup thing thing. but the only keys that i remember that i changed right now is REnter-RCtrl. then some of the num lock keys that streches the tiles. i think it is originally numlock 2-4-6-8. 2 and 8 being opposites and 4 and 6 being opposites.
0

User is offline   Helixhorned 

  • EDuke32 Senior Developer
  • 700

#6

To the OP:
this really seems like a misconfiguration of X (or the keyboard part) to me. The way I understand it is than X effectively adds another translation stage to the keys that is moreover visible to the application. This is unlike Windows, where raw keycodes seem to be passed to it. Are you running a non-US keyboard layout by chance? It could be as simple as that.

Fixes for various other issues:
* AltGr
* dead key cominations like Shift-KP5-KP8/2
* needs solution: caps lock if it's remapped to Ctrl...

(o~ Lunatic home: documentation, stand-alone LuaJIT, LunaCON and utilities ~o)
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners. Instead of reading this text, you could be playing Ion Maiden! ;) © 2018 Voidpoint, LLC

Enter your sign in name and password


Sign in options