Duke4.net Forums: BuildGDX & Blood: CD/MP3 music and cutscenes? - Duke4.net Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

BuildGDX & Blood: CD/MP3 music and cutscenes?

User is offline   Rekrul 

#1

I've had Blood setup to run in DOSBox for a while, but just recently tried BuildGDX. I ran BuildGDX, went to the Blood section and pointed it to my Blood directory. The game works, but the cutscenes don't play. The opening logos play, but not the in-game cutscenes, even though they're enabled in the options menu. They play in DOSBox (although the opening logos don't play there).

How can I fix this?

Also, how do I set it to play the CD tracks as MP3 files? I saw something about making a cue file for them, but it didn't say what it had to be named, or the exact format of it.
0

User is offline   fgsfds 

#2

Use this
https://steamcommuni.../?id=1602966657
0

User is offline   Phredreeke 

#3

even though the patents on it have lapsed, open source projects are generally not inclined to support MP3 as it's seen as an inferior format to Ogg Vorbis

This post has been edited by Phredreeke: 23 July 2020 - 10:29 AM

0

User is offline   Rekrul 

#4

 fgsfds, on 23 July 2020 - 05:34 AM, said:


I don't have Steam and I don't intend to install it. I know that's hard to believe, but that's how I feel.

Besides, why does that "fix" come with a copy of DOSBox? I want to run Blood (and the other games) with BuildGDX, not the DOS executables in DOSBox. I've already got them working in DOSBox (except for the opening logos in Blood for some reason).

 Phredreeke, on 23 July 2020 - 10:29 AM, said:

even though the patents on it have lapsed, open source projects are generally not inclined to support MP3 as it's seen as an inferior format to Ogg Vorbis

OK, so how do I set BuildGDX to play the tracks as OGG files?

As an aside, I generally prefer MP3 as I really can't hear a difference most of the time and when I rip the tracks myself, the MP3 files are generally quite a bit smaller than the OGG files. When I ripped the audio tracks on my Tomb Raider disc, OGG came to 54MB, while the MP3s were only 15MB.

And I still need to figure out why the cutscenes don't work...
0

User is offline   Phredreeke 

#5

Set a lower Q value when encoding.

BloodGDX should load them automatically (in place of CD audio) if they're named blood02.ogg to blood09.ogg
0

User is offline   Rekrul 

#6

 Phredreeke, on 23 July 2020 - 11:10 AM, said:

Set a lower Q value when encoding.

BloodGDX should load them automatically (in place of CD audio) if they're named blood02.ogg to blood09.ogg

Thank you, that works. I had them named differently.

What are the required music filenames for the other games?

And the cutscenes still don't work. I have;

cs1.smk
cs1822m.wav
cs2.smk
cs2822m.wav
cs3.smk
cs3822m.wav
cs4.smk
cs4822m.wav
cs5.smk
cs5822m.wav
cs6.smk
cs6822m.wav

In the game directory, but they don't play. I'm using the Polymost renderer. The Classic one doesn't work for me, it just gives me a blank screen.

And how are you supposed to set up the three Redneck Rampage games when Rides Again has overlapping files with the main game?
0

User is offline   86232and 

#7

There is already a theme and solution for the game of cutscenes:
Unable to Play Cutscenes
You need to open the file blood.ini and specify the absolute path to the videos.
0

User is offline   Phredreeke 

#8

The SMK and WAV files should be in the MOVIE subfolder in the Blood folder, not in the same folder.

As for RR, there's a seperate button for Rides Again the launcher, use that. Don't try to merge the two!
0

User is offline   Rekrul 

#9

 86232and, on 23 July 2020 - 09:44 PM, said:

You need to open the file blood.ini and specify the absolute path to the videos.

Thank you, that works. :)

 Phredreeke, on 23 July 2020 - 11:47 PM, said:

As for RR, there's a seperate button for Rides Again the launcher, use that. Don't try to merge the two!

You're right, I overlooked that.

I've run into a problem though with Redneck Rampage though...

One of the things I hate in DOS FPS game is the auto-aim, which prevents me from aiming at the targets I want to aim at. When using any kind of modern port, I always turn auto-aim off. This works fine in Blood and Shadow Warrior, but in Redneck Rampage, when I turn off auto-aim, it's almost impossible to hit enemies at any distance with the pistol. I shot at one enemy about 20 times and only hit him once or twice. Even at medium range, half my shots seem to miss.

I'm sure you think I'm just bad at aiming and blaming the game, but the first shotgun enemy is plenty big enough to hit from across the road. besides, I don't have any complaints about trying to hit enemies in the distance in Blood or Shadow Warrior.

Is it like this for everyone else?

Also, the cheats don't work. I type them in, but nothing happens. They work in Blood and Shadow Warrior. And yes, I tried both typing them in by themselves and after pressing "T" like in the other games. Nothing.
0

User is offline   Phredreeke 

#10

You have to type cheats in the console.
0

User is offline   Rekrul 

#11

 Phredreeke, on 25 July 2020 - 05:07 PM, said:

You have to type cheats in the console.

And the key for that would be what?
0

User is offline   Phredreeke 

#12

It can be defined in settings menu
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks not owned by Voidpoint, LLC are the sole property of their respective owners. Play Ion Fury! ;) © Voidpoint, LLC

Enter your sign in name and password


Sign in options