Duke4.net Forums: Release: AMC Fork Update + Patch 3.6.5-x - Duke4.net Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Release: AMC Fork Update + Patch 3.6.5-x  "Interim patches to update to the most recent eduke32 builds"

#1

AMC Fork Update + AMC TC Interim Patch 3.6.5-X

Repository: https://github.com/c...amcfork-revised

Releases: https://github.com/c...vised/releases/

What is this?

This is patch 3.6.5-x for the AMC TC, including updated eduke32 builds and a script patch to fix critical issues.

For the release of 3.6 we forked eduke32 to allow updating to the newest eduke32 revisions while keeping existing features intact, and to raise some limits we were starting to reach
It also alters some hardcoded Duke 3D behavior to allow for greater flexibility in development, and to work around issues which may be difficult to resolve without adversely affecting other Build games.

As such, this repository offers updated builds of said fork, based on the most recent eduke32 from mainline, with all the neat features that come with that, such as sloped sprites and improved mouse aim, as well as many engine fixes.
To make sure that it is compatible with v3.6 of the TC, we also include a maintenance patch to fix critical issues in the CON scripts that would otherwise occur.

The patch itself is released on Github instead of ModDB as it is intended as a rolling release, being updated semi-regularly as improvements are made to mainline eduke32.

Many thanks go to the eduke32 team for their tireless work on improving the engine.

Installation

To install, simply drop the contents of the most recent release zip into your AMC TC 3.6 install folder and rename 'eduke32.cfg' to 'amctc.cfg'.
Renaming the CFG is important because some gamevars that track progress are stored there, and due to internal changes, the config file had to be renamed.

You can of course also compile the binary from source, and instructions to do so are given on the repo. Note that the patch folder will still need to be downloaded to fix critical issues.

What about the original repo?

The original repository for the AMC Fork for 3.6 is still accessible here and is kept available for legacy purposes.
However, the repo was set up shoddily because I didn't know what I was doing, and is basically impossible to maintain.

With the move of eduke32 from SVN to Gitlab, we decided that remaking the repository for the fork was an appropriate step.
5

User is offline   Player Lin 

#2

OH FINALLY...

I can play AMC TC now...thanks for releasing this. :D
0

User is offline   Player Lin 

#3

Found a problem, not sure the old version does happens.

I'm playing Island Facility level on EP2(since savegame won't working so I have start new EP2 game again) now with this version, and found the tank, but for some reasons when I use the tank, in-tank's view never changes, whatever I do it just stuck at one angle, it seems player's angle does change when I check automap but not the actual view angle in the tank.

Before enter the tank: Attached Image: duke0001.png
After enter the tank, it always stuck at this angle:Attached Image: duke0002.png
1

User is online   Jim 

#4

I am in the middle of playing a map, should I finish the map first, and then copy over which file?
0

User is offline   Player Lin 

#5

View PostJim, on 29 June 2020 - 05:37 PM, said:

I am in the middle of playing a map, should I finish the map first, and then copy over which file?


If you have a mission in progress, you should finish it first, the game will save needed data to other files.
Then download this version(fork update + Patch 3.6.5-x), extract it to your 3.6.x game directory(if you want, you can backup the 3.6.x directory first before you overwrote anything), rename the eduke32.cfg to amctc.cfg, and you should be fine.

If your AMC TC version isn't 3.6.x, do not use this version, update your AMC TC to latest 3.6.4 first, then use this engine + 3.6.5-x update.
1

#6

View PostPlayer Lin, on 29 June 2020 - 10:41 AM, said:

Found a problem, not sure the old version does happens.

I'm playing Island Facility level on EP2(since savegame won't working so I have start new EP2 game again) now with this version, and found the tank, but for some reasons when I use the tank, in-tank's view never changes, whatever I do it just stuck at one angle, it seems player's angle does change when I check automap but not the actual view angle in the tank.

Before enter the tank: Attachment duke0001.png
After enter the tank, it always stuck at this angle:Attachment duke0002.png

This indeed sounds like an oversight on my part with this patch, I'll check and see what the problem is.

Edit: I can't reproduce it on my end currently. Do you remember which maps you played before you got to that point?

This post has been edited by Doom64hunter: 30 June 2020 - 06:05 AM

0

User is offline   Player Lin 

#7

View PostDoom64hunter, on 30 June 2020 - 05:53 AM, said:

This indeed sounds like an oversight on my part with this patch, I'll check and see what the problem is.

Edit: I can't reproduce it on my end currently. Do you remember which maps you played before you got to that point?


Big Trouble in China > Secret Dojo > The Wharf > Offshore Oil Rig

Yeah, I found both secret missions and completed them.

EDIT : I finished them when I still on 3.6.4, so I start the Island Facility via the base's mission select menu after updated to 3.6.5-x and start a new EP2 game.

EDIT 2 : I did drove the hoverboat before I drive the tank, but the hoverboat works very well, not sure if it cause something wrong to the tank.

This post has been edited by Player Lin: 30 June 2020 - 07:14 AM

0

#8

I was able to reproduce the problem now. It definitely has something to do with the boat, as the tank's view is always locked in the direction the boat is facing.

Try reentering the boat and EDIT: move it out of the cave, then reenter the tank. I think it has something to do with proximity but I'm not sure.

This post has been edited by Doom64hunter: 30 June 2020 - 09:01 AM

0

User is offline   Player Lin 

#9

View PostDoom64hunter, on 30 June 2020 - 08:56 AM, said:

I was able to reproduce the problem now. It definitely has something to do with the boat, as the tank's view is always locked in the direction the boat is facing.

Try reentering the boat and EDIT: move it out of the cave, then reenter the tank. I think it has something to do with proximity but I'm not sure.



I go back to the boat and move it out the cave, drive it back the other side and go back to tank, sadly the tank's view still stuck at where the boat facing. :(
0

#10

Patch 3.6.5-2 Released

Release: https://github.com/c...es/tag/v3.6.5-2

Download both the appropriate binary (64 bit or 32 bit depending on your system) and the patch and again overwrite the existing files.

Changelog:
  • Added shortcuts for mapster32 for 2D and 3D mode, including a number of key combinations to facilitate sprite sloping. (by oasiz)
    (see the files `event_keys2d.m32` and `event_keys3d.m32` for documentation)
  • 3D Mode key combination [ ' + Y ] turns tile selection background purple to better distinguish black tiles.
  • Expand tile categories for mapster32.
  • Fixed a bug where driving a Tank after using another vehicle could lock your camera view in place. (@Player Lin this fixes your issue)
  • Fixed bike freelook mode (toggle by hitting the "quick-kick" button while on a bike)
  • Fix bug where x64-2 level transition would not work.
  • Disable detection and reading of duke3d grp


This post has been edited by Doom64hunter: 02 July 2020 - 12:52 PM

3

User is offline   Player Lin 

#11

View PostDoom64hunter, on 02 July 2020 - 12:47 PM, said:

[*] Fixed a bug where driving a Tank after using another vehicle could lock your camera view in place. (@Player Lin this fixes your issue)



Yeah, it seems fixed the tank problem now I can play again. (Since savegame still not compatible so I have start new game again~)
0

User is offline   Player Lin 

#12

Now I have other problem...

Attached Image: duke0000.png

I'm on Ghost Ship's final boss(es?), sadly, after the "big boss" appears, my fps counter starts went badly...it went totally unplayable(<1 fps) when Balgaar appears...the worst value I ever see is "5120 ms, 0.2 fps"(I can't take screenshot when the game just totally slideshow) before my game went messed up and have to restart the level again...

This boss is worse than that poor Polymer...:P


EDIT: Try again, and went to inside the ship(guess was got killed so it restarts), game still went totally slideshow but the boss dies and complete the level...cutscene runs but still in slideshow...(got 16872.7ms 0.1fps before level ends and character select screen shows up, then back to normal...taken the fps counter with my cellphone when in ending cutscene...)

Attached Image: DSC_0090.JPG


EDIT 2 : Go to NEW L.A., found this weird ATM will "flashing" its textures, I know this thread may not fit for report this problem but still...just post it.
Attached Image: duke0003.png
Attached Image: duke0004.png

This post has been edited by Player Lin: 03 July 2020 - 11:10 PM

1

#13

View PostPlayer Lin, on 03 July 2020 - 10:42 PM, said:

Now I have other problem...

Attachment duke0000.png

I'm on Ghost Ship's final boss(es?), sadly, after the "big boss" appears, my fps counter starts went badly...it went totally unplayable(<1 fps) when Balgaar appears...the worst value I ever see is "5120 ms, 0.2 fps"(I can't take screenshot when the game just totally slideshow) before my game went messed up and have to restart the level again...

This boss is worse than that poor Polymer...:P


EDIT: Try again, and went to inside the ship(guess was got killed so it restarts), game still went totally slideshow but the boss dies and complete the level...cutscene runs but still in slideshow...(got 16872.7ms 0.1fps before level ends and character select screen shows up, then back to normal...taken the fps counter with my cellphone when in ending cutscene...)

Attachment DSC_0090.JPG


EDIT 2 : Go to NEW L.A., found this weird ATM will "flashing" its textures, I know this thread may not fit for report this problem but still...just post it.
Attachment duke0003.png
Attachment duke0004.png

Odd, I think the boss problem is because of the HUD elements that are being drawn. From the looks of it, it seems to have drawn multiple health bars.

My current theory is that in certain cases it keeps redrawing additional health bars, thus slowing the game down to a crawl.

Edit: Do you happen to have a save on Ghost Ship where the issue occurs?

This post has been edited by Doom64hunter: 04 July 2020 - 02:26 AM

0

User is offline   Player Lin 

#14

View PostDoom64hunter, on 04 July 2020 - 12:06 AM, said:

Edit: Do you happen to have a save on Ghost Ship where the issue occurs?


Yeah, I still have my all Ghost Ship saves(didn't overwrote them in case you needed), but since I forgot which one is so I just pack them all...

https://sites.google...3_savegames.zip
only one save is before the final boss, two for in-battle, ~3x% boss HP, one save just seconds before I take my first screenshot.

(Seriously, I hope EDuke32 should shows some savegame date/time/actual filename info, not just only episode/level name which just pointless if I forgot place better name on my savegames and days later I forgot which one was... :unsure:)

0

#15

Patch 3.6.5-3 Released

Download: https://github.com/c...es/tag/v3.6.5-3

Only the patch itself was updated this time, the binary is still the same as before.

Changelog:
  • Fixed transparent background of tiles so that they again appear as pink in mapster32. Thanks to Kyanos for providing the fix!
  • Fixed bugs with horse movement (stopping on water, lightspeed backpedal)
  • Fixed camera view getting locked in place when using another vehicle before switching to the Horse.
  • Fix game freeze when returning to base with the nailgun equipped.
  • Fixed boss fight health bars showing up incorrectly during Ghost Ship fight.
  • Fixed framerate drop during Ghost Ship Part 2 boss fight.

The FPS drop was caused by particles of the main cannon not disappearing properly.
Since this was not an issue in the original release, it's probable that some eduke32 revision changed the collision of these particles.
1

User is offline   Player Lin 

#16

Thanks for fixing but since update scripts caused the savegame won't be compatible so I have to wait until I finished Zeta Base mission.
0

User is offline   DougQuaid 

#17

another issue, when using the gun vending machine in shooting range in base with certain characters (highwire, zaxtor, maybe others), the game freezes
1

#18

View PostDougQuaid, on 05 July 2020 - 09:52 PM, said:

another issue, when using the gun vending machine in shooting range in base with certain characters (highwire, zaxtor, maybe others), the game freezes


Fixed, will be part of the next patch.

This post has been edited by Doom64hunter: Yesterday, 05:37 AM

0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks not owned by Voidpoint, LLC are the sole property of their respective owners. Play Ion Fury! ;) © Voidpoint, LLC

Enter your sign in name and password


Sign in options