Duke4.net Forums: keybind resets - Duke4.net Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

keybind resets

User is offline   Lazy Dog 

#1

eduke resets keybinds to it's defaults if they're bound to nothing, could this be disabled? is annoying. there's too many useless keys (keyboard look keys for example)
i'd like to be able to set my binds the way i want without the program resetting things.
0

User is online   NightFright 

  • The Truth is in here

#2

Right now the only workaround is to bind useless functions to keys you don't use and/or don't interfere with your useful keys. Still I agree it should be possible to just have unassigned keybinds.
1

User is offline   Rimantas 

#3

What about autoexec.cfg with "unbind all" command and your binds? I don't know would it work since i use xDuke port and didn't encounter such problem. Fitzquake have different problem with cfg - it does not save some options to it, so i put them to autoexec. Also vanilla Quake 2 does not save "gl_round_down 0".
0

User is offline   Lazy Dog 

#4

View PostRimantas, on 18 March 2019 - 05:57 PM, said:

What about autoexec.cfg with "unbind all" command and your binds? I don't know would it work since i use xDuke port and didn't encounter such problem. Fitzquake have different problem with cfg - it does not save some options to it, so i put them to autoexec. Also vanilla Quake 2 does not save "gl_round_down 0".


doesn't work, autoexec.cfg doesn't get executed on start, you have to manually execute it every time you launch the game
0

User is online   Mark 

  • Honored Donor

#5

I've been using a custom autoexec.cfg file in all my projects for years. It runs as expected at start time. I never tried using it for key binding though.

This post has been edited by Mark: 18 March 2019 - 06:38 PM

1

User is offline   Lazy Dog 

#6

View PostMark, on 18 March 2019 - 06:37 PM, said:

I've been using a custom autoexec.cfg file in all my projects for years. It runs as expected at start time. I never tried using it for key binding though.


You're right, i just tested with disabling vsync from autoexec.cfg, you can also bind keys from it and it works

But the key reset happens AFTER autoexec.cfg is executed, so putting unbindall in it is useless. :wallbash:

the reason i said autoexec.cfg didn't work was because i only put unbindall in it :P

This post has been edited by Lazy Dog: 18 March 2019 - 07:31 PM

0

User is offline   Rimantas 

#7

Can you bind a key with command to execute cfg with binds? It will not get reset since it's not bound to nothing.
1

User is offline   Lazy Dog 

#8

View PostRimantas, on 19 March 2019 - 02:10 AM, said:

Can you bind a key with command to execute cfg with binds? It will not get reset since it's not bound to nothing.


can be done, but at this point is more trouble than it's worth. i just bound every useless key to keypad9. still think the key reset needs to go :angry:

This post has been edited by Lazy Dog: 19 March 2019 - 07:51 AM

0

User is online   Mark 

  • Honored Donor

#9

I haven't followed this issue closely. Was this an intended feature the devs put in and if so, what was the reason? Or has it been officially labeled a bug to be taken care of later?
0

User is offline   Lazy Dog 

#10

View PostMark, on 19 March 2019 - 07:53 AM, said:

I haven't followed this issue closely. Was this an intended feature the devs put in and if so, what was the reason? Or has it been officially labeled a bug to be taken care of later?


TerminX asked how this interfere

If it's a feature, there should be an option to turn it off

This post has been edited by Lazy Dog: 19 March 2019 - 08:24 AM

0

User is online   NightFright 

  • The Truth is in here

#11

For me this is actually hands down THE most annoying thing in current builds. There's nothing I hate more than having to rebind my keys with every launch of the game. I dunno what was the idea behind the change, but I am afraid I cannot see anything positive in this "feature".
0

User is offline   TerminX 

  • el fundador

  #12

I will be working on a fix for this soon.
1

User is offline   TerminX 

  • el fundador

  #13

r7442
1

User is online   NightFright 

  • The Truth is in here

#14

Unfortunately not fixed for me yet even with the new snapshot. Besides that, the game always defaults to software renderer, both in the launcher and ingame. Even if you choose OpenGL in the launcher, ingame it's set to Classic and you need to change it a second time. With next launch of EDuke32, it's the same thing again.

Discard. During an earlier attempt to preserve my settings, I had set my cfg files to read only. After undoing that, everything works just fine now. Thanks a lot, TerminX!

This post has been edited by NightFright: 20 March 2019 - 04:56 AM

0

User is offline   Lazy Dog 

#15

Thanks for the fix!
0

User is offline   TerminX 

  • el fundador

  #16

Np guys, glad the fix is sufficient.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks not owned by Voidpoint, LLC are the sole property of their respective owners. Play Ion Fury! ;) © Voidpoint, LLC

Enter your sign in name and password


Sign in options