Duke4.net Forums: eDuke32 (w/ DukePlus mod) hangs from time to time - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

eDuke32 (w/ DukePlus mod) hangs from time to time

User is offline   240-185 

  • 2

#1

I noticed that latest versions of eDuke32 hang if the application tries to load the next level from episode 3 and onward. First two episodes and custom levels play fine. This only occurs with DukePlus enabled, so I don't know whether it is related to DukePlus or not, as the latest version was released 2 years ago.
This was tested with several .CON files: the bad ones from JonoF's era, from a version that was, erm, obtained somewhere, the correct ones from GoG, and the ones from World Tour Edition.

I can't provide anything from the crash log as the application can't detect anything wrong. However, in "eduke32.log", I can see that the last line was cut abruptly, such as for example: "Load tile 884: p0-m0-…", meaning eDuke32 seems to enter into an infinite loop at some point.

Also, eDuke32 hangs more rarely ingame, showing the same defects as stated above.

This post has been edited by 240-185: 12 January 2019 - 09:08 AM

0

User is online   Trooper Dan 

  • Duke Plus Developer
  • 3,316

#2

View Post240-185, on 12 January 2019 - 09:05 AM, said:

I noticed that latest versions of eDuke32 hang if the application tries to load the next level from episode 3 and onward. First two episodes and custom levels play fine. This only occurs with DukePlus enabled, so I don't know whether it is related to DukePlus or not, as the latest version was released 2 years ago.
This was tested with several .CON files: the bad ones from JonoF's era, from a version that was, erm, obtained somewhere, the correct ones from GoG, and the ones from World Tour Edition.

I can't provide anything from the crash log as the application can't detect anything wrong. However, in "eduke32.log", I can see that the last line was cut abruptly, such as for example: "Load tile 884: p0-m0-…", meaning eDuke32 seems to enter into an infinite loop at some point.

Also, eDuke32 hangs more rarely ingame, showing the same defects as stated above.


DukePlus has its own set of CON files. It's not even possible to be using DukePlus with a set of CON files from JonoF's era etc. It could be that you have them in your folder but if DukePlus is actually working then those CONs were not loaded.

I hope someone will look into this since that mod worked for years without crashing on map loads until now, and this is probably indicative of a general problem.

When you say "latest versions" of EDuke32, how far back have you gone? The devs are more likely to look into this if a specific revision that caused the break can be identified.
0

User is offline   240-185 

  • 2

#3

I downloaded each week of this December the latest build of eDuke32 (back from when it displayed a banknote instead of the nuclear symbol when loading a level)
I had downloaded the version released prior Xmas and my main rig has currently the build from the 11th of January. Before that, I think I had a build from August 2018, but I am afraid I can't help more :/

I also have a GPD Win 2 on which I encounter the same problems. Therefore, this is why I could rule out a hardware-related issue.

This post has been edited by 240-185: 12 January 2019 - 04:09 PM

0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners. Instead of reading this text, you could be playing Ion Maiden! ;) © 2018 Voidpoint, LLC

Enter your sign in name and password


Sign in options