Duke4.net Forums: Jittery vsync - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Jittery vsync

User is offline   Drac Snackem 

  • 0

#1

Love this port. I have a problem where turning on vsync creates a jittery framerate that seems to skip several frames at a time. I've tried all video settings and framerate caps and they all seem to exhibit the same problem.

And I can't seem to force a smooth framerate using external limiters or NVIDIA control panel settings, either. No vsync and it's fine but the screen tearing can be pretty bad.
0

User is offline   Devon 

  • 11

#2

View PostDrac Snackem, on 10 January 2019 - 12:04 AM, said:

Love this port. I have a problem where turning on vsync creates a jittery framerate that seems to skip several frames at a time. I've tried all video settings and framerate caps and they all seem to exhibit the same problem.

And I can't seem to force a smooth framerate using external limiters or NVIDIA control panel settings, either. No vsync and it's fine but the screen tearing can be pretty bad.



i would recommend using the ingame framerate limiter and then use borderless program to get it to run in proper windowed fullscreen,

Runs like a dream when i do this.
0

User is offline   VGA 

  • 14

#3

Devon, what is your screen refresh rate and what limit did you set?
0

User is offline   Drac Snackem 

  • 0

#4

For some reason I get screen tearing with or without borderless windowed or fullscreen. The frame limiter only causes tears to happen at different frequencies.
0

User is offline   Drac Snackem 

  • 0

#5

Don't know how helpful it is, but most of my problems seemed to be alleviated by running the game borderless AND running it at a sub-desktop resolution. So running it in 1600x900, where my desktop is visible beneath the game window, seems to fix 90% of the stutters I was experiencing.

I also set up as second monitor the day before trying this, but I don't know what effect that might have if any.
0

User is offline   Devon 

  • 11

#6

View PostVGA, on 11 January 2019 - 08:56 PM, said:

Devon, what is your screen refresh rate and what limit did you set?



60hz screen.

And i have fps limit set to off.

Also i dont use bloodgdx borderless option as it does not work for me. i have to use the borderless gaming program instead.
0

User is offline   TerminX 

  • el fundador
  • 5,558

  #7

Try asking Zaxx; I hear he is a big fan of BloodGDX and an expert on V-SYNC.

EDuke32 wiki svn builds bugs
Join us in #eduke32 on irc.freenode.net!
0

User is online   m210 

  • 529

#8

Drac Snackem
http://m210.duke4.ne...dGDX_2019b5.jar
Can you try this version?

Devon
Borderless mode should looks like on the screenshot. Are you have other?

Attached File(s)

  • Attached File  sss.png (82.7K)
    Number of downloads: 12


M210 Projects - My personal site

BuildGDX
0

User is offline   HenitoKisou 

  • 4

#9

View Postm210, on 18 January 2019 - 04:14 AM, said:

Drac Snackem
http://m210.duke4.ne...dGDX_2019b5.jar
Can you try this version?

Whoa! I don't know what you did but that version fixed these open area lags/ROR freezes. ;p
0

User is online   m210 

  • 529

#10

View PostHenitoKisou, on 19 January 2019 - 06:41 AM, said:

Whoa! I don't know what you did but that version fixed these open area lags/ROR freezes. ;p

Hm, ok :)
Btw, this is a release condidat, maybe I will release it soon

M210 Projects - My personal site

BuildGDX
0

User is online   Zaxx 

  • 468

#11

View PostTerminX, on 17 January 2019 - 10:01 PM, said:

Try asking Zaxx; I hear he is a big fan of BloodGDX and an expert on V-SYNC.

Frametime judder still happening in Ion Maiden btw...

Anyway don't use vsync for BloodGDX since it's pretty broken. Borderless fullscreen might work but get ready for additional input lag. Best solution from my experience (if your PC can handle it but it should since Blood is old as balls): use native fullscreen mode and lock your fps to a very high value (something like 240-300), that way you won't see screen tearing and the game will run smooth.
0

User is offline   Drac Snackem 

  • 0

#12

View Postm210, on 18 January 2019 - 04:14 AM, said:

Drac Snackem
http://m210.duke4.ne...dGDX_2019b5.jar
Can you try this version?

Devon
Borderless mode should looks like on the screenshot. Are you have other?


Sorry I didn't get back to you sooner, that link is dead but I assume its the newest update. I tried it and I still have the same issues, where fullscreen and borderless at 1080p, with vsync on, there's an odd jutter that seems to be tied to turning or rounding corners, but I can't say that for certain. Without v-sync, even on borderless at 1080p, theres tearing that turns into a funhouse warping at uncapped framerates (2000-3000fps uncapped).

It's only when I run it windowed at lower than 1080p that I don't get any tearing. I figure my configuration must be weird.
0

User is offline   Mr. Death 

  • 5

#13

View PostDrac Snackem, on 22 January 2019 - 02:14 AM, said:

Sorry I didn't get back to you sooner, that link is dead but I assume its the newest update. I tried it and I still have the same issues, where fullscreen and borderless at 1080p, with vsync on, there's an odd jutter that seems to be tied to turning or rounding corners, but I can't say that for certain. Without v-sync, even on borderless at 1080p, theres tearing that turns into a funhouse warping at uncapped framerates (2000-3000fps uncapped).

It's only when I run it windowed at lower than 1080p that I don't get any tearing. I figure my configuration must be weird.

I have the exact same issue w/ v-sync as you Drac. It almost seems like it's a texture caching/streaming problem when v-sync is enabled. Just like you said, turning corners & entering new areas causes the game to stutter, but once everything loads in it becomes smooth again...until you round the next corner. For some reason this problem doesn't exist when v-sync is turned off.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners. Instead of reading this text, you could be playing Ion Maiden! ;) © 2018 Voidpoint, LLC

Enter your sign in name and password


Sign in options