Duke4.net Forums: Eduke32 missing original 320x200 video mode on software renderer - Duke4.net Forums

Jump to content

Hide message Show message
Welcome to the Duke4.net Forums!

Register an account now to get access to all board features. After you've registered and logged in, you'll be able to create topics, post replies, send and receive private messages, disable the viewing of ads and more!

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Eduke32 missing original 320x200 video mode on software renderer

User is offline   gaula92 

  • 3

#1

Hi there,

I am trying (again) to build a satisfactory version of Eduke32 for the Raspberry Pi3.
The Pi3 should be perfectly capable of silk-smooth 60fps *if no software scaling is used* (that's why the Pi3 has an adequate GPU!)
Take into account that SDL2 on the Pi is ALWAYS fullscreen. There's nothing like a windowed mode: it runs on the SDL2 KMSDRM driver, no X server involved. So setting a windowed mode will simply make SDL2 upscale in hardware whatever window size we want to the physical resolution in use.
As things are:
-I have to set ScreenMode=1 on the eduke32.cfg. Setting it on the game menu is ignored and Full Screen is disabled on next boot.
-There's no way to tell the game to render to 320x200 and let SDL2 upscale in hardware, as other SDL2 programs do (Doom Retro, SDLPop, etc). It insists on producing hi-res frames: if I try to set a 640x480 video mode, boom! black screen and I have to killall Eduke32 on the SSH session and reboot the system. My guess is that it's trying to free up something it shouldn't be freeing on dynamic screen resolution changes, thus causing the SDL2 KMSDRM driver to go nuts.
-I can force a 640x or 320x mode in eduke.cfg, but then the game only shows a small corrupt graphics band on the upped side of the screen (thicker on 640x).

Thus, I thing screen mode management is utterly broken as things are. I guess most Windows users just use whatever they are thrown at and that's all, for for special cases like devices that only have fullscreen modes and need to disable all software scaling, it's in a very bad shape. Is it somehow fixable, please?
0

User is online   Phredreeke 

  • 222

#2

PCs are generally fast enough to run the software renderer without resorting to lower resolutions.

I recall Hardware scaling being added a few months ago. I have no idea if it works on the Pi though.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks are property of their respective owners. Instead of reading this text, you could be playing Ion Maiden! ;) © 2018 Voidpoint, LLC

Enter your sign in name and password


Sign in options