Duke4.net Forums: KickAss Duke - Duke4.net Forums

Jump to content

  • 4 Pages +
  • « First
  • 2
  • 3
  • 4
  • You cannot start a new topic
  • You cannot reply to this topic

KickAss Duke  "It's out !"

User is offline   Polunka 


Hello once again. I'm starting to think these constant reports may be annoying. If it's the case, tell me and I'll stop posting for some time.

Would like to report glitches found by me recently as well as offer a suggestion. Some glitches you may be aware of, again, and sorry if a double report comes up.

First I'd like to describe the more important bugs.

  • This one is an old glitch from the core game (which should be fixable since I remember it being fixed at least in Alien Armageddon mod): when in the shrunk state, Commanders can regain their usual AI behavior if you do some damage to them. The amount of damage seems random to me, most often it occurs when using explosive weapons on them. Basically, they start going around slicing you and firing rockets at full damage while being tiny as hell, can't grow back, and you can't stomp them, only kill them with regular weapons (their health going back to full). Unsurprisingly, they become a real pain in the ass to deal with. I'm also pretty sure you've come across this bug yourself (tho I might be wrong).
  • A problem with the MTA upgrade for Devastator. It can be reproduced if you play an episode and go between levels. Basically, if you keep the MTA turned on and go to a subsequent level which takes away your weapons at the start, upon picking up the Devastator (without picking up the upgrade) it'll retain the upgrade (while having regular Devastator sprites), and you won't be able to turn it off until having found another MTA upgrade again. I'm not sure if it affects any other upgrades offering switchable fire modes (like Chaingun rotary upgrade).
  • Tazed enemies can't be shrunk normally. Upon taking a shrink blast hit, the enemy will decrease in size only partially. This can be done seemingly twice or thrice, and then they'll stop getting shrunk at all. After that, they can't be shrunk, they'll just retain the decreased size (about twice smaller than normal). It seems to affect all enemies that can be shrunk (hence no small or big bosses, pig tanks and recon flyers, Sentries, Protector Drones or Slimers).
  • This one is sorta connected to the previous glitch. Certain enemies under certain negative effects seem to have shrinking problems: liztroops, pigs and commanders sometimes can't be shrunk while poisoned or on fire. I've noticed that it may have something to do with the damaging effect of fire/poison. Essentially, if a shrink blast hits the enemy exactly at the moment when it receives damage from a respective effect, it does nothing. Liztroops/Captains here are less of a problem cause they die very quickly from fire/poison. Pigs receive damage from fire/poison at a decreased frequency, about the one of Commanders (from what I gather) so there's a better chance of timing the shrinker hit well, so they might not be much of a problem too. In Commanders' case, on the other hand, the aforementioned old glitch comes into play, so they sometimes can't be shrunk at all while on fire/poison, but if you do succeed to initiate the shrinking process, they'll either stop decreasing amid or get shrunk completely and then may or may not regain their usual AI (while poison/fire is still doing damage), the latter resulting in fighting those tiny-but-super-potent assholes again. Also, as far as I've observed, the normal behavior you intended for shrunk enemies on fire/poison is simply get shrunk no matter what and then instantly die from the negative effects (as happens to enforcers and octabrains). So I suppose you would want to make other enemies I mentioned earlier behave this way as well.

Now about the minor things.

  • Ooze shells can still be collected even at full ammo.
  • Hazard Suit and Scuba Gear HUD graphics disappear during keycard insertion animations.
  • Singularity charges can't be fired when Shrinker's mag is empty (unsure if it's a glitch or intentional).
  • Protector Drone limbs create a red blood pool upon fully stopping (see Attachment #1). It doesn't affect heads or those gibs that are present in the vanilla game (eyes/jaws/viscera etc.) Their wall blood splatters are also red with a strange green outline to them (see Attachment #2). On another note, Slimer Eggs' wall blood splatters are also red (I think they are supposed to be green).
  • Green gibs (Slimer Eggs or Protector Drones) leave red blood splatters on walls too.
  • Ooze wall decals (appering from firing Ooze Launcher's alt fire) can be destroyed (they just disappear upon damaging them) and leave red wall blood splatters too.
  • Tripmines can be selected again even if at zero if you have the remote mode set; if you switch to either of the other modes (or use up the last mine in either of those modes), you can't select it again. Also, not sure if it's a glitch but both Tripmines and Proximity Mines remain in the weapon selection HUD even if depleted fully.
  • If you have an uneven photon cell amount in the reserve, firing Battlelord Minigun and depleting the ammo will cause the graphic of ammo reserve to disappear from the HUD, affecting all laser weapons, until you pick up some ammo again (see Attachment #3). Another thing, when trying to reproduce this, the Minigun will stop firing exactly upon ammo dropping to 1, but then you can press and hold the primary fire button again and it will fire the last round left, resulting in the glitch. So, as a side thought, this (and the fact Battlelord Minigun uses 2 rounds per shot) leads me to believe that you shouldn't even be able to fire the one last round at the end.

And the list has finally come to an end.

I also got a suggestion: it would be handy if we could remove installed Tripmines from the walls and take them back like Proximity Mines (when in laser or remote mode, tho it could potentially work with the timed mode too). Also, the ability to install them on floors/ceilings sounds good to me.

Well, that's all so far. Let's hope I won't come across any more glitches in the near future.

Attached thumbnail(s)

  • Attached Image: duke0014.png
  • Attached Image: duke0013.png
  • Attached Image: duke0012.png

This post has been edited by Polunka: 06 August 2020 - 10:57 PM



Keep up, Polunka, your reports are precious and useful.

This time the only known bug was about green/red blood splats; all shrink-related were unknown at all, instead.

User is offline   Polunka 


Alright. Glad to be of service here. :)

User is offline   Polunka 


Hello again. Time for another report (which I really hope will be the last until v2 has seen the light since I feel I've reported a lot already).

I'm reluctant to split the findings into categories based on their significance this time so I'll just provide the full list as a whole (it's not that big this time, anyway ;) ).

First one is about tazed states again. Recently I found out you've made Sentry Drones prone to being taze-stunned. While so, they still detonate in proximity in spite of being tazed; I'm not entirely sure if that was your actual intention or not but I guess mentioning this nuance won't hurt.
Another thing I've found is, Protector Drones can't be tazed while in their dormant state (you know, when they float slightly above the ground, arms crossed, and can't do shit until getting damaged or after some time in case of having been spawned by a Queen). The taze dart fired at such a drone only slaps it out of the said dormant state and then you can actually taze them like any other enemy which doesn't have taze immunity. So, essentially, if you try to taze a dormant proctector drone, you end up wasting one dart.

Second is about a problem with switching between firemodes for the shotgun and the thermal tool. If you try to switch over from certain firemodes when at zero ammo for them to certain other ones when the latter have ammo left, you may end up accidentally firing a round of the one you've switched to.
Basically: try to drop your regular shells in the shotgun to zero (as in, zero shells left in the mag, not in the whole reserve) and then switch to any other firemode. If you press the fire button in this case (when choosing the latter firemode) for too long, you end up firing a special round (most likely) in vain. It seems to happen almost simultaneously with choosing the firemode (there isn't even an animation of loading a special round playing, it just fires right away; same shit for the thermal tool - sprite swap is simultaneous, no animation of changing firemodes in any way).
For the shotgun, it happens only if you switch from zero regular shells to any other firemode with some ammo left. For the thermal tool, it happens only while switching from zero flamethrower/freezer to any other mode with some ammo left (laser cutter doesn't cause this since its ammo can't really drop to zero).
Also, to clarify the italicized "too long" - the difference between the duration of fire button press needed for firing accidentally and of that to avoid firing is really subtle but it can be achieved. Basically, a moderately light tap of LMB does the trick. This also leads me to believe that the main problem here is the absence of the firemode change animations, so the game just swaps firemode in no time and proceeds to take the command to fire while you're still pressing the button.
This glitch could also affect RPG but I did not encounter anything while testing it.

Third is about not being able to lock onto "sleeping" monsters with the RPG lock-on mode. Not sure if it's a glitch or intentional, once again.

The last but not the least is glitchy "allies". By allies I mean the mini-protector drone and the turret. They seem to be broken. While the drone is not as broken (sometimes it seems not to react to enemies properly but this could be just me), the turret is almost completely useless at this stage. After firing for some time (usually a short period) at some enemies, it just stops reacting to anything and goes spinning around its stand for eternity. I tried to understand what causes this and did some testing but to no avail, so I leave it to you as the developer. Another thing I (accidentally) managed to find is, if an enemy has been targeted by a turret and gets crushed (you know, when the Squished! message appears), the turret will keep firing at the spot where the enemy was crushed (a door, for example) infinitely. I could suppose this actually happens only when doors crush monsters and turrets just keep targeting the stretchy meat sprites that remain after the crushed enemies; I'm not sure, however, whether those stretch sprites also appear when an enemy gets crushed in other geometry and not by a door.

This is all so far. I'll post another time when I gather enough info for a report again. Keep up the good work on the mod :)

This post has been edited by Polunka: 02 September 2020 - 07:14 PM



Name: Polunka
Profession: Reporter XD

Well, thank You again for such dedication !

What i can say about the issue you mentioned here:

- Making the Sentry Drone unable to detonate while tazed is a nice (and logical) addition i was just not aware of
- I was not aware of the issue when tazing dormant Protector Drones, it surely involves the AIs / actions
I also found that when they are damaged while stunned (in normal form) they stand still indefinitely when tazing effects ends, and they resume their behaviour if they are damaged again.
Little addition: i'm going to add damage over time to "tazed" effect, for balancing reasons.

- I was aware of fire/selection issue, i just forgot infinite times to fix it :)

- "Allies" have very old code, like many parts of this mod ( 2012ish ); i was not aware of such bugs, despite i've tested them so much at that time, but maybe Eduke updates broke something with time, too.

In the meantime I have already fixed many of the bugs you reported before, and I'm also going to make a full refresh to KADuke code, mainly for shorter forms, syntax optimization and use of newer CON commands.


Hey, i dont know if the mod is still active but it crashes will tring to use the last eduke32 release

Attached thumbnail(s)

  • Attached Image: Captura.PNG


User is online   Jimmy 

  • Let's go Brandon!


Use an older release of EDuke32.

User is offline   Polunka 


Yea, as far as I know (ain't tried otherwise), the most compatible EDuke build must be the one supplied by the author along with the mod. You could try and see if any further releases actually work without breaking anything, tho.


Or you could try fixing the error. You cannot define a variable that starts with a digit, this never worked correctly.

Fixed CON files, place these in the folder and the game will run:

Attached File  KickassDuke_1.12_fixedCONs.zip (113.51K)
Number of downloads: 76


View PostPolunka, on 22 December 2021 - 06:45 PM, said:

Yea, as far as I know (ain't tried otherwise), the most compatible EDuke build must be the one supplied by the author along with the mod. You could try and see if any further releases actually work without breaking anything, tho.

Definitely yes, Eduke changes often and older mods are likely to not work properly, as they were designed with the release shipped with them

View PostDoom64hunter, on 30 December 2021 - 10:28 AM, said:

Or you could try fixing the error. You cannot define a variable that starts with a digit, this never worked correctly.Fixed CON files, place these in the folder and the game will run: Attachment KickassDuke_1.12_fixedCONs.zip

I thought KADuke was totally rid of that mistake since ages, can you tell me which var(s) started with a digit ?

Share this topic:

  • 4 Pages +
  • « First
  • 2
  • 3
  • 4
  • You cannot start a new topic
  • You cannot reply to this topic

All copyrights and trademarks not owned by Voidpoint, LLC are the sole property of their respective owners. Play Ion Fury! ;) © Voidpoint, LLC

Enter your sign in name and password

Sign in options