Duke4.net Forums: Jitter/Judder on non-Gsync screen - Duke4.net Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Jitter/Judder on non-Gsync screen

User is offline   GemaH 

#1

I had this issue a couple of years ago so i decided to try again with the latest version of eduke3d. But it's still not smooth on my regular, 60hz TV.

On the 240hz gsync monitor is 100% smooth.

So the problem is that on the regular TV there are "jitters". These are not frame rate drops or stutters. The game reports 60fps without drops via RTSS. And yet, despite that, there are some specific parts on the first map where i can see the frame rate going bonkers.

For instance, the room inside the Cinema, that has the small room where you get the shotgun and the cashier. Opposite of the cashier there is a wall with a poster. If i circle strafe around that wall, targeting the poster, i get intense judders. There are other parts of the map where this happens. It also happens randomly sometimes but these specific parts of the map are bad. And no, it's not a performance issue, my GPU/CPU usage is below 10% when running this.

I tried every vsync option, frame rate limit, video setting, NVIDIA driver setting, etc. It's always the same.

If i use some other client like Raze, the game runs perfectly. Only eduke3d has this issue.

This post has been edited by GemaH: 08 July 2021 - 04:43 AM

0

User is offline   Mr. Death 

#2

View PostGemaH, on 08 July 2021 - 04:27 AM, said:

I had this issue a couple of years ago so i decided to try again with the latest version of eduke3d. But it's still not smooth on my regular, 60hz TV.

On the 240hz gsync monitor is 100% smooth.

So the problem is that on the regular TV there are "jitters". These are not frame rate drops or stutters. The game reports 60fps without drops via RTSS. And yet, despite that, there are some specific parts on the first map where i can see the frame rate going bonkers.

For instance, the room inside the Cinema, that has the small room where you get the shotgun and the cashier. Opposite of the cashier there is a wall with a poster. If i circle strafe around that wall, targeting the poster, i get intense judders. There are other parts of the map where this happens. It also happens randomly sometimes but these specific parts of the map are bad. And no, it's not a performance issue, my GPU/CPU usage is below 10% when running this.

I tried every vsync option, frame rate limit, video setting, NVIDIA driver setting, etc. It's always the same.

If i use some other client like Raze, the game runs perfectly. Only eduke3d has this issue.

This sounds like the same issue reported here in this thread: https://forums.duke4...ing-megathread/

The only way I've found to fix this issue is to set the frame rate limiter to the same value as your current refresh rate. My monitor is 75hz, so with vsync enabled and frame rate limiter set to 75 the frame rate smooths out and the stutters/jitters go away.

I hope that helps!
0

User is offline   GemaH 

#3

Even if i set the frame rate limiter to 60, the game has these weird internal stutters that don't get pick up by any frame rate counter like RTSS.

Even if i lock the frame rate with RTSS, the frame pacing issues remain.

Thing is, other games that use eduke32 also have janky frame pacing on my 60hz TV. Ion Fury has similar issues but not as bad, probably because it uses a different version, dunno.

Raze runs all build games with perfect frame rate/pacing on both of my screens so i ditched eduke and using that.
0

User is offline   doubletap 

#4

View PostGemaH, on 16 July 2021 - 04:44 AM, said:

Even if i set the frame rate limiter to 60, the game has these weird internal stutters that don't get pick up by any frame rate counter like RTSS.

Even if i lock the frame rate with RTSS, the frame pacing issues remain.

Thing is, other games that use eduke32 also have janky frame pacing on my 60hz TV. Ion Fury has similar issues but not as bad, probably because it uses a different version, dunno.

Raze runs all build games with perfect frame rate/pacing on both of my screens so i ditched eduke and using that.


for me that jittering / jumping resulted from vsync on, but only in earlier eduke versions. for the steam version, vsync on turns the game to be virtually unplayable. with vsync off, theres no jittering anymore. make sure your nvidia control panel is using vsync mode to be determined by the application. latest eduke must have had vsync improvements that cured this for me, too. try using kmt or adaptive vsync or use vsync off. i get best results with kmt and fps limit matching refresh rate, e.g. 60 fps @ 60 hz. id recommend adding 2/3 fps on top of the fps limit to saturate triple buffering and pre-rendered frames if you have it, e.g. fps max 63 for 60 hz display. you can also try set r_glfinish 0. higher fps limit also improves vsync behaviour, e.g. 240fps or something.

but your issue is something else. run the game with borderless and turn off detail textures and 3d models. what you described at the cashier and other areas on the map is exactly that, ive had that, too. its worst with polymer, dynamic lights, detail textures and 3d models. all of that should be avoided and you get full performance. you will still get better textures with hrp or other packs, just dont use the detail textures on setting, that and the 3d models will crush performance.

This post has been edited by doubletap: 18 July 2021 - 12:41 PM

0

User is offline   GemaH 

#5

View Postdoubletap, on 18 July 2021 - 12:05 PM, said:

for me that jittering / jumping resulted from vsync on, but only in earlier eduke versions. for the steam version, vsync on turns the game to be virtually unplayable. with vsync off, theres no jittering anymore. make sure your nvidia control panel is using vsync mode to be determined by the application. latest eduke must have had vsync improvements that cured this for me, too. try using kmt or adaptive vsync or use vsync off. i get best results with kmt and fps limit matching refresh rate, e.g. 60 fps @ 60 hz. id recommend adding 2/3 fps on top of the fps limit to saturate triple buffering and pre-rendered frames if you have it, e.g. fps max 63 for 60 hz display. you can also try set r_glfinish 0. higher fps limit also improves vsync behaviour, e.g. 240fps or something.


I already tried all of these. There is no change in behavior whatever i do.


View Postdoubletap, on 18 July 2021 - 12:05 PM, said:

but your issue is something else. run the game with borderless and turn off detail textures and 3d models. what you described at the cashier and other areas on the map is exactly that, ive had that, too. its worst with polymer, dynamic lights, detail textures and 3d models. all of that should be avoided and you get full performance. you will still get better textures with hrp or other packs, just dont use the detail textures on setting, that and the 3d models will crush performance.


I'm getting these stutters even with the classic renderer. It's like whatever i do, there is no difference.

Which is why i'm suspecting this has something to do with the analog stick handling. I feel like eduke looks smoother if i don't use a controller.

But anyway, the solution for me was switching to Raze.
0

#6

@GemaH: Does your problem look like this?

https://cdn.discorda...19_23-24-31.mp4
0

User is offline   GemaH 

#7

View PostDoom64hunter, on 19 July 2021 - 09:57 PM, said:

@GemaH: Does your problem look like this?

https://cdn.discorda...19_23-24-31.mp4

Yes. It looks exactly like this.
1

#8

View PostGemaH, on 20 July 2021 - 05:43 AM, said:

Yes. It looks exactly like this.

Alright good, then we have identified the commit the problem stems from, and a fix will be coming soon.
0

#9

An interesting aspect to this problem is that, if you launch the map directly through the `-map` parameter, the problem is not observable. Only after you open the main menu does the stutter start.
0

User is offline   GemaH 

#10

View PostDoom64hunter, on 24 July 2021 - 12:01 AM, said:

An interesting aspect to this problem is that, if you launch the map directly through the `-map` parameter, the problem is not observable. Only after you open the main menu does the stutter start.

How do you do that? I mean, what's the full command?
0

User is online   Player Lin 

#11

View PostGemaH, on 24 July 2021 - 02:27 AM, said:

How do you do that? I mean, what's the full command?


eduke32.exe -map <map filename>

Example: eduke32.exe -map e1l1.map, it will load Hollywood Holocaust after eduke32 launches.
(Of course you needed run the command on the eduke32 directory)

I can confirm that...but I still feel something a very, very little off but it's much less notice-able before open the main menu. :unsure:
(It may also explains why Raze has no problem about that, they ditched all old menu code and used their new one, but that's my guess only.)

This post has been edited by Player Lin: 24 July 2021 - 10:52 PM

0

#12

View PostPlayer Lin, on 24 July 2021 - 10:49 PM, said:

eduke32.exe -map <map filename>

Example: eduke32.exe -map e1l1.map, it will load Hollywood Holocaust after eduke32 launches.
(Of course you needed run the command on the eduke32 directory)

I can confirm that...but I still feel something a very, very little off but it's much less notice-able before open the main menu. :unsure:
(It may also explains why Raze has no problem about that, they ditched all old menu code and used their new one, but that's my guess only.)


This effect is observed because the totalclock timer is fixed to ototalclock while the menu is open, which afterwards somehow changes the value computed for smoothratio.

Raze replaced the old Build timer functionality with the one inherited from GZDoom which is very likely why it does not suffer from these problems.
2

User is online   Player Lin 

#13

Okay, so it's about the (buggy?) timer of original Build engine, and the menu just triggered it...good to know that...at least it sounds like fixable, right?
0

#14

Please try r9569 and report whether the effect is still observable.
0

User is online   Player Lin 

#15

I tried with r9570 and I don't see any jittering on that place in E1L1 at all, just smoothing, at least on my end.
0

User is offline   GemaH 

#16

Classic and Polymer seem to be smooth now.

Polymost is juddery but not in particular spots. Just in general.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


All copyrights and trademarks not owned by Voidpoint, LLC are the sole property of their respective owners. Play Ion Fury! ;) © Voidpoint, LLC

Enter your sign in name and password


Sign in options